Denis S

Member
  • Content count

    4
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Denis S

  • Rank
    Newbie
  1. Hey polyxo! Please verify the version of 3D-Coat you are currently using. If it's feasible, please update to the latest 3.5.16. I'm using Win32, Nocuda version on Vista32 for development and testing. This infinite looping in ZBrush after sending mesh to 3DCoat is by design. It's supposed that after sending info to 3DCoat, ZBrush enters kind of "waiting state" until it will get results back from 3DCoat (which is done by pressing "File -> Open in originall app" in 3DCoat). Pressing Esc while ZBrush in waiting state, will cancel whole export-import sequence, and you will be unable to get anything from 3DCoat without re-exporting from ZBrush. Unfortunatelly, in waiting state, ZBrush UI sometimes freezes after Alt-Tab to another window. But inside it's still working and waiting either Esc or results from 3DCoat. I will try to somehow address this issue (maybe it's possible to force ZBrush to redraw it's UI properly after alt-tab), so ZBrush won't look "freezed" when waiting for 3DCoat. Regards, Denis
  2. New Version 03. Please, check release notes in first message.
  3. Hi guys!. Just uploaded new version 0.2. I've temporary disabled 3D-Coat existence check. Basically it was checking all running processes for "3D-COAT" symbols in .exe name. Now the rest of the code will work regardless of this check. But the check itself is still in place and I would be really appreciate if you will attach "3dcoat_link_log.txt" file to your previous posts about this problem (it should be written to your ZBrush root folder). Uncompressed formats support problem is being resolved. I think at least BMP will be usable in near future. About normal map formats: I'm not very familiar with this problem, will do some research about 'maya style' and 'zbrush style' differences. MAC OSX support is planned to be added after resolving most of the issues. Regards, Denis
  4. 3D-Coat to ZBrush AppLink Description: 3D-Coat AppLink functionality for Pixologic ZBrush Version: 0.4 Last Update: 13/04/2011 ################################################################################ Installation: Unzip and run the installer, select your ZBrush folder, press Install. Restart ZBrush. In ZBrush new ZPlugin:3D-Coat subpalette should be available with single button labeled Edit in 3D-Coat.... ################################################################################ Usage: Run ZBrush and 3D-Coat. In ZBrush, go to Edit Mode with some mesh tool. While in Edit Mode, press Edit in 3D-Coat... button in ZPlugin:3D-Coat subpalette. "Export Type" dialog will pop up. Select type of the export with one of the buttons. After a few moments youll see Waiting for 3D-Coat... note in progress bar. Switch to 3D-Coat window. A dialog with options based on your 'Export Type' selection in AppLink script should pop up. Set needed options, hit 'OK' and edit imported mesh to your heart content, using 3D-Coat's rich features for Texture Painting, UV Editing, Retopo and Sculpting. When done, select File ->Open in Originall App from 3D-Coat main Menu. Now go back to ZBrush, there should be Got results from 3D-Coat! note, hit any button to bring edited mesh with textures and maps created in 3D-Coat back to ZBrush, new PolyMesh3D tool will be created and texture maps assigned to the correct tool slots (Texture Map and Normal Map will be assigned, but Specular Map will only be imported into textures list). You can repeat the whole process as many times as needed. ################################################################################ Release notes: Version 04: "Waiting for 3D-Coat" progress bar replaced with explicit "Get results from 3D-Coat" button. AFAIK, it's the only way to fix 'ZBrush GUI freezing after Alt-Tab' issue. Version 03: BMP textures format and Displacement map transfer to/from 3D Coat is working now, but requires 3D-Coat 3.5.16 or later. For correct interpretation of displacement map by ZBrush, you should select "8bit + Zero level is black, normalized + BMP" options in 3D-Coat Export options. UV flipping issues addressed. Only Windows version available so far, no Mac OS AppLink yet. Version 02: To transfer textures from 3D-Coat to ZBrush you should use JPG format. There is some problem with loading 3D-Coat-created TGA/PNG/TIF files by ZBrush. Displacement map transfer from 3D-Coat to ZBrush is not working for now because of the same problem with loading ZBrush alpha from 3D-Coat-created BMP/TIF. ################################################################################ Video Demonstration: ------------------------------------------------------------------------------------------------- //Admin edit ZBrush 4R6 ZAppLink.zip zbrush_applink_04.zip