Andrew Shpagin

3D-Coat 4.7 (Beta testing thread)

690 posts in this topic

I've found a bug with Smooth All in Surface mode. I turn off the option to keep sharp edges that were made by a boolean but it keeps them anyway

 

 

smooth_all.JPG

Share this post


Link to post
Share on other sites

Ok, so I splitted the mesh by elements on 3dsmax, then reimported it on 3dcoat, it worked fine but the curvature took way more time to be computed ( it usually take few seconds, now it took some minutes ). I guess that separate by "connective picking" would lead to that same huge bake time, but that way we could keep our lowpoly's element hierarchy clean, as we dont always need to explode our models and we need sometimes to keep it the way we want in order to have some premade group selections.

Share this post


Link to post
Share on other sites
On 2017-6-15 at 6:11 PM, Carlosan said:

Your graphic drivers are up to date ?

Yep, drivers all up to date.  I can work for an hour maybe then all of a sudden the mouse cursor will freeze and my whole machine will seize up.  This ONLY happens when running these latest beta releases.  

 

I will roll back until I find one where this doesn't happen.

 

*EDIT*

Ok so I've been using version 4.7.29(DX64) on Windows 10 version.  So far so good.  No freezing or hanging PC.

Share this post


Link to post
Share on other sites

I've noticed a bunch of regressions in the scripting model. They pretty much break most of the scripts that worked so far.

http://3dcoat.com/mantis/view.php?id=2296

http://3dcoat.com/mantis/view.php?id=2295

http://3dcoat.com/mantis/view.php?id=2294

There's also been a change in ShowFloatingMessage function which isn't reflected in the documentation. It now accepts three arguments, with the third, a boolean, being the recent addition.

1 person likes this

Share this post


Link to post
Share on other sites

I can't import in surface / sculpt room a mesh higher that 25 millions polys, without a virtual memory error.
I'm on Win7, with 64 go of ram

Share this post


Link to post
Share on other sites

I found a UDIM numbering issue

I import a mesh with 6 udims in retopo room
I bake , then in paint room, the Udims tiles are in wrong order

original udim order :         1001   1002   1003  1004  1005  1006
3dc correponding order :   1006   1005   1004  1002  1003   1001

Share this post


Link to post
Share on other sites
On 6/21/2017 at 6:51 AM, Frimasson said:

I can't import in surface / sculpt room a mesh higher that 25 millions polys, without a virtual memory error.
I'm on Win7, with 64 go of ram

Can you try it, with the layer set in Surface Mode? In voxel mode, the result might be massive.

Share this post


Link to post
Share on other sites
2 hours ago, AbnRanger said:

Can you try it, with the layer set in Surface Mode? In voxel mode, the result might be massive.

The layer was in surface mode.

Share this post


Link to post
Share on other sites
17 minutes ago, Frimasson said:

The layer was in surface mode.

Please let Andrew know about this (support@3dcoat.com), so he can address it. If you can handle 50-100+ million polys in the scene, one should be able to import a similar amount, in surface mode.

Share this post


Link to post
Share on other sites
On 6/19/2017 at 5:47 AM, Allabulle said:

Is there any Linux update in the horizon? 

+1, any news on a new Linux version?  

 

Jason

Share this post


Link to post
Share on other sites
On ‎6‎/‎23‎/‎2017 at 0:53 AM, Grimm said:

+1, any news on a new Linux version?

Currently working on Linux build. By the way, will it be ok if the new build will require latest Linux Ubuntu (particularly 16 and above)? What Linux distros do you have? Please report me directly on my e-mail "support DOT linux AT 3dcoat DOT com".

1 person likes this

Share this post


Link to post
Share on other sites

Email sent, thanks Sergyi!  

Jason

Share this post


Link to post
Share on other sites

E-mail sent, too. Thanks Sergyi!

Edited by Allabulle

Share this post


Link to post
Share on other sites

Hi guys !

I've got an issue that is here since several builds, here it's from the 4.7.24. The issue is about curvature baking on 3dCoat's default Tile plane, it has some artifacts on UVs borders and partially on the half of the texture.

Steps to reproduce :
- open the default tile
- paint on a new layer something which use depth parameter. Paint on seams and paint large
- bake a curvature with its default options
- activate curvature's layer visibility and show up seams, then look close at them
( if it's not clear toggle the "flat shade" mode )

Almost same issue on AO but only on half of the UVs ( bake a default AO and choose Standard Blending mode to see it )

TileIssue.jpg

TileIssue_Spotted.jpg

TileIssue_Spotted_AO.jpg

Share this post


Link to post
Share on other sites