Jump to content
3D Coat Forums
Andrew Shpagin

3D-Coat 4.7 (Beta testing thread)

Recommended Posts

6 hours ago, ajz3d said:

I think something with the primitives' gizmo should also be done. For example, on the following screenshot I'm creating a capsule, and I cannot access most of the manipulator's controls from the orthographic view, because they are all clumped up into singularity. I can move the primitive on two axes all right, but scaling or tweaking its radii is nigh on impossible without rotating the viewport, and zooming in doesn't make things significantly better.

I'm not sure if I'm not mixing 3D Coat and Maya together, but I think there was an option somewhere to increase the manipulator size. Can anyone direct me to it please?

PS. I just noticed that capsule's Cap parameters are not sliders, but input fields instead. It makes tweaking the primitive harder in circumstances mentioned above.

Treat this post as a productivity hint.

screenshot_17-08-29_00_07_22.jpg.c16057b94f3aac61f7da4d9f01e44efc.jpg

That happens when you are zoomed way out. The Gizmo is proportional to the scale of the primitive, as it should be. However, I noticed that even zoomed in, when in orthographic view, some transform widgets are obscured by others. For example, the global scale widget in the center is obscured by the axis scale widget. Andrew really needs to revisit these from an orthographic view, as most modeling will be done from that view.

I know what he will say..."you can make the same transforms from the Tool Options panel." But the problem with that, is, we don't need a work-around. We need the tools that are there, to work properly...not find a detour around the ones that don't.

  • Like 2

Share this post


Link to post
Share on other sites
On 8/27/2017 at 3:45 AM, Carlosan said:

Do you have a proposal to improve it ?

Beyond what was mentioned below?


I could refine the mockups/concept if I felt it actually had some impact. I wont lie, most of the time it feels fruitless. The UI could be streamlined though, a lot can be combined and built to work a cleaner interactive panel.

  • Like 1

Share this post


Link to post
Share on other sites

Dp you mean mimic SPainter ? -as example-

Share this post


Link to post
Share on other sites

Any chance we will see Color ID UV maps this year? I saw that in Trello etc.. this is a request for a few Years now. Sad that it is still not implemented.This is really needed.

  • Like 1

Share this post


Link to post
Share on other sites
On 8/29/2017 at 7:17 AM, AbnRanger said:

That happens when you are zoomed way out. The Gizmo is proportional to the scale of the primitive, as it should be. However, I noticed that even zoomed in, when in orthographic view, some transform widgets are obscured by others. For example, the global scale widget in the center is obscured by the axis scale widget. Andrew really needs to revisit these from an orthographic view, as most modeling will be done from that view.

I know what he will say..."you can make the same transforms from the Tool Options panel." But the problem with that, is, we don't need a work-around. We need the tools that are there, to work properly...not find a detour around the ones that don't.

Sometimes I missed a second undocked view to be able to edit there, while having the second view as a reference. Or a quad view. This might be cool for drafting hardsurface.

  • Like 2

Share this post


Link to post
Share on other sites

Bug on latest 4.7.37P.

Many thanks to Rui Costa that pointed out to me.

When creating a smart material pack with more than 100 (118 to be precise) it creates the pack BUT it doesn't install it back.

I had to brake it to 2 folders , each one with half of materials to be able to re install the exported packs back into 3D Coat.

 

As a side effect , when 3D Coat AUTO creates the preview spheres (copy paste the half materials t a new folder from windows , so i can brake the collection to 2 parts)  it creates them as SQUARES and not with the standard preview sphere.

Once clicked it works fine but icon shows as SQUARE for some reason. 

Minor issue just reporting this as well.

Edited by Michaelgdrs

Share this post


Link to post
Share on other sites
On 9/2/2017 at 4:35 AM, Carlosan said:

Dp you mean mimic SPainter ? -as example-

Not so much SPainter, but a general combining of input fields into one or two context driven panel. The management side of things needs to be updated, especially as more gets added over time (brushes, alphas, matcaps, shaders, categories for each..ect). SP makes it easier for sure, but they also have the problem of displaying too much any one given time. In that sense I would look at Zbrush (and to a minor extent ddo/photosho) with its input areas, which then pop up the resource window for alphas, matcaps..ect

Apparently the new version of Mari is getting a UI upgrade that focuses on pop out panels as well (thank god).

  • Like 1

Share this post


Link to post
Share on other sites

There is a problem with retopology. Also unwrapped UV, saved, made a correction in voxel room, then back, survived again, and got such a bug. In retopo and textured the room all messed up. How to fix? Too much time it will take to do it all over again.

1.thumb.jpg.50bde15825b81697b1838f4f0bccbadd.jpg

 

Share this post


Link to post
Share on other sites

Zoom out UVpreview and try to find faces outside UV Preview square box limits.

 

 

UVpreview.jpg

  • Like 2

Share this post


Link to post
Share on other sites

No, it's not. Earlier there was such problem in 3dsmax, all polygons stretched across the stage, same thing here

2.thumb.jpg.3054db35afe8c421196b64c08d9cf6bd.jpg

By the way, this problem always occurs in retopo room if you save the scene, then take a step back

Once again, I apologize if I write not there. In Mantis is not yet understood

Edited by Cleitus

Share this post


Link to post
Share on other sites

Can anyone else confirm if this is indeed a bug, or perhaps i'm just doing it wrong.

If i assign a different hotkey to the custom navigation section to replace "MMB" move in screen space.  (to pan the viewport).  The viewport simply slowly scrolls camera left with the custom key input.  it only seems to function correctly with the middle mouse button

 

Share this post


Link to post
Share on other sites

Hi, please post in the v4.8 beta thread. v4.7 is no longer in development.

Here is the URL:

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×