Andrew Shpagin

3D-Coat 3.3 updates thread

916 posts in this topic

Andrew:

The same major symmetry bug can be observed by also following these steps:

1) Create a symmetrical voxel model

2) Right click on voxel layer in tree and select "Auto retopology"

3) Leave all fields unchanged except "Approximate Polycount", changing this field to 400

4) Click through the following dialogs without adding density shading or guidelines

5) When whole mesh appears in Retopo Room, select "Merge for per-pixel painting with normal map" - (an incredibly long menu option)

6) When dialog appears, don't change default settings

7) Observe 1/2 model in Paint Room.

Greg Smith

I see the same phenomen in the last couple of Builts (including the Release-Candidate) also with leaving all Values at Default.

Edit: The Retopo-Mesh gets created entirely but only half of it gets merged.

Share this post


Link to post
Share on other sites

Andrew, a longstanding problem I have noticed in the Voxel Room has been the transform gizmo often times not being centered on the object that is selected in the Vox Tree. The workaround up to this point has been to create "copy space density" and then merge the layer to that. That gets old and tedious really quick, it's not intuitive for a new user, and frankly it's not an answer for a professional application. For DAZ or Poser, maybe....but not something that will be used at major studios.

Can you at least simply this process by having a "Reset to Object Center" in the Parameter Panel that does this process for the user, that way it's just a matter of one click to correct?

Share this post


Link to post
Share on other sites

Hi Andrew,

I just downloaded version 3.5.00 and the object I sent you via email now causes 3D-Coat to become unstable and close down creating a crash report (which I have also sent) when I try to "import model for ptex" painting.

I also emailed you the file again.

Thanks,

Andrew.

Share this post


Link to post
Share on other sites

Hi Andrew,

Just a follow up, after a bit of cleaning up in lightwave I have managed to import the object into 3.5.00.

Thanks,

Andrew.

Share this post


Link to post
Share on other sites

just testing out the auto-retopo changes, very impressive meshes coming out.

couple of things that would be awesome...

in the wizard:

  • painting density - mask by occlusion/surface curvature would be very handy here
  • pressing ESC to clear lines for auto-retop also quits wizard... perhaps the tool tip could be changed to END instead of ESC?
  • be able to add/remove points from drawn lines... :)
  • more tools for drawing auto-retop lines please! similar tools already available in the pen operations like "draw with curves", draw rectangle, draw circles etc
  • smooth all lines is great idea, but breaks any orange lines drawn by dragging outside mesh (straight lines/loops)

after mesh is auto-retop

  • symmetrical meshs always need a clean edgeloop along the symmetry axis. currently some faces are split there, some are not.
    -edit... this seems to be related to symmetry in the retop room, and not caused by the auto-retop

And a question... how would an artist know when/if to use the new fill inner hollows function? would it be better if that was automatically run when required, such as before auto-retop?

Thanks for all the hard work, brilliant program and fantastic to see the continued fast progress!

Jamie Macdougall

Share this post


Link to post
Share on other sites

And a question... how would an artist know when/if to use the new fill inner hollows function? Would it be better if that was automatically run when required, such as before auto-retop?

The problem with doing it automatically is that it takes away the option to have "inner hollows" if you want them. Especially if you're making a thin object with just a skin that will be printed out. You can easily see these hollow places if you hold the W key to see the object in Wireframe mode.

Edit: Speaking of which, the wireframe mode looks kinda weird with the new shader.

Edit 2: There's a huge problem with the display of the new shader in orthographic mode.

Video: http://screencast.com/t/YmEwYmU2Nj

Share this post


Link to post
Share on other sites

Edit 2: There's a huge problem with the display of the new shader in orthographic mode

Try it with original shader supplied in 3.5,i probably messed up the setting while tweaking it.

Does problem is there too?

I cant check right now,i dont have my computer in front of me.

Share this post


Link to post
Share on other sites

Yeah, they both do it.

2010-09-15_0559.png2010-09-15_0600.png

Share this post


Link to post
Share on other sites

I uploaded preliminary 3.5.00 ....

Please put feedback right there in this thread.

That's cool! 3.5! at last! :)

(IMHO: Shouldn't we start a new '3D-Coat 3.5.xx thread' (may be after a preliminary release), just to keep some logical line of releases & features separately. Not to mention we 'miss 3.4 release' :) )

Share this post


Link to post
Share on other sites

That's cool! 3.5! at last! :)

(IMHO: Shouldn't we start a new '3D-Coat 3.5.xx thread' (may be after a preliminary release), just to keep some logical line of releases & features separately. Not to mention we 'miss 3.4 release' :) )

Actually it is not release but last check before it.

We will start new thread as soon as...

Share this post


Link to post
Share on other sites

It's the download on the first page of this thread. Though it's nor officially released yet.

Share this post


Link to post
Share on other sites

Hi Andrew,

I just downloaded version 3.5.00 and the object I sent you via email now causes 3D-Coat to become unstable and close down creating a crash report (which I have also sent) when I try to "import model for ptex" painting.

I also emailed you the file again.

Thanks,

Andrew.

Hi Andrew,

This is now fixed in the final release of 3.5.00, thanks :) Great release.

Andrew.

Share this post


Link to post
Share on other sites

Just tried out 3.5 and Auto-retopology (hadn't actually used it yet). Really useful and impressive stuff. But seems it doesn't play nice with symmetry yet (pic).

btw, what happened to 3.4? :p

Share this post


Link to post
Share on other sites

Just tried out 3.5 and Auto-retopology (hadn't actually used it yet). Really useful and impressive stuff. But seems it doesn't play nice with symmetry yet (pic).

btw, what happened to 3.4? :p

When the Auto-retopology finish the process, try hit "s" and no symetry, and you will see the correct wire. The auto-retopo apply symetry automatically.

Share this post


Link to post
Share on other sites