haikalle

Blender Applink

42 posts in this topic

3D-Coat/Blender applink manual

Applink Version: 1.55

Updated: 25.9.2010

1. Download latest trunk from http://www.graphicall.org/builds This script dosen't work if the blender version is too old.

2. Download rar file and Copy "coat" folder into your /.blender/scripts/io/ Download the script

3. Open blender. Now you should be able to see 3d-coat applink area under the scene tab.

4. This video shows the right settings.

5. Here is brief demo how to use this

6. Better video tutorial is WIP...

Export Settings:

--------------------

Export Obj = If this is on. It will export your model everytime you press "export". If this is off, It only export your model if it dosen't find object. Also if you

set only a folder into object path, the script exports the model and adds automaticly the name of the object into "object path".

Modifiers = This export your model with modifiers. Be careful if this is on you might want to turn off Import -> Modifiers.

No Import File = If this is on. The script dosen't write import.txt file. It brings some advantages in some situations. For example when working with Microvert or Ptex.

You can use this when you don't want to take models into 3d-coat, you just want to seek and updates all the textures that are linked into object quickly.

Import Settings:

--------------------

Mesh = Updates base mesh

Modifiers = Keep and updates object modifiers.

Bring Textures = Seek new textures and bring them into your active material.

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------

My future plan is to add some special features into script that will make the script work better with Vray renderer in blender.

Also one interesting idea is to make exchange bridge where you don't need to click any buttons. Bridge would work automaticly.

I think that in blender API there is already tools to make this but It needs some brain work.

If you have any questions or problems with this script, you can email them or write them down here.

Share this post


Link to post
Share on other sites

Thank you haiklle, I will test it out,as I'm still learning Blender. I need your opinion too, is it better to learn 2.49 to get a firm hold on Blender or go completely with the 2.5 alpha version.

Share this post


Link to post
Share on other sites

I would say..it's better to learn 2.5. 2.5 and 2.49 are two totally different programs. If you decide to learn first 2.49 then you have to learn 2.5 again.

But 2.5 is still in Alpha stage so If you are taking that road there can be some bumps on the way. but the speed of the blender coders is amazing... so

we don't have to wait for long for solid version.

It's a little bit risky to develop something like this script. When they fix something, it's most likely that my script stops

working until I change the code. But It's nice to live on the edge :D

Share this post


Link to post
Share on other sites

Thanks haikalle, I'll test it soon. Great work, wow...

BTW about v2.49b and v2.5.2, multi res meshes with UV mapping are incompatible, try to remember, here's what coders answered to my report.

>Comment By: Nicholas Bishop (nicholasbishop)

Date: 2010-06-06 23:50

Message:

Fixed in SVN, thanks for reporting.

Usage note: your old UV data will now be imported on a separate layer. So, in the example file provided, it will still appear to load incorrectly, but you can go to the UV Texture selector and choose the newly added UV layer, which should contain the correct UV coords.

Share this post


Link to post
Share on other sites

This seems like it would be great however i cannot get it working. Looking at the blender console i think due to it using a path from your computer rather than the users path and also in the 3dc share folder a text file missing. Possibly a option to select a folder might be better as then it would always work.

Do you have better installation instructions if possible? what exactly do i have to change in the scripts? I found the path and changed it to the location of the folder i had but it just causes errors still so i deleted it as i couldn't get it to work.

Btw - If you haven't already it might be worth posting about on the blender artists forums.

Share this post


Link to post
Share on other sites

Thanks, i will test this when i get time. The new option should hopefully fix the error i was getting. :)

Share this post


Link to post
Share on other sites

haikalle , thank you very much, very useful script

Share this post


Link to post
Share on other sites

Script update. Let's say that this is version 1.0

There was some nasty bugs that had to solve. The Script works much better now.

Share this post


Link to post
Share on other sites

This is really nice! A linux/osx version would be nice, I guess it's just a matter of different path naming?

Share this post


Link to post
Share on other sites

That's right. It shouldn't be too difficult. There is so many people really liking this so I will do Linux/Mac support very soon. I need a little help about macs. Where

is 3d-coat exchange folder located. Does it have similar folder tree with windows. For example c:\temp\mesh.obj

Share this post


Link to post
Share on other sites

Version 1.1 Release.

-Support for win, linux and mac.

Linux: The script is seeking 3d-coat folder from /home/username/ or /home/username/Desktop (Tested and should works)

Mac: The script is seeking 3d-coat folder from /Users/username or /Users/username/Desktop (Not tested, not sure how folder structure works in macs)

Share this post


Link to post
Share on other sites

Wow that was fast! I can't test it right now tough because I am going to Helsinki (yeah!) for 9 days, but I will when I get back.

Thanks!

Share this post


Link to post
Share on other sites

Nice. I hope you like it here. I have heard that the weather here has been amazing 8) Maybe it's time for me to get some fresh air too.

Share this post


Link to post
Share on other sites

This is actually broken for me still because it uses the C drive, for most people this will definitely be ok but others like me might use something like E:\ instead and for that it is broken. That is actually what i meant when i suggested choosing the path however the option to choose the model path is also very useful.

When i open blender by default it doesn't actually appear, if however i add a user folder (it said it could not find in blenders consoles) then it shows. When it shows though and i try to get it running i can't at the moment unfortunately as it can find the paths it needs on the E drive. Hopefully if it is ok you could maybe add a option to select another drive or the 3DC exchange folder so it will work with other drives that have 3DC and blender installed on. Hopefully this info is useful and you like this suggestion, many thanks :)

Share this post


Link to post
Share on other sites

good point. Didn't even crossed my mind when I was coding this script. Maybe the easy fix could be that if the script looks for address where the blender

is installed and use that same drive letter to find exchange folder. This wouldn't be 100% bullet broof for errors but could work better than it's now.

Share this post


Link to post
Share on other sites

Script update 1.2

-Now it will check where is your blender located and use the same drive letter to search exchange folder.

-Code cleaning in many areas.

Share this post


Link to post
Share on other sites

Thanks, it always shows in blender now however the Exchange Bridge is not connected still. Not sure if it helps but on my computer the folder paths are like this -

E:\Documents and Settings\Username\My Documents\3D-CoatV3\Exchange

E:\Program Files\3D-Coat-V3

E:\Program Files\Blender Foundation\Blender\scripts\io

With one of the recent graphicall builds i got the blender folder setup seems to have changed slightly now so this might have something to do with it also maybe. I think when i was trying to run it though it saved a file to the E:\ however but i think that it might need to save to the exchange folder instead so another possible reason maybe. Many thanks

Share this post


Link to post
Share on other sites

I've also got problems with the script finding the path, and I've got the "3D-Coat" folder in my home directory. If generating the paths is a problem why not give the user the ability to override them, at least with a variable in the script. So you can edit the script and insert the correct path. Not optimally user friendly but at least it works.

Share this post


Link to post
Share on other sites

You are right. I was busy but now I have some time to update the script again. The problem I have with blender API is that I can't create new find path boxes. I can only use ones that are built into blender. I already use one path finder to set your object path. that same path finder is used to set your scene folder in blender. And when you change one, the other one is changed too. If I add one more path finder it can start to be very confusing. I could add just a text box, but then you have type the path manually and that's not fun in a long run. hmm... Maybe I could add save button, that way you need to type it only ones...

Thanks for feedback GeeJay and Digital777. It has been very helpful :)

GeeJay. Do you use Win XP? Soon I will update the script that it works in Xp too.

Share this post


Link to post
Share on other sites

No, I am using Linux (Ubuntu). You could place a variable in the script so you can edit the script directly (the respective .py file, with a text editor) and set the correct paths. Maybe I am mistaken but the path doesn't change? So it would only have to be set once. If the variable is empty (not set) then you can try the autodetection.

PS: Suomi was hella hot. And the whole sunshine-22-hours-a-day thing didn't help either... But it was nice!

Share this post


Link to post
Share on other sites

Script update 1.3

-Auto exchange folder search system is out of the window :D How it works now is you first set your exchange folder into file Browser.

After this, the status should change to "connected".

-Import mesh works. Even when this was off It used to import mesh again and again into blender. Now it only imports if this is on. Good for

huge poly meshes.

Also remember to download the latest blender trunk. There was some changes again so this dosen't work with older versions.

With new blender version relative paths is set on by default. You have to go to User Preference -> File and set Relative paths

off to make this script work. If you leave it on blender will crash.

GeeJay, they say it this was the hottest summer in 40 years in Finland so you really picked the best time to come here.

Share this post


Link to post
Share on other sites

Ok now I got it working somewhat. I can export and 3D-Coat picks it up, then I can import again and I get the textures assigned and everything. But on a second push of the import button it crashes with an error regarding the material assignment. And another bug: I add a monkey, rotate it and export to 3D-Coat. On re-import to blender the whole mesh is deformed. This is using on of the latest trunk versions.

Share this post


Link to post
Share on other sites

Script Update 1.4

- Rotation and Material issues should be fixed.

GeeJay: You can try this. But the problem when pressing import button twice can be tricky because in windows it works.

This is so called "segmentation fault". It is much harder to fix because it dosen't say what should be fixed.

In windows this should be quite stable version.

EDIT: I just updated my ubuntu 10.04 system and it seams that some "segmentation fault" errors are gone too.

Share this post


Link to post
Share on other sites

Script Update 1.45

coat.rar

-Should work in Linux.

-Multi-Material Support. If you uncheck all import checkboxes, it only updates textures from all materials. If you check

Bring Texture it will try to find textures into active material.

-Exchange folder path and object path are two diffrent fileBrowsers.

I will update my video tutorial and manual a little bit later.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now