Andrew Shpagin

3D-Max AppLink

130 posts in this topic

I am glad to present 3D-Max applink

- old version written by 1acc (scriptattack.com)

3DS_AppLink (3).zip

 

- new version for 2016 written by PolyHertz: look at this thread

3DS Max Applink - Complete Rewrite

-------------------------------------------------------

UPGRADES FOR NEW 3D-MAX VERSIONS:

 

Edit: 12 Oct 2010 - updated to release version
Edit: 22 Oct 2010 - updated with several fixes
Edit: 01 Nov 2010 - updated
Edit: 19 Jan 2011 - updated
Edit: 15 Jan 2012 - updated

Edit: 09 Dec 2014 - For v.2014/2015 follow this instructions

3DS_AppLink_source.rar

Share this post


Link to post
Share on other sites

copy in the folder macroscripts - It is in root of 3dsmax.

mcr file is replace for new file. It is works in 2013 Max ONLY!

macro_3DS_AppLink.zip

Share this post


Link to post
Share on other sites

Hi There,

I just installed V4 Beta3. I cant figure out how to get the 3D-Max AppLink

working together with V4. Is this working at this stage?

Share this post


Link to post
Share on other sites

Hi,guys

I cleaned this topic and I hope you will be easy to find a information :)

I will be do it from time to time so as not to clutter up this thread

Thanks for understanding.

Share this post


Link to post
Share on other sites

Phizter yes, it's problem 3d-coat 4 version. will be fixed soon.

Share this post


Link to post
Share on other sites

Any word on this, for V4? I'm very surprised that it would be broken from 3.7.18 and V4. What changes have occurred to break the Applink?

Share this post


Link to post
Share on other sites

copy in the folder macroscripts - It is in root of 3dsmax.

mcr file is replace for new file. It is works in 2013 Max ONLY!

Can you go through the process to install this in 2013 - I tried but got nowhere :( Thanks

Share this post


Link to post
Share on other sites

Iv just tried to install this into max 2013 on win8 -64 an it will not load up, it shows nothing in the customise window its just not there. i dragged the mzp into the viewport an nothing. iv placed the script into other directories but thats no good coz the bitmap icons are missing. iv been using max for 15 years and no what im doing so there is defo a problem with the script. if i just try to run the script it spits out an error about not being able to access directories macroscripts or something like that. i realy want to get this working with my pipeline. can you give me a helping hand here... what should i do... the zbrush one is showing up. i just need to max one to work... also how can we do a manual install of the script when the icons are missing. Im stumped !!! HELP !!!

Share this post


Link to post
Share on other sites

Iv just tried to install this into max 2013 on win8 -64 an it will not load up, it shows nothing in the customise window its just not there. i dragged the mzp into the viewport an nothing. iv placed the script into other directories but thats no good coz the bitmap icons are missing. iv been using max for 15 years and no what im doing so there is defo a problem with the script. if i just try to run the script it spits out an error about not being able to access directories macroscripts or something like that. i realy want to get this working with my pipeline. can you give me a helping hand here... what should i do... the zbrush one is showing up. i just need to max one to work... also how can we do a manual install of the script when the icons are missing. Im stumped !!! HELP !!!

It's not yet working on V4 Beta...as noted above. I sent an e-mail to Andrew about this, haven't heard back yet.

Share this post


Link to post
Share on other sites

Hello everyone! Can anyone help me to solve the following problem: the toolbar stays empty when I drag "3DS_AppLink v1.0" from the category "ScriptAttack" to the newly created toolbar, i don't have icons either, because I could not find them anywhere. The version of max is 2012, Windows 7 x64

Share this post


Link to post
Share on other sites

Hello everyone! Can anyone help me to solve the following problem: the toolbar stays empty when I drag "3DS_AppLink v1.0" from the category "ScriptAttack" to the newly created toolbar, i don't have icons either, because I could not find them anywhere. The version of max is 2012, Windows 7 x64

Did you download the main link in the first post? You should be able to drag and drop the 3ds_Applink.mzp file directly into the viewport. If you follow the instructions and can bring up the applink panel, yet don't see the icons, you can open the .mzp file and see two .bmp files. Copy those into your Max main directory > UI > Icons. Restart Max and you should see it. Here are the two bmp files, just in case.

Share this post


Link to post
Share on other sites

Any news on update to Applink & compatibility for Max 2014?

1 person likes this

Share this post


Link to post
Share on other sites

3ds max 2014 should be able to also use 3ds max 2013 plugins. But during the beta of max 2014 I couldn't get it to run.

Share this post


Link to post
Share on other sites

I'm unable to get this to work. The script generates the error "--Unknown property: isOpen is undefined" in Max 2013

Share this post


Link to post
Share on other sites

I never knew the AppsLink existed until I upgraded to V4 today. I downloaded from the 3D-Coat website and only got a '3DS_AppLink.ms' file. I tried dragging it into Max 2014 and nothing worked. It never showed up in Customize/Toolbars. I tried to 'Open' and 'Run' it and nothing happened. I'm sure that was user error because I know little about scripts. From this thread I got the '3DS_AppLink.mzp' file and dragged it into Max 2014. Everything setup and worked per the installation instruction. However, when I launch the app I to get an error: "--No ""+"" function for undefined" . The 3DS_AppsLink.ms file now opens and the following line is highlighted "t=((findString a "Documents")+9"

Now, if I close the error and close the open script, I'm left with the applet and it works. I can set the 'Path' and the 'Folder' and everything works. But, when I close Max 2014 and relaunch the AppLink, I get the error again, the open script again and have to reinsert the 'Path' and 'Folder'. That's a pain but it works.

Edited by RobH2

Share this post


Link to post
Share on other sites

I'm going to answer my own post. I think I've fixed the Max 2014 functionality, at least for my installation. As I said above, I know little about script but I can look at it and deduce obvious errors. For instance, around line 142 this code appears:

if (findString pathtoIO "3D-CoatV3\\Exchange\\")==undefined then (

a=pathConfig.convertPathToAbsolute "meshes"

t=(findString a "Documents")+9

tt=(substring a 1 t)+"3D-CoatV3\\Exchange\\"

if (doesFileExist tt) then pathtoIO=tt

)

Notice that it specifies '...CoatV3'. Well, we are using 'CoatV4' so I changed the two CoatV3's to CoatV4's while the script was still open (thrown open due to the error) and then saved it. I then set my 'Path' to the 'Exchange' folder in My Documents in the V4 folder and closed Max 2014. I reopen Max and launch the AppsLink and everything is great. I get no errors and the 'Path' was held. So from my perspective, it's all working.

Share this post


Link to post
Share on other sites

Yeah, I had to install it manually and I forget what exactly what steps I had to take, but I was able to get it to work with both Max 2013 and 2014

Share this post


Link to post
Share on other sites

hi RobH2,

I changed th "3" to "4" but didn´t understand the thing about the Path. Would you please be so kind and offer us a full explanation on how to get the app link running?
Thanks

Share this post


Link to post
Share on other sites

Already introduced a problem with the latest beta.  If you try to paint without depth over a material, it simply paints color, but not the material.

Share this post


Link to post
Share on other sites

Try and close the app > Restart and see if that doesn't help. Sometimes little glitches like this occur and it helps...but not always.

Share this post


Link to post
Share on other sites

If 3DS_AppLink.mzp drag and drop to 3d max 2014, applink don't install. i open mzp file and install script manualy. When i start script in 3d max it don't work and write message: "--Unknown property: "isOpen" in undefined)"

Share this post


Link to post
Share on other sites

It needs to be cleaned up and spelled out clearly. I was able to get it to work, but it takes a lot of trial and error trying to figure which one works and which one has the icons in it for the toolbar, etc. It was/is a hassle...for sure.

Share this post


Link to post
Share on other sites

To make script 3DS AppLink work in 3d max 2013/2014 you should follow instructions:

Install

Put macro_3DS_AppLink.mcr and folder macro_3DS_AppLink into folder Max_Folder\MacroScripts

Create folder UI\Icons
Put files macro_3DS_AppLink_16i.bmp and macro_3DS_AppLink_24i.bmp into UI\Icons

Put 3DS_AppLink.ms into folder Max_Folder\scripts\Startup

While closing the window an error may occur:  can't write pathtoIO file
You can also delete a piece of code into Max_Folder\scripts\Startup\3DS_AppLink.ms

if (doesFileExist pathtoIO) then (
   
   s=getFilenamePath (getSourceFileName())
   pathtoIOfile=s+"pathtoIO.ini"
   if doesfileExist pathtoIOfile then deleteFile pathtoIOfile
   
   vecbut=[0,0,0]
   if chkStartTimer.checked then vecbut.x=1
   if chkDeleteOld.checked then vecbut.y=1
   if chkNoPrompt.checked then vecbut.z=1
   out_pathtoIOfile = createfile pathtoIOfile
   format "%\n" vecbut to:out_pathtoIOfile
   format "%\n" pathtoIO to:out_pathtoIOfile
   if arr.count>0 then for i in arr do format "%\n" i to:out_pathtoIOfile
   close out_pathtoIOfile
   )

Probably, this fault is caused by denied access. I deleted checkout and now it works.

 

http://rghost.ru/49132967 - 3d coat v4 applink for 3d max 2013/2014

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now