Jump to content
3D Coat Forums
Styler

Maya AppLink

Recommended Posts

Hi there, I'm trying to get this applink to work but don't know what's wrong. I've installed the plugin and the shelf and everything in maya shows up but when I try to send an object to 3DCoat it will open the program but the object isn't there.

I'm using Maya 2017 and 3DCoat-V4.5

Not sure if there's some step I'm missing? 

Share this post


Link to post
Share on other sites

Hey guys, I have a new update. Currently in beta

v.2.2.0-beta.jpg.7a7a0d2a065072b0385b080bb021f9e6.jpgmanual_settings.jpg.6e3cae0d675e205f113a274323796706.jpg

What's new:

  • Now you can choose one of 2 approaches. "Use manual setting" uses old method. When you click "Show" button a new dialog will appear where you can find all familiar options plus some extra.
  • In release version will be introduced a new method, using presets. it's temporarily locked, because Andrey have to fix some issues in 3D-Coat, first.
  • From this version you'll be able to choose a shader type for imported object. Currently supported Software and MR, I'll putting more in upcoming versions. (Note!  You have to load Mentalray plugin before running applink. If you still can't see it in settings, try to unload/load applink and run it again).

Found a bug? Report it here. Thanks!

 

 

3dcoat_for_maya_v2.2.0-beta.zip

  • Like 4

Share this post


Link to post
Share on other sites

Hello & Thank you very much for this plugin!
I believe I found a small bug: Whenever you export from Maya and let the plugin (!) start 3D-Coat, for some reason, the "File -> Export" feature in 3D-Coat is disabled. You have to manually go to another "room" in 3D-Coat first to make this option available again. This only happens the first time when you want to export something from Maya and 3D-Caot is started by the plugin (I attached a screenshot of the problem).

MPLGMAY.jpg

Share this post


Link to post
Share on other sites

Hi @Styler,

I have a quick question, regarding Maya export, i downloaded the latest (beta) app link for Maya, and i’m testing it with Maya 2018.
The objects are sent to 3DCoat BUT once i have to re import them this happens:
 
- from 3D coat, i see MAYA in file / export but it’s greyed out. I know it's a bug that says i do not own a commercial license (which is not the case) but anyhow it does not export to maya.
 
- In maya, via the app link UI, the IMPORT button says : “no information for processing input” . I also tried to export “normally” inside the exchange directory, but nothing changes.
 
NOW:
 
i can still export and go to Maya with a "standard" export procedure and as i use Arnold unfortunately there’s no way to send textures and attach them to a AIStandard Material (would be a dream) so in any case i will have to re link manually, but this is such a great piece of software that a more direct communication between the softwares would be the ICING on an already AMAZING CAKE.
 
I really hope i’m doing something wrong here and you can solve this,
thanks 
 
Marco

Share this post


Link to post
Share on other sites

Hey man,

i'm on Mac High Sierra and i'm using 3dCoat latest version i could find when i bought it, which is 4.804,

hope this helps you to help me :)

thanks

 

marco

Share this post


Link to post
Share on other sites

Cool, this and the ZBrush Applink and I am in heaven. Nice work! Will test it later.

Edited by houGenie

Share this post


Link to post
Share on other sites

I agree... solid Applinks allowing 3DCoat to talk to Maya and ZBrush would mean other great reasons to consider this freaking great piece of software !

 

Share this post


Link to post
Share on other sites

 marcoi

On 09/01/2018 at 6:37 PM, marcoi said:

- from 3D coat, i see MAYA in file / export but it’s greyed out. I know it's a bug that says i do not own a commercial license (which is not the case) but anyhow it does not export to maya.

I had exactly the same problem on MacOs.The old solution was to run  3d-coat before doing export operation from Maya. The latest version 4.8.08 should not have this problem with license detection. Just tried and it works indeed. High Sierra introduced a few more bugs (god damn), but they're not critical.

On 09/01/2018 at 6:37 PM, marcoi said:

- In maya, via the app link UI, the IMPORT button says : “no information for processing input” . I also tried to export “normally” inside the exchange directory, but nothing changes.

Be sure that you've set paths correctly:

/Applications/3D-Coat/4-8/3D-Coat.app
/Users/username/3D-CoatV48/Exchange

version 2.2.1
*************
Fixed:
- The way of detection "is 3D-Coat already running or not" (MacOS)

3dcoat_for_maya_v2.2.1-beta.zip

Edited by Styler

Share this post


Link to post
Share on other sites

Hi Styler,

thanks for putting the time into this. So, after installing the new beta and following your tips (i'm also referring to the Vimeo workflow video that came with the applink)

- export (per pixel painting) from Maya 2018 works fine, 3D Coat opens and import correctly

- after painting i "open in original App"   -  The parameters i can choose are different than what i see on the Vimeo video, i have to put a path for the OBJ (i use the exchange folder)

and i have to choose a PRESET (i tried different, and there's no "native" Maya one, only VRay or Mental Ray, ideally a Maya Arnold one would be great)

- once done, Maya does not automatically recognize and asks for which channel to import, as you see in the video, but I click import and the geometry comes in.
 

Unfortunately the geometry comes in with the normal map correctly applied BUT no color, no roughness etc

Exporting then back for displacement for example works fine, but again re importing it misses some texture links. 

Maybe the presets are the problem?? Do you think it's possible to import with textures linked to an AIStandard material anytime soon ?

Should Maya default project be pointing at the Exchange directory ?

Thanks a lot Styler, i think you're getting closer and closer !

cheers

 

marco
marcoiozzi.com

 

 

Share this post


Link to post
Share on other sites

>> Maybe the presets are the problem?? Do you think it's possible to import with textures linked to an AIStandard material anytime soon ?

Presets are not currently supported. Use a non-preset mode for now. I have implementation for them but it was a problem with passing a preset name from applink to 3D-Coat. I switch them on as soon as I'll solve with issue.

Arnold will be supported soon (next in my list)

>> Should Maya default project be pointing at the Exchange directory ?

Nope. Exchange folder in setting only requires for 3D-Coat to know where is your export data.

Edited by Styler

Share this post


Link to post
Share on other sites

I did that but the Export presets at the bottom does not disappear, which is something maybe could make sense (just a suggestion)

As it does not disappear i thought presets were still taken into consideration.

However, with export constructor off the export process works as expected.

As of now, outside of the AI shader preset, i do not see other problems, so i REALLY thank you for this Styler,

and i'll be following the thread for the further evolution of this plugin as well as waiting for the ZBrush one for Mac.

Thanks again for this plugin !

 

marco

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×