Andrew Shpagin

3D-Coat for OSX 64-bit [beta testing]

101 posts in this topic

Yes, I'm wondering if the beta builds are being tested on Lion and whether we should upgrade for better stability. I'm still having some issues where a force quit will cause the entire system to go down. Is Lion better at handling these crashes and freezes?

Share this post


Link to post
Share on other sites
I'm still having some issues where a force quit will cause the entire system to go down

I noticed this. Force quit from right click on dock icon. Avoid activity monitor as it may crash the OS.

Share this post


Link to post
Share on other sites

Testing 3d-coat in OSX Lion. It seems to be working fine. The nice thing is other 64 bit apps seem to be working a lot better too, making the system much more responsive. (late 2008 macbook pro with 6 gig of memory)

Share this post


Link to post
Share on other sites

Posted this over in the regular update thread as well, but figured I'd ask here in case Mac folks are reading this instead of the other thread:

Ever since the first 64-bit beta, I've been having a problem with 3DC. It gets into this state as if the alt key is constantly held down (and yes, I've checked sticky keys, and other prefs that might cause similar effect). It doesn't always happen right away, but once it gets into this state, I can't figure out any way to get it back out again. Clicking with alt held, etc. doesn't fix it. Once in this state, I can't draw, etc. because mouse-dn dragging just rotates the view, and so forth. Has anyone else run across this problem? If so, any workarounds? It seems "new" to 64-bit 3DC, but as I've been messing around with peripherals it could as easily be an incompatibility.

Share this post


Link to post
Share on other sites

No, it doesn't happening here.

On a dual xeon nehalem + nvidia graphics OSX 10.6.8

Share this post


Link to post
Share on other sites

Posted this over in the regular update thread as well, but figured I'd ask here in case Mac folks are reading this instead of the other thread:

Ever since the first 64-bit beta, I've been having a problem with 3DC. It gets into this state as if the alt key is constantly held down (and yes, I've checked sticky keys, and other prefs that might cause similar effect). It doesn't always happen right away, but once it gets into this state, I can't figure out any way to get it back out again. Clicking with alt held, etc. doesn't fix it. Once in this state, I can't draw, etc. because mouse-dn dragging just rotates the view, and so forth. Has anyone else run across this problem? If so, any workarounds? It seems "new" to 64-bit 3DC, but as I've been messing around with peripherals it could as easily be an incompatibility.

the opposite happened for me. Before the 64-bit build I ALWAYS had a modifier key locked down in 3DC only, and now, with the 64-bit beta, that has been remedied. Sounds like an underlying issue in 3DC. I couldnt even use it before the fix that occurred in the 64-bit builds.

OSX 10.6.8

Share this post


Link to post
Share on other sites

cant wait to test out the new 3.5.23 beta release on OSX, I've been enjoying the 3.5..21 beta 64bit release for a while now, its been great overall, compared to the previous 32bit release.

Thanks Andrew & Sergey & team!

Share this post


Link to post
Share on other sites

A first for me. Any attempt to use LC freezes my computer in this new build. One stroke and that's it. Mostly in stamp mode.

Share this post


Link to post
Share on other sites

Lorenzo:

Can you please give us your hardware specifications and system version?

Thanks,

Greg Smith

Share this post


Link to post
Share on other sites

A first for me. Any attempt to use LC freezes my computer in this new build. One stroke and that's it. Mostly in stamp mode.

Andrew has fixed stamp mode issue, he did that after releasing 3.5.23C. So it should work in next build. This issue is in Win too.

Share this post


Link to post
Share on other sites

Andrew has fixed stamp mode issue, he did that after releasing 3.5.23C. So it should work in next build. This issue is in Win too.

OK, thanks haikalle.

Share this post


Link to post
Share on other sites

Hi PSmith. I'll have something for you when I get back to my officer tomorrow. Thanks for your response.

Here are my system spec's,

Macbook Pro4,1 - 10.6.8 - 2gb Ram - 512mb VRAM

Lorenzo:

Can you please give us your hardware specifications and system version?

Thanks,

Greg Smith

Share this post


Link to post
Share on other sites

Besides LC Stamp mode, the new build for OSX is awesome. I'm noticing amazing performance improvements all around. You guys are doing great work in record time.

Thanks 3DC crew!

Cheers, Andrew.

Share this post


Link to post
Share on other sites

Besides LC Stamp mode, the new build for OSX is awesome. I'm noticing amazing performance improvements all around. You guys are doing great work in record time.

Thanks 3DC crew!

Cheers, Andrew.

The link in this therad was updated just now, so check if you downloaded right version 3.5.23C. I was sure LC stamp should work there.

Share this post


Link to post
Share on other sites

Reduce tool in live clay works like crazy.

1. the more wide it is the more it reduces (should be the opposite)

2. There should be the opposite (to subdivide) ctrl+drag.

3. Pressing ctrl+z (undo) holes remain.

post-2454-0-80569700-1313571217_thumb.jp

Share this post


Link to post
Share on other sites

I have had an ongoing problem with display of the Texture UV Editor window. This problem developed a while ago seemingly at random and effects all versions of 3d-coat for mac. The window appears to have the wrong shaders attached and rolls a texture across it like freeze view.

Deleting and reinstalling hasn't helped. Has anyone else had this problem?

More on this thread http://3d-coat.com/forum/index.php?showtopic=8504

Share this post


Link to post
Share on other sites

The link in this therad was updated just now, so check if you downloaded right version 3.5.23C. I was sure LC stamp should work there.

Updated? OK, i'll download again.

Share this post


Link to post
Share on other sites

The link in this therad was updated just now, so check if you downloaded right version 3.5.23C. I was sure LC stamp should work there.

Yes Andrew, I had the latest build. LC in stamp mode still freezes. One stamp, that's all she wrote.

Any other OSX users experiencing this?

Share this post


Link to post
Share on other sites

hi

uv unwrap not eficient as before,in this last build!

an arm (cilindrical) needs 2 cuts (in two pieces) instead of just one cut to be OK

please check

happy joy!

Share this post


Link to post
Share on other sites

@moska

this is happening in the last 2-3 64 bit builds, I'll report it to mantis

@ LorenzoS

I can't reproduce the stamp-LC issue. I missed something?

Though I collected a ton of LC issues so far.

In any case it's in pre-alpha stage so I can't use it for serious work. I can't test it. I even don't understand the need of it.

I do understand a workflow between 3dc and sculptris. An app link is all we need. LOL

So far, the use of LC tool (0 strength) for just adding geometry and reducer tool is all I can do.

3DC devs should have a closer look to sculptris, Andrew especially. The behavior of these few tools matters more than all 3dc tools together.

Remeshing in sculptris is also superior.

Share this post


Link to post
Share on other sites

hi

uv unwrap not eficient as before,in this last build!

an arm (cilindrical) needs 2 cuts (in two pieces) instead of just one cut to be OK

please check

happy joy!

This is really strange - look this

http://bit.ly/oUd6SM

(or I have not understood)

Share this post


Link to post
Share on other sites

Andrew, I reported it to mantis.

OK, have a look here

post-2454-0-92177800-1313651780_thumb.jp

Share this post


Link to post
Share on other sites

Hello to all 3D_Coat community and thanks Sergyi for bringing us 3D-Coat in 64 bits for OSX.

Works great for me so far, except for one thing (important for me), it seems that the 64 bits version doesn't recognize 3Dconnexion mouse (it worked very well in 32 bits). My graphic tablet, on the other hand, works like a charm.

Should I report it via Mantis ?

I add my hopes for 3Dconnexion.

Just returning after a couple of years and 3Dconnexion was first thing needed....

I'll come back again in hopes of eventually learning this software.

Share this post


Link to post
Share on other sites

I'm not sure if this helps, but 3D Connexion did put out a new driver/software that allows you to use a 3D Connexion mouse with just about any application. Maybe that will help folks? I'm not certain, just a thought.

Here is the URL:

http://www.3dconnexion.com/supported-software/3dxlabs.html

Share this post


Link to post
Share on other sites

I add my hopes for 3Dconnexion.

Just returning after a couple of years and 3Dconnexion was first thing needed....

I'll come back again in hopes of eventually learning this software.

Use 3DC from this thread

http://3d-coat.com/forum/index.php?showtopic=6634

This thread's link is no longer updated. 3DC 64 bit should correctly support 3D-Coannexion.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.