Andrew Shpagin

3D-Coat 3.7 updates thread

1,787 posts in this topic

thanks for verifying, LJB! :)

just tried again with microvertex and with all possible file extensions and no joy. :(

Hope it's a quick fix and something was commented out or some such....

Share this post


Link to post
Share on other sites

I have been able to bake to PP with NM with a poly painted sculpt. Color and NM detail baked nicely. What you can see underlying is the sculpt you have made in the voxel/LC. If you switch off the visibility of the sculpt in the Voxel layer/s this makes the appearance in the paint rm. seem normal like it should.

Try switching off the visibility of everything in the Vox/LC rm. and see how it looks. If it is all good, you should be able to delete everything in the Voxel/LC rm. Then save the file with a different name so you can keep your sculpt.

I think this is because of the poly painting feature the paint rm. is tied to the Voxel/LC rm. Once you no longer need your sculpt after baking you just have to remove it from the Voxel/LC rm and every thing is back to normal.

Share this post


Link to post
Share on other sites

can someone verify if the Bake tool is working? (I'm on Vista 64-bit CUDA DX)

I've got 2 heads, exactly the same, but with different UVs on 1 that is textured...trying

to bake that texture onto the other head (as external object, and tried as a retopo for per-pixel but that

didn't work either) with proper UVs and get nothing but grey... :(

Here's a test object for anybody that can't be bothered to use their own. ;)

Have only tried (and failed) with per-pixel,,,,

Hi, I tried bake in ppp.

I got good result. video -> http://youtu.be/ytr6qvrssn4

If it was my misunderstanding, I'm sorry.

Share this post


Link to post
Share on other sites

Howdy Polygoon and marupura, thanks for your input too! :)

Polygoon, my model never went through the voxel process, this was strictly trying to bake from a model

with an imported texture and 1 UV setup, onto another external model with altered UVs.

marupura, your UV-swap technique works perfectly, thanks! (another option to solve the 'no bake' error)

It worked on my heads to just swap the UVs instead of trying to bake.

Based upon your feedback, it would seem there's still an error in the baking tool specifically with imported

textures (diffuse is all I've tested thusfar) and attempting to bake them onto external objects, though. I hope

Andrew can have a look at it, as it's handy to swap textures onto objects that may not have the exact same polycount

or point order but still be in the 'same' world space....

Share this post


Link to post
Share on other sites

Based upon your feedback, it would seem there's still an error in the baking tool specifically with imported

textures (diffuse is all I've tested thusfar) and attempting to bake them onto external objects, though. I hope

Andrew can have a look at it, as it's handy to swap textures onto objects that may not have the exact same polycount

or point order but still be in the 'same' world space....

I tried another test. Same world space, but different meshs baking.

import diff -> import divided mesh -> bake

Is this way?

Share this post


Link to post
Share on other sites

thanks again, marupura!

It appears you are luckier than me! ;)

At any rate, I've uploaded a video of what I've encountered with

trying to bake. Perhaps it's machine/video-card or CUDA specific?

(My vid-card is GTX 560ti running drivers 301.24 and I've got

CUDA 4.2.1 installed)

bake_texture_error-process.mov

Share this post


Link to post
Share on other sites

The texture baking tool function has been broken on linux for number of past versions. All I get is a grey image as the video showed. You could in the past import a model as a ptex model. Do your work and then use the texture baking tool to bake the textures to the same model that had a regular uv map.

At one time Andrew said the texture baking tool was buggy and it now appears to be broken completely.

Use Mantis to report the bug with a link to your video as it shows clearly the problem. I get busy and cannot take the time to write up a bug report for everone I find.

Share this post


Link to post
Share on other sites

Do smoothing groups work correctly? 3DC will not preserve original indices of groups, it creates one grup per cluster of smoothed vertices. Maybe Max assigns same index fo 2 groups that don't have adjacent faces.

And it is strange regarding performance. Nothing in this area was changed. Do it works slower on the same scene?

If I understand correctly, and this is just a guess, I would say yes regarding 2 groups that don't have adjacent faces. Say I have a 6 polygon cube in Max. I can select the top polygon and bottom polygon and add them both to smoothing group #1. I do this a lot because of the turbosmooth modifier, which can subdivide/smooth based on those smoothing groups. It's also orderly and efficient to apply a single smoothing group to multiple areas, especially on parts that look the same. Here is an example:

1) Low poly mesh with several smoothing groups assigned (no turbosmooth).

2) Turbosmooth applied, separate by smoothing groups option is turned off.

3) Turbosmooth with separate by smoothing groups option turned on.

The effect is a bit like creasing edges before subdividing. I prefer smoothing groups for this though because it allows me to easily reselect a group (or groups) of polygons for further editing if I find it's needed later on.

About performance, I loaded my last .3b save from 3.7.09 into 3.7.10 so that I could finish up the last little bit of retopo work it needed. The difference in performance was very noticeable. No trouble panning/rotating/zooming in 3.7.09, but doing so is nearly impossible in 3.7.10 and nothing else about my PC has changed (no new software, driver, or hardware).

post-9206-0-17146800-1335230469_thumb.jp

Share this post


Link to post
Share on other sites

thanks again, marupura!

It appears you are luckier than me! ;)

At any rate, I've uploaded a video of what I've encountered with

trying to bake. Perhaps it's machine/video-card or CUDA specific?

(My vid-card is GTX 560ti running drivers 301.24 and I've got

CUDA 4.2.1 installed)

Ok, reproduced, I will fix it asap.

But you may do it through retopo tools. Just import as retopo mesh and bake for ppp.

Share this post


Link to post
Share on other sites

If I understand correctly, and this is just a guess, I would say yes regarding 2 groups that don't have adjacent faces. Say I have a 6 polygon cube in Max. I can select the top polygon and bottom polygon and add them both to smoothing group #1. I do this a lot because of the turbosmooth modifier, which can subdivide/smooth based on those smoothing groups. It's also orderly and efficient to apply a single smoothing group to multiple areas, especially on parts that look the same. Here is an example:

1) Low poly mesh with several smoothing groups assigned (no turbosmooth).

2) Turbosmooth applied, separate by smoothing groups option is turned off.

3) Turbosmooth with separate by smoothing groups option turned on.

The effect is a bit like creasing edges before subdividing. I prefer smoothing groups for this though because it allows me to easily reselect a group (or groups) of polygons for further editing if I find it's needed later on.

I can't keep original groups. But I may decrease amount by assigning same number to non-ajacent groups. Not sure it will be useful.

About performance, I loaded my last .3b save from 3.7.09 into 3.7.10 so that I could finish up the last little bit of retopo work it needed. The difference in performance was very noticeable. No trouble panning/rotating/zooming in 3.7.09, but doing so is nearly impossible in 3.7.10 and nothing else about my PC has changed (no new software, driver, or hardware).

It could be very good to get scene that works slower in 3.7.10 to understand the reason of problem. Please send it to support.

Share this post


Link to post
Share on other sites

Ok, reproduced, I will fix it asap.

But you may do it through retopo tools. Just import as retopo mesh and bake for ppp.

Excellent! Thank you, Andrew.

FYI, I can't bake with 'Texture Baking Tool' with the method you've described above...I had tried

that technique as an option earlier, but it fails as well. (produces pure grey texture file) Hopefully

you'll kill the bug that's affecting the tool as a whole! :)

Share this post


Link to post
Share on other sites
Excellent! Thank you, Andrew. FYI, I can't bake with 'Texture Baking Tool' with the method you've described above...I had tried that technique as an option earlier, but it fails as well. (produces pure grey texture file) Hopefully you'll kill the bug that's affecting the tool as a whole! :)

Ok, fixed baking. Will reupload probably tooday. But usual baking retopo->paint should work.

Share this post


Link to post
Share on other sites
It could be very good to get scene that works slower in 3.7.10 to understand the reason of problem. Please send it to support.

I can send you the file, or any OBJ which has been exported from ZBrush (where my own current project originated). After more testing, it turns out that any sufficiently high poly mesh which is imported as a reference mesh will do it (the one I just created 5 minutes ago for test purposes is approximately 1 million quads). Just to clarify, panning and zooming are unaffected. It's only rotating that stutters badly in 3.7.10 x64 CUDA DX/GL.

PS: I just tried importing as a big mesh instead of as a reference and discovered that option doesn't work at all anymore. I get a popup describing how it works (import low poly retopo mesh first, then the big mesh second) but that is it. No file dialog appears. Either something is wrong with the import functions relating to retopo or I need to redo a clean install.

Share this post


Link to post
Share on other sites

I can send you the file, or any OBJ which has been exported from ZBrush (where my own current project originated). After more testing, it turns out that any sufficiently high poly mesh which is imported as a reference mesh will do it (the one I just created 5 minutes ago for test purposes is approximately 1 million quads). Just to clarify, panning and zooming are unaffected. It's only rotating that stutters badly in 3.7.10 x64 CUDA DX/GL.

PS: I just tried importing as a big mesh instead of as a reference and discovered that option doesn't work at all anymore. I get a popup describing how it works (import low poly retopo mesh first, then the big mesh second) but that is it. No file dialog appears. Either something is wrong with the import functions relating to retopo or I need to redo a clean install.

Ok, found reason. Now fixed. I will reupload asap.

Thanks for pointing!

Share this post


Link to post
Share on other sites

Updated to 3.7.10A

- fixed slowdown when rotating viewport with ref mesh or ppp/mv

- voxel fill tool improved - now it will close holes over thin surfaces much better. It is very important to fix scan errors.

- fixed broken Textures->Baking tool

Share this post


Link to post
Share on other sites

First off, Andrew, I want to thank you. Few developers work as tirelessly as you do. Even fewer respond to criticism with such aplomb. Thanks.

That said, 3DC has been giving me nothing but headaches since v3.708. Really.

Starting with v3.708 and going all the way to v3.709, 3DC would automatically import all of my OBJ models in flat shaded mode. I had to manually click 1 go get into relief display. (Thanks to johnnycore for pointing that out.) This was what was happening by default. Knowing that I could just click 1 after import eased my misery some. It added one more step to my process, but it was totally doable. It was a bug I guess I could live with.

v3.710 and 3.710a are just so much more unpredictable though. Starting with a fresh 3DC session, importing an OBJ gives me one of 5 results:

1. Imported just fine (in relief mode, which should be the default)

2. Imported in flat shade mode (without ever having set it to that mode, mind you)

3. Imported in some crunchy, mangled, and ill-rendered manner. No way for me to fix this other than restarting 3DC and reimporting.

4. Imported as being semi-transparent, which I can't change out of mode or fix it in the same session. I have to restart 3DC again. (Couldn't snag a pic of this. It's a totally random occurrence.)

5. 3DC just hangs.

There's no predictable pattern. I've tried it with different object, with and without UVs. Which result I get is totally random. Getting a normal, perfectly displayed OBJ does rank with low probability. I can only get a well displayed OBJ import 10%-20% of the time. It's a crap shoot.

Knowing that ATI systems can be touchy, I've tried various display drivers, but none have offered me any relief. I've even nuked my whole system, thinking that maybe THAT was corrupt. No such luck. Given how much I use 3DC, it is really disconcerting. Not to offend, but I really do feel that 3DC seems to be at fault since the problem started with v3.708. Earlier versions didn't give me such a hard time. I can roll back to v3.707a, but I don't see that as much of a solution.

My current PC setup is as follows:

- Intel Core i7 980 Extreme (6-core) @ 3.33GHz

- 24GB RAM

- ATI Radeon HD 5770 1GB

- Windows 7 Pro x64

I've tried just about every ATI driver version from Catalyst 11.1 to 12.3 ... ... No help.

Tried different OBJs ... ... Same results.

Tried different 3DC versions ... ... ... Only pre-v3.708 versions seem to be stable and predictable when importing and displaying OBJs.

That I'm only one of the few people this is happening to makes it that much more frustrating.

EDIT>>>>> I'm using the SIMP64 versions, btw. The problem appears in both DX and GL versions.

post-1309-0-30671900-1335291374_thumb.jp

Share this post


Link to post
Share on other sites

Got a picture of the semi-transparent one. Again, appearing at random for imported OBJs on a clean 3DC session

post-1309-0-68634000-1335294980_thumb.jp

Share this post


Link to post
Share on other sites

...

Seems there are some shaders issues since shaders was changed recently.

First, please check if "Edit->Preferences->Show beta tools" enabled.

Second, I attached shader obj_tbn.hlsl - please copy it overwrite installation_folder/Shaders/onj_tbn.hlsl

Then try to import anything fot ppp. Will anything work better?

Do same problem appears in all modes - reference mesh, ppp, microverts?

Try all this on DX version.

Share this post


Link to post
Share on other sites

Excuse, I forgot. There is file:

obj_tbn.zip

check if file is overwritten over existing one.

1 person likes this

Share this post


Link to post
Share on other sites
Ok, found reason. Now fixed. I will reupload asap.
First off, Andrew, I want to thank you. Few developers work as tirelessly as you do. Even fewer respond to criticism with such aplomb. Thanks.

^ +1000 :D

Rotational performance with high poly meshes is silky smooth once again. Thank you very much, Andrew! :wub:

Edit: Is it just me, or is it actually working even better than it used to in 3.7.09? I suppose it could be a placebo effect after dealing with the awful stutter in 3.7.10, but rotating my reference mesh in 3.7.10A really does feel super smooth now. No stutters at all, not even tiny ones. B)

Share this post


Link to post
Share on other sites

Excuse, I forgot. There is file:

obj_tbn.zip

check if file is overwritten over existing one.

It's a partial solution. Let me explain.

The problem with OBJs importing and displaying in all sort of random states? That's fixed. Imported models now display predictably. I don't worry about it randomly importing as some blotchy or semi-transparent mess anymore. Having said that, the reason why it's a partial solution is as follows:

1. Importing an OBJ for PPP works beautifully. The default shading mode is a smooth relief and everything displays as expected. Every time.

2. Same perfect and and predictable results with microvertex

3. Importing an OBJ as a reference results in a default shading mode of flat. Every time. I can click "1" to get back into relief mode just fine. After that, every other model imported in that 3DC session will be in relief mode too. However, if I restart 3DC, it reverts my default shading mode to flat again. This is the same exact problem I've been having since v3.708.

post-1309-0-11598800-1335362008_thumb.jp

Share this post


Link to post
Share on other sites

Thanks for testing!

Now try to replace 2 files:

1) I reverted obj_tbn.hlsl back because probably problem is in other file

2) I add missed file emptygrey.dds

Files.zip

Share this post


Link to post
Share on other sites

That looks like it did the job. B) Works reliably and predictably in PPP, Microvert, AND reference mesh now, Thanks a lot, Andrew.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.