View Issue Details

IDProjectCategoryView StatusLast Update
00011063D-Coat v4.1Retopo roompublic2014-09-08 04:47
ReportercarlosaAssigned Tocarlosa 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0001106: For a better Auto retopology - place an edgeloop exactly along a stroke guide
DescriptionAdd the ability to auto retopologise but specify exact positions of edges.

[quote name='Harvey Greensall' timestamp='1366225501' post='90058']
For instance we've got really high res. meshes of shoes that need dropping down to about 10,000 polys, and using the existing guides we can make the polys run in a useable manner but we can't draw in a guide that says 'this is a definite edge position' so for instance where a shoes upper meets the sole. Where there is a seam in the actual shoe that needs an edge for smoothing groups etc.

Many thanks in advance!
[/quote]
Steps To Reproduce[quote name='AbnRanger' timestamp='1366237335' post='90063']
I agree with you on that. It would be nice if we could force the algorithm to place an edgeloop exactly along a stroke guide.
[/quote]

[quote name='puntoit' timestamp='1366268313' post='90068']
In the lastest version of mudbox you can now define edges that should be followed exactly and others to be designed as rough guides. Maybe we can have something like that for some future build.
[/quote]
Additional Informationhttp://3d-coat.com/forum/index.php?showtopic=11804
TagsNo tags attached.

Activities

AbnRanger

2013-04-19 04:43

reporter   ~0002855

+1.

What I would like to see is perhaps colored strokes, that give specific instructions to the algorithm. Red might dictate strict adherence to place edgeloops precisely along the stroke. Blue could define fewer edgeloops along the stroke (perpendicular to the stroke).

AbnRanger

2013-06-04 22:40

reporter   ~0003050

Bump

carlosa

2013-06-28 12:38

administrator  

346135m.jpg (779,463 bytes)
346135m.jpg (779,463 bytes)

carlosa

2013-06-28 12:40

administrator   ~0003144

http://www.polycount.com/forum/showpost.php?p=1868999&postcount=66
-------------------------------
Swizzle's
Swizzle on Today 01:51 AM

Basically, it's kind of a big deal. With other auto-retopo solutions, you get polygon distribution and layout that's far too uniform to be useful right out of the gate as a game and/or animation-ready mesh. With ZRemesher, a lot of the headaches associated with auto-retopo have been alleviated. The polygon layout and distribution is great, the control curves are actually useful, and the final mesh doesn't have as much of that annoying crap where a quad cuts across a sharp crease or angle in a strange way.

It's by no means perfect, but almost every model I've thrown at it has gotten me useful, useable results. Previously, auto-retopo tools would mainly spit out models that were only really useful for high-end sculpting applications because of their weird geo.

AbnRanger

2013-06-28 18:06

reporter   ~0003151

Last edited: 2013-06-28 18:16

View 2 revisions

+1. Yeah, this is the very reason I have never used Auto Retopo that much. Usually just on secondary objects, like buckles, belts, bracelets, rings, etc....where it can do a good job on primitive type objects, or objects that don't necessarily need perfect geometry.

Pixologic spent time refining this algorithm, to where it appears to solve many of the issues normally associated with Auto Retopology. I don't think it's so imperative for Mudbox to have this type of functionality, as it has always been positioned as a sculpting/painting app...not one for model construction.

However, it is important for both ZBrush and 3D Coat to offer this level of efficiency regarding auto-retopology. Why? Because they both offer a solid alternative to modeling in traditional 3D apps.

The downside has always been that it appears to take longer to model in these apps because you then have to retopologize afterward. To studio heads and Art Directors, time is money...literally. This is a big step forward, and at least it shows it can be done. They mention curvature analysis. I would also hope to see a planar surface analysis. Meaning there will be much fewer edgeloops where surfaces are found to be planar or near planar (within 10-20 degrees?), and wherever there is a sharp angle contrast, an edgeloop should be placed there

carlosa

2013-06-29 14:36

administrator  

retopo compair.jpg (1,413,058 bytes)
retopo compair.jpg (1,413,058 bytes)

carlosa

2013-06-29 14:36

administrator  

retopo compair2.jpg (1,221,597 bytes)
retopo compair2.jpg (1,221,597 bytes)

Zeddicus

2013-07-02 21:53

reporter   ~0003156

+1 Just like psychoacoustic and psychovisual algorithms in the field of audio/video compression, auto-retopology is likewise one of those areas that will always have room for improvements and tweaking no matter how far it has already come. What we're seeing is the evolution of this technology and I'm hopeful that some day it'll get so good that we can use the generated output straight off with little to no post repair work required. Pixologic is proving it's entirely within the realm of possibility, so maybe someone will now look into improving 3D Coat's autopo algorithm to match, or better yet one up the competition just as they've now done with Zremesher. I hate extra (entirely avoidable) work as much as anybody, and sadly autopo hasn't been particularly useful due to the fact it's easier to just retopo manually than try to fix what 3DC generates automatically (messy topology, triangles, ngons, lot's of holes and other varying levels of weirdness).

One thing I had in mind is giving the user different types of curves they can draw onto the high poly mesh. For example a hard edge/crease curve that tells the algorithm which areas should be sharp as a tack. You could even give the user an aid for drawing these curves, something which works similar to the polygonal lasso tool in Photoshop where you would click multiple times to create distinct beginning, middle, and end points for an hard edge (as opposed to free drawing a curve like we do now), perhaps along with a degree field similar to how auto-smoothing groups work in 3ds Max for automatic placement. Painting areas of density could be improved as well. Instead of just painting where you want more edges, you could also paint where you want less detail. Another thing that springs to mind is how you can paint areas of attraction and repelling when doing UV's in ZBrush (indicated by using red and blue paint). Surely one could do something similar for topology creation.

No doubt there are a lot of good ideas out there as to how much input and control an artist should have over how the final retopo mesh is generated and hopefully people will add them here. No doubt some aspects of a truly amazing auto-retopo algorithm requires code that is nothing short or mind reading AI lol. This is where the artists input will be most valuable and it's important to get it right. Better all this prep work than having to spend forever fixing the badly garbled mesh it spat out, or worse not using a feature you paid for at all (nothing generates bad word of mouth faster than disappointment).

Malo

2013-07-26 07:29

reporter   ~0003201

+1

carlosa

2013-09-14 03:54

administrator   ~0003239

V4_07
Users strokes will create exact edges if tangent post-smoothing is turned off

carlosa

2014-05-25 19:29

administrator   ~0003735

v4.1.8A

without decimate or voxelice the result is very good... almost near

but

using decimate or voxelice... stokes are not followed

carlosa

2014-08-10 02:39

administrator   ~0003868

I was reading about CySlice
http://www.headus.com.au/3d-tools/cyslice

CySlice has been used here to fit topologically identical polymeshes to two different 3D scans, then a pair of normals maps are extracted from the hirez scan data. In the animation, the polymeshes are interpolated between to morph the 3D shape, and the normal maps are blended to create the varying texture over the surface.

Big goal will be to do the same using 3DC
http://www.youtube.com/watch?gl=US&v=luuWwbkeu6g

ty

Issue History

Date Modified Username Field Change
2013-04-19 04:38 carlosa New Issue
2013-04-19 04:38 carlosa Status new => assigned
2013-04-19 04:38 carlosa Assigned To => carlosa
2013-04-19 04:43 AbnRanger Note Added: 0002855
2013-06-04 22:40 AbnRanger Note Added: 0003050
2013-06-28 12:38 carlosa File Added: AUTORETOPO_TWEAK.jpg
2013-06-28 12:38 carlosa File Added: 346135m.jpg
2013-06-28 12:40 carlosa Note Added: 0003144
2013-06-28 12:42 carlosa Priority normal => high
2013-06-28 12:42 carlosa Severity feature => major
2013-06-28 12:42 carlosa Product Version => 4.0.04
2013-06-28 12:42 carlosa Target Version BETA 15 => 4.0.04
2013-06-28 12:42 carlosa Summary Auto retopology - place exact polygon edges => For a better Auto retopology - place exact polygon edges
2013-06-28 13:00 carlosa Summary For a better Auto retopology - place exact polygon edges => For a better Auto retopology - place an edgeloop exactly along a stroke guide
2013-06-28 18:06 AbnRanger Note Added: 0003151
2013-06-28 18:16 AbnRanger Note Edited: 0003151 View Revisions
2013-06-29 14:34 carlosa File Deleted: AUTORETOPO_TWEAK.jpg
2013-06-29 14:36 carlosa File Added: retopo compair.jpg
2013-06-29 14:36 carlosa File Added: retopo compair2.jpg
2013-07-02 21:53 Zeddicus Note Added: 0003156
2013-07-26 07:29 Malo Note Added: 0003201
2013-09-14 03:54 carlosa Note Added: 0003239
2014-05-09 13:32 carlosa Project 3D-Coat v4 => 3D-Coat v4.1
2014-05-09 13:32 carlosa Category Retopo room => General
2014-05-25 19:29 carlosa Note Added: 0003735
2014-08-10 02:39 carlosa Note Added: 0003868
2014-08-10 02:42 carlosa Priority high => normal
2014-08-10 02:42 carlosa Severity major => feature
2014-08-10 02:42 carlosa Category General => Retopo room
2014-08-10 02:42 carlosa Product Version 4.0.04 =>
2014-08-10 02:42 carlosa Target Version 4.0.04 =>
2014-09-08 04:47 carlosa Status assigned => resolved
2014-09-08 04:47 carlosa Resolution open => fixed