MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
00014403D-Coat v4Paint roompublic2014-03-14 00:032014-04-09 20:58
Reporterajz3d 
Assigned ToAndrew 
PriorityhighSeveritymajorReproducibilityalways
StatusfeedbackResolutionreopened 
PlatformPCOSWindows 7OS Version(64 Bit)
Product Version4.0.16 
Target VersionFixed in Version 
Summary0001440: Strokes go crazy when vertex painting near edges
Description4.0.17 and older
I don't know why, but strokes show up in random places when I paint over vertices. Check out the video I recorded. I also uploaded a scene file that you can use for testing. The bug is 100% reproducible.
TagsNo tags attached.
Attached Files? file icon vertexPainting_bug.mp4 [^] (1,628,463 bytes) 2014-03-14 00:03
7z file icon scene.7z [^] (679,022 bytes) 2014-03-14 00:04
? file icon vertexPainting_video2.mp4 [^] (1,470,085 bytes) 2014-03-14 16:26
? file icon brush.3dcpack [^] (16,485 bytes) 2014-03-14 16:27
? file icon vertexPainting_video3.mp4 [^] (440,265 bytes) 2014-03-14 16:38

- Relationships

-  Notes
(0003612)
Andrew (administrator)
2014-03-14 09:20

Seems scene is different from video, I still can't reproduce.
Please check:

- does all depend on current voxel tool? Try painting in paint room after setting "Draw" as current voxel tool and "LiveClay" as current tool.
(0003615)
ajz3d (reporter)
2014-03-14 16:30

I recorded another video that uses the test object I initially uploaded. You'll also find a brush I'm using on both videos.

I didn't send the original object from video one, because it's 66MB compressed and wouldn't pass through my mailbox. However, if you really need it I can divide it into smaller volumes and send it in multiple e-mails.
(0003616)
ajz3d (reporter)
2014-03-14 16:36

It's not connected to voxel room tools. It doesn't matter whether Draw, LiveClay, Move or any other tool is selected.
(0003617)
ajz3d (reporter)
2014-03-14 16:39

I uploaded another video that shows how to reproduce the bug with the test scene. This one's even better.
(0003619)
Andrew (administrator)
2014-03-17 11:08

fixed in 4.0.17B or later
(0003681)
ajz3d (reporter)
2014-04-09 20:58

Problem still present in 4.1.

- Issue History
Date Modified Username Field Change
2014-03-14 00:03 ajz3d New Issue
2014-03-14 00:03 ajz3d Status new => assigned
2014-03-14 00:03 ajz3d Assigned To => Andrew
2014-03-14 00:03 ajz3d File Added: vertexPainting_bug.mp4
2014-03-14 00:04 ajz3d File Added: scene.7z
2014-03-14 09:20 Andrew Note Added: 0003612
2014-03-14 09:20 Andrew Status assigned => feedback
2014-03-14 16:26 ajz3d File Added: vertexPainting_video2.mp4
2014-03-14 16:27 ajz3d File Added: brush.3dcpack
2014-03-14 16:30 ajz3d Note Added: 0003615
2014-03-14 16:30 ajz3d Status feedback => assigned
2014-03-14 16:36 ajz3d Note Added: 0003616
2014-03-14 16:38 ajz3d File Added: vertexPainting_video3.mp4
2014-03-14 16:39 ajz3d Note Added: 0003617
2014-03-17 11:08 Andrew Note Added: 0003619
2014-03-17 11:08 Andrew Status assigned => resolved
2014-03-17 11:08 Andrew Resolution open => fixed
2014-04-09 20:58 ajz3d Note Added: 0003681
2014-04-09 20:58 ajz3d Status resolved => feedback
2014-04-09 20:58 ajz3d Resolution fixed => reopened


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker