View Issue Details

IDProjectCategoryView StatusLast Update
00002033D-Coat v3.xPaint roompublic2011-04-19 08:48
ReporterguestAssigned ToAndrew 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformwindowsOSvistaOS Version64bit
Product Version 
Target VersionFixed in Version 
Summary0000203: memory leak/crash on import for per-pixel paint
Descriptionimporting an obj for per-pixel painting causes 3dC to chew up all memory, then the page file, and just stall out the entire systems. I was only able to stop it by forcing a shutdown. Repeatable with two different meshes.
Steps To Reproduceimport for per-pixel painting. First dialog shows up, chose the basic options (eg texture resolution) and then upon okaying that it just spirals out of control.
TagsNo tags attached.

Activities

haikalle

2011-03-20 16:59

developer   ~0000438

Hi!

Is it possible to share the mesh where problems shows. Did some testing but wasen't able to repeat this bug. Thanks.

guest

2011-03-21 00:51

viewer  

night_stand_for_UV_base.obj (4,774,655 bytes)

guest

2011-03-21 00:52

viewer   ~0000447

Here is one of the meshes that is causing the problem. I tried a simpler object and it imported fine. this one, and at least one other model from this same project were causing the memory overload.

I was attempting to send it to 3DC via the applink script to re-UV it. Importing for per-pixel paint also creates the same problem.

haikalle

2011-03-21 08:24

developer   ~0000449

Confirmed.

guest

2011-03-21 08:28

viewer   ~0000451

Thanks :)

Brett

Andrew

2011-04-12 23:14

administrator   ~0000545

This problems happens ofthen if model have random or incorrrect UV set. This modet has square of UV set = 130. It is really huge. Like 130 UV sets. So such models should be loaded with Auto-mapping and then get UV set correction. To avoid such problem in future I made detection of incorrect UV sets. In this case warning will be shown - "The square of UV set is too big. It may mean that UV set is incorrect or tiled too much. It may lead to long loading time or crash because of lack of memory. We recommend you use auto-mapping and then use UV tools to create correct UV set."

simmsimaging

2011-04-19 08:48

reporter   ~0000617

Thanks Andrew - noted.

Issue History

Date Modified Username Field Change
2011-03-20 05:37 guest New Issue
2011-03-20 16:59 haikalle Note Added: 0000438
2011-03-21 00:51 guest File Added: night_stand_for_UV_base.obj
2011-03-21 00:52 guest Note Added: 0000447
2011-03-21 08:23 haikalle Assigned To => Andrew
2011-03-21 08:23 haikalle Status new => assigned
2011-03-21 08:24 haikalle Note Added: 0000449
2011-03-21 08:28 guest Note Added: 0000451
2011-04-12 23:14 Andrew Note Added: 0000545
2011-04-12 23:14 Andrew Status assigned => resolved
2011-04-12 23:14 Andrew Resolution open => fixed
2011-04-19 08:48 simmsimaging Note Added: 0000617