View Issue Details

IDProjectCategoryView StatusLast Update
00002463D-Coat v3.xOtherpublic2011-12-12 22:32
ReportergeothefaustAssigned Togeothefaust 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindows 7OS Version64bit
Product Version 
Target VersionFixed in Version 
Summary0000246: Tools not supporting Masks
DescriptionI spent a couple hours going through all of the tools in 3DC (where applicable), attempting to discover which tools do and do not work with masks.

Here are all of the tools that do not support/work with masks as of build 3.5.17D:


Voxel Room (Voxel & Surface Tools)

(Voxel) Burrow, Muscles, Spikes, Snake, Text, Curves, Primitives

(Voxel) Sphere, Plane, Scrape, Pinch

(Voxel) Pose, Move, Hide, Cell (hide), Copy, Cut&Clone

(Surface Mode) Smooth, Pinch, Shift, Fill, Move


Tools that do occasionally (but are buggy and don't work correctly)

(Voxel) Clone


Part of the confusion here, at least for the Pose tool, is that the Pose tool works with masks perfectly fine in Surface mode but does not work at all in Voxel mode.

================

Paint Room (PTEX, Per Pixel & Microvertex Modes all tested)


Shift layer in tangent space (all modes, Smudge, Collapse & Expand)
Clone (All modes, Translation, Mirrring, Inversion, Clone Sector, Smmetrical Copy, Copy using pen)
Transform/Copy (Copying and pasting)
Text tool
Eraser tool
Hide tool
Flatten
Topological symmetry

================

Sculpt Room

All tools (Move, Select/Move, Drag points, Draw, Collapse, Expand, Shift, Smudge, Flatten, Smooth)
Steps To ReproducePick any of the tools listed above
Select a mask
Attempting to paint or sculpt with mask applied
Additional InformationIf any screenshots or demo videos are required, please just let me know.
TagsNo tags attached.

Activities

geothefaust

2011-06-24 22:16

developer   ~0000725

Any update on this?

haikalle

2011-06-26 17:58

developer   ~0000729

Last edited: 2011-06-26 18:00

View 2 revisions

I think that some work has done already to solve this issue. Because (Voxel) Plane, Scrape already works.

I'm not quite sure how (Voxel) Burrow, Muscles, Spikes, Snake should work with masks.

But I can confirm that pose tool dosen't work with masks in voxel mode.

haikalle

2011-11-07 13:01

developer   ~0001222

Last edited: 2011-11-07 13:04

View 2 revisions

Now Pose tool does work with mask. I'm not sure do we need to keep this report still open?

Andrew

2011-11-07 16:32

administrator   ~0001237

It is rather feature request IMO. Most of tools are not easy to do compatible with mask.

geothefaust

2011-12-12 22:32

developer   ~0001322

Pose tool now works with masks. Other tools considered feature request.

Issue History

Date Modified Username Field Change
2011-04-17 10:40 geothefaust New Issue
2011-04-17 10:40 geothefaust Status new => assigned
2011-04-17 10:40 geothefaust Assigned To => Andrew
2011-06-24 22:16 geothefaust Note Added: 0000725
2011-06-26 17:58 haikalle Note Added: 0000729
2011-06-26 18:00 haikalle Note Edited: 0000729 View Revisions
2011-11-07 13:01 haikalle Note Added: 0001222
2011-11-07 13:04 haikalle Note Edited: 0001222 View Revisions
2011-11-07 16:32 Andrew Note Added: 0001237
2011-12-12 22:32 geothefaust Note Added: 0001322
2011-12-12 22:32 geothefaust Status assigned => resolved
2011-12-12 22:32 geothefaust Resolution open => fixed
2011-12-12 22:32 geothefaust Assigned To Andrew => geothefaust