View Issue Details

IDProjectCategoryView StatusLast Update
00000323D-Coat v4Retopo roompublic2014-05-09 05:03
ReportergeothefaustAssigned ToAndrew 
PriorityhighSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
PlatformN/AOSN/AOS VersionN/A
Product Version 
Target VersionFixed in Version 
Summary0000032: Retopo Groups Color Coding & Locking
DescriptionThe ability to change the color of a retopo mesh has become a necessity. If there were a color swatch in the retopo groups for which a user could define a color would drastically enhance work flow and ease of use of 3DC for retopology.

The idea is, the user clicks the swatch, this prompts with the color picker, the user chooses a color and once complete the swatch color will change to what the user has selected. Thus the retopo mesh it is associated with also changes color in the 3D viewport.

Notice also a few small tweaks; The text name is right aligned, There is now also a LOCK icon to lock the mesh from editing and also a color SWATCH icon for the aforementioned change.

Check the attached mock-up for more details.
TagsNo tags attached.

Activities

geothefaust

2010-10-25 08:58

developer  

Taros

2010-10-25 16:05

administrator   ~0000018

The idea is nice.
In my opinion the text align should be always optional and defined by the user (text align: left, center, right).

haikalle

2010-12-08 12:52

developer   ~0000038

Agree very nice feature. But I think text should be in the center as it is right now. If Andrew wants to add option for text alignment that's fine. But center should be the default. But color box idea is very good.

geothefaust

2011-02-27 09:41

developer   ~0000356

Any word on this?

Agree with you guys on the text align. :)

webadministrator

2011-06-07 12:36

administrator   ~0000693

I have changed permission for guest user and have deleted post with spam links. Thanks for reporting.

geothefaust

2011-09-03 07:54

developer   ~0000869

This was added almost a year ago. Any word on this? I think that custom colors per retopo group/layer is a very good feature to have.

Taros

2011-09-05 09:33

administrator   ~0000887

@Andrew: Can you give some status info about this feature request?

Bal

2012-06-18 17:02

reporter   ~0001456

Still no news on this?

Feels like 3D-Coat is really lagging behind with topology just because of this problem, especially when working on a mesh that already has UVs.
Your retopo meshe ends up with some random ultra-saturated color with checkers over it, making it impossible to see the reference mesh underneath (even when tweaking the lighting settings).

Ideally I want the retopo mesh material to be almost completely transparent, just having a slider somewhere to determine the transparency would be enough (Topogun gives much better options for this for example).

(Posted a second screenshot just to illustrate the problem, hope that's ok).

Bal

2012-06-18 17:02

reporter  

3dc_retopocolors.jpg (233,028 bytes)
3dc_retopocolors.jpg (233,028 bytes)

philnolan3d

2012-07-09 07:17

developer   ~0001481

Another theory I had, which is similar to what Javis said above, was to have a specific color palette that the user can set with whatever colors they want and save it as an ACO file like the other palettes. 3DC would look for a certain file name and use only those colors randomly, if that file name is not found it just uses the current method.

pixo

2012-08-28 23:13

reporter   ~0001685

+1
I'm retopo-ing a character this time and i just find this color organisation is missing from 3D Coat.
Hope andrew want to integrate something similar at least.

carlosa

2012-11-18 13:21

administrator   ~0002033

+1
mark seams over a blue retopo give BIG troubles

ajz3d

2013-01-04 16:11

reporter   ~0002184

This is absolutely a must. Sometimes the automatic colour 3D Coat assigns to retopo groups makes working in Retopo Room a nightmare for human eyes (e.g. black edges on dark blue faces).

carlosa

2013-02-12 13:00

administrator   ~0002421

absolutely must

Im doing a manual retopo over a WHITE retopo mesh :P

carlosa

2013-02-12 15:40

administrator  

RETOPOWHITE.jpg (173,685 bytes)
RETOPOWHITE.jpg (173,685 bytes)

stry

2013-02-12 15:42

reporter   ~0002422

+1!

Andrew

2013-02-14 13:32

administrator   ~0002433

Each group can't have separate color because each cluster, not each group has own color. So this request can't be fulfilled exactly and still stays unresolved. I may do customization of palette used across all clusters. Will it be enough?

stry

2013-02-14 13:37

reporter   ~0002434

That would be a big help.

Zeddicus

2013-02-14 16:14

reporter   ~0002435

Select the mark seams button. Now you can use the drop down menu of the UV checker to load any bitmap you want. I have a number of custom ones, including a few 64x64 bitmaps of basic colors which come in handy, especially when making selections and marking seams (yellow on green is common and horrid).

Other ways to possibly aid visibility include the ambient and primary lighting controls, view menu, z-bias slider, opacity slider, the hide menu, and theme preferences to a degree.

None of that is an ideal solution compared to adding new features, but better than nothing if your having difficulty. I would love more control over wireframe and selection colors on the fly too.

carlosa

2013-02-14 16:53

administrator   ~0002436

customization of palette used across all clusters...
Will it be enough for sure !!

BIG BIG help. :D ty

digman

2013-02-14 17:49

reporter   ~0002437

Last edited: 2013-02-14 17:50

View 2 revisions

Please if all at possible add this to 3DCoat. I was helping a user through Skype and his retopo mesh was bright green in the area he was working on making it almost impossible to select the uv seams...

+1 on all the other reasons as well.

geothefaust

2013-02-26 00:41

developer   ~0002562

Hi Andrew, what do you mean exactly by each cluster does so each group cannot? I'm not following exactly why each group cannot have their own colour as specified by the user, when each group already has it's own colour.

Thanks.

PalSan

2013-03-21 05:51

developer   ~0002716

+1

Issue History

Date Modified Username Field Change
2010-10-25 08:58 geothefaust New Issue
2010-10-25 08:58 geothefaust File Added: RetopoGroups-ColorCoding-001.jpg
2010-10-25 16:02 Taros Severity tweak => feature
2010-10-25 16:02 Taros Summary [FEATURE REQUEST] Retopo Groups Color Coding & Locking => Retopo Groups Color Coding & Locking
2010-10-25 16:03 Taros Additional Information Updated View Revisions
2010-10-25 16:05 Taros Note Added: 0000018
2010-12-08 12:52 haikalle Note Added: 0000038
2010-12-09 10:52 geothefaust Priority normal => high
2011-02-27 09:41 geothefaust Note Added: 0000356
2011-06-05 01:22 guest Note Added: 0000691
2011-06-05 08:17 guest Note Edited: 0000691 View Revisions
2011-06-06 10:29 guest Note Edited: 0000691 View Revisions
2011-06-07 12:20 guest Note Edited: 0000691 View Revisions
2011-06-07 12:21 guest Note Edited: 0000691 View Revisions
2011-06-07 12:21 guest Note Added: 0000692
2011-06-07 12:28 guest Note Edited: 0000691 View Revisions
2011-06-07 12:36 webadministrator Note Added: 0000693
2011-09-03 07:54 geothefaust Note Added: 0000869
2011-09-05 09:33 Taros Note Added: 0000887
2011-09-05 09:33 Taros Assigned To => Taros
2011-09-05 09:33 Taros Status new => feedback
2011-09-05 09:33 Taros Assigned To Taros => Andrew
2011-09-05 09:33 Taros Status feedback => assigned
2012-06-18 17:02 Bal Note Added: 0001456
2012-06-18 17:02 Bal File Added: 3dc_retopocolors.jpg
2012-07-09 07:17 philnolan3d Note Added: 0001481
2012-08-28 23:13 pixo Note Added: 0001685
2012-10-29 10:38 Taros Project 3D-Coat v3.x => 3D-Coat v4
2012-11-18 13:21 carlosa Note Added: 0002033
2013-01-04 16:11 ajz3d Note Added: 0002184
2013-02-12 13:00 carlosa Note Added: 0002421
2013-02-12 15:40 carlosa File Added: RETOPOWHITE.jpg
2013-02-12 15:42 stry Note Added: 0002422
2013-02-14 13:32 Andrew Note Added: 0002433
2013-02-14 13:32 Andrew Status assigned => feedback
2013-02-14 13:37 stry Note Added: 0002434
2013-02-14 16:14 Zeddicus Note Added: 0002435
2013-02-14 16:53 carlosa Note Added: 0002436
2013-02-14 17:49 digman Note Added: 0002437
2013-02-14 17:50 digman Note Edited: 0002437 View Revisions
2013-02-26 00:41 geothefaust Note Added: 0002562
2013-02-26 00:41 geothefaust Status feedback => assigned
2013-03-21 05:51 PalSan Note Added: 0002716
2014-05-09 05:03 carlosa Status assigned => resolved
2014-05-09 05:03 carlosa Resolution open => fixed