Jump to content
3DCoat Forums

TimmyZDesign

Contributor
  • Content count

    1,029
  • Joined

  • Last visited

Everything posted by TimmyZDesign

  1. I just found out about this free program written by researchers at the Swiss Federal Institute of Technology in Zurich. It performs automatic retopology and also guided semi-automatic retopology. It was demonstrated at SIGGRAPH Asia 2015. You can download it from GitHub for free (the actual compiled executable app is there). The license there says that you can use it for any purpose (including commercial purposes), also see the license there for any further questions. I haven't had a chance to try it yet, but I am interested to see how it compares to 3D-Coat's Autopo or Zbrush's Zremesher. Demo video: https://www.youtube.com/watch?v=U6wtw6W4x3I Download from GitHub here: https://github.com/wjakob/instant-meshes I will try to test it sometime this week if/when I get time. If you test it out, please post your results in this thread!
  2. TimmyZDesign

    V4.5 BETA (experimental)

    Did you try adjusting the settings in the Tool Options panel? There are a lot of settings there which will help you orient the model's rotation, offset, etc. for "On Brush". Also you can turn off view of the brush alpha in the User Preferences. Not sure if you tried all of that already or not, but I thought I'd mention it just in case...
  3. TimmyZDesign

    importing

    Ajz3d, please post a link to your Mantis report. I can't find it. Andrew and Carlos are researching these bugs and can't reproduce them.Also, where is the thread that you were discussing this bug with another user? Was that you, or some other users? I remember it from a while ago, but I am having trouble finding it again now. EDIT: Ok I found it! The problems you were having are related to the Pose Tool. The discussion is here: http://3dcoat.com/forum/index.php?showtopic=19116 And the Mantis report is here: http://3dcoat.com/mantis/view.php?id=2095
  4. TimmyZDesign

    importing

    I think that's a 3D-Coat bug. If a part of the model is below the "floor" when imported, then it gets split at the floor. This bug has been mentioned by several other users. However, I don't think an official bug report has been created on Mantis.The workaround is to raise the model above the floor and the split no longer occurs when importing.
  5. TimmyZDesign

    V4.5 BETA (experimental)

    You should probably PM one of the mods (Carlosan, Javis, etc.). I don't know how strict they are with the rules, maybe they will accommodate your request.
  6. TimmyZDesign

    V4.5 BETA (experimental)

    So I did some more tests with a bunch of different OBJs, and some seem to work and some don't. I'll send Andrew an OBJ that doesn't work at some point. Maybe those files are corrupted or maybe there is a difference depending on where the OBJ was generated, or perhaps there is something else special about them. Anyways, I don't want to troubleshoot it anymore, so I'll just be using the Retopo Room import workaround. That's good enough for me for now.But thank you so much Gary for offering to help! People like you make this community great!
  7. TimmyZDesign

    V4.5 BETA (experimental)

    So I updated the driver for my Quadro k4000, and now CUDA works in 3D-Coat again! The update info said it was now using CUDA 7, so I guess that means 3D-Coat is using CUDA 7 too (since it is working again).Thanks for the help everyone!
  8. TimmyZDesign

    Smooth subdividing to make a high res mesh?

    Thanks for your help Carlosan! It still doesn't work for me. I'm trying to figure out why...
  9. TimmyZDesign

    V4.5 BETA (experimental)

    Still doesn't work for me. I wonder why? Can anyone else confirm please?
  10. Just FYI, I discovered a bug in the Import Tool. The "Subdivide" button is currently not working correctly. It is supposed to subdivide AND smooth, but it is only subdividing right now. The button "Flat Subdivision" is for only subdividing without smoothing. Unfortunately the "Subdivide" button is doing the same thing as the "Flat Subdivision" button right now. I reported this bug to Andrew and hopefully he will fix it soon. In the meantime there is a workaround. You can first import your mesh into the Retopo Room, then go to the Sculpt Room, click on the Import Tool, and choose "Pick From Retopo". If you use that method, then the "Subdivide" button will work correctly. Strangely, it doesn't work with the "Select Mesh" button right now.
  11. TimmyZDesign

    V4.5 BETA (experimental)

    Bug Report: The "Subdivide" button in the Tool Options of the Sculpt Room Import Tool is not working correctly. Currently it acts the same as the "Flat Subdivision" button. The "Subdivide" button should subdivide AND smooth, not just subdivide. This button works correctly if the "Pick From Retopo" button is used, but it does not work if the "Select Mesh" button is used. Please fix this. Thank you!
  12. TimmyZDesign

    Smooth subdividing to make a high res mesh?

    Ok, so I just tested out the Import Tool to make sure about this, and it is not working correctly. There is a bug in there somewhere, and we need to report it to Andrew! The "Subdivide" button in the Tool Options is SUPPOSED TO use Catmull Clark subdivision, in other words, it is supposed to subdivide AND smooth. The button called "Flat Subdivision" is supposed to subdivide WITHOUT smoothing. I know this is a bug because the tool works correctly if you use the "Pick From Retopo" button. For example, if you import your mesh into the Retopo Room first, then go to the Sculpt Room, use the Import Tool there, and click on "Subdivide" in the Tool Options you will see that it is subdividing AND smoothing. If you use the "Select Mesh" button instead, then you will see that the "Subdivide" button stops working correctly. It is definitely a bug.
  13. How about:First import the subdivided high poly into the Sculpt Room, paint on it with the vertex paint method, then Import the low poly (with its UVs) to the Retopo Room, then Bake the vertex paint to the low poly, which will send the low poly to the Paint Room (with its UVs), and then finish up painting any last things on the low poly in the Paint Room. Finally export the low poly with texture maps.
  14. TimmyZDesign

    Smooth subdividing to make a high res mesh?

    Yes, as Candy-floss said, there is a button in the Tool Options panel "Import Without Voxelization" which will import the mesh as a surface, not as voxels. Don't forget to also click on the "subdivide" button to get the smoothed subdivision level you want. Each time you click it, it will subdivide and smooth more.
  15. TimmyZDesign

    Smooth subdividing to make a high res mesh?

    Did you try the Import Tool in the Sculpt Room? There is a tool there in the toolbar called "Import". In the Tool Options of that tool there is a "Select Mesh" button. Click on that to choose your model. If you don't see your model, then use the transform gizmo to scale it up until you see it in the viewport. There is a "subdivide" button there in the Tool Options too. The subdivision used there actually smooths the mesh in addition to subdividing it. When using that tool you will see a preview before importing. Click on the "Apply" button to commit the import, then switch to a different tool to get rid of the preview. Then you can go to the Retopo Room and perform retopo on it. I don't know if that is the workflow you are looking for, but you can try it out if you want.
  16. You can also try to import the model in the Sculpt Room. There is a tool there in the toolbar called "Import". In the Tool Options of that tool there is a "Select Mesh" button. Click on that to choose your model. If you don't see your model, then use the transform gizmo to scale it up until you see it in the viewport. There is a "subdivide" button there in the Tool Options too. The subdivision used there actually smooths the mesh in addition to subdividing it. When using that tool you will see a preview before importing. Click on the "Apply" button to commit the import, then switch to a different tool to get rid of the preview. Then you can go to the Paint Room and vertex paint it if you want. I don't know if that is the workflow you are looking for, but you can try it out if you want.
  17. TimmyZDesign

    V4.5 BETA (experimental)

    Ok, I'll check the Quadro drivers. Maybe a newer or older driver will fix it. Thanks Michael!
  18. TimmyZDesign

    V4.5 BETA (experimental)

    But those are both GTX. Maybe CUDA is not working for Quadro cards?
  19. TimmyZDesign

    V4.5 BETA (experimental)

    Thank you! That's exactly what I was looking for! It says there that each card has a "CUDA compute capability" number. All the legacy cards have 2.0 or lower. Actually now I remember that I used to have a Quadro FX 3800 that didn't work with Blender Cycles GPU because the compute capability was too low. I got rid of that card a long time ago... Anyways, my Quadro k4000 has a 3.0 compute capability. It's not listed as legacy, but it still doesn't work with the latest 3D-Coat CUDA betas. I wonder how much compute capability 3D-Coat CUDA is requiring now? Shouldn't 3.0 be enough?
  20. TimmyZDesign

    V4.5 BETA (experimental)

    Is there a list somewhere saying which graphics cards and drivers are no longer supported? I've noticed some newer Quadros don't work with Cuda 3D-Coat, while other cards do...
  21. TimmyZDesign

    Retopo mesh/Reference mesh change color?

    Hi alan f, There is a better way to import your model instead of using the "perform retopo" option on the intro menu. I have experienced bugs with several of those options, and also some of those options limit the funcionality of 3D-Coat, so I don't use them. Step 1: When first opening 3D-Coat, and you see that initial intro menu, just close it. Step 2: 1) Go to the Sculpt Room. 2) Select the Import Tool. 3) Turn on "Import without Voxelization". 4) Select your mesh with the file browser. 5) A preview of your mesh will be generated. If you can't see the mesh, most likely you will need to scale it up with the Transform Gizmo. As you scale it up you will see the "Estimated Poly Count" go up (shown in the middle of the Tool Options panel), but that number doesn't mean anything if you are importing without voxelization. Therefore in this case you can safely ignore the "Estimated Poly Count". 6) Once your mesh fits into the viewport nicely, then click on Apply and your mesh will finally be imported into 3D-Coat. The import preview however still remains, so you need to switch to a different tool to get rid of the preview. Step 3: Choose any other tool to get rid of the import preview. Step 4: Now you can finally see your reference mesh in both the Sculpt Room and the Retopo Room. If your mesh does NOT have any vertex color data associated with it (known as "polypaint" in Zbrush), then you can now change the color of your reference mesh by changing its shader. Step 5: If however there is in fact vertex color data on your mesh, then changing the shader will have no effect. You will need to go to the Paint Room, turn off visibility of the vertex color (by clicking on the "eye" icon next to the vertex color layer), which will make the shader visible underneath. Then you will finally be able to change the look of the shader in the Retopo Room.
  22. TimmyZDesign

    Retopo mesh/Reference mesh change color?

    To change the reference mesh color: Step 1: Go to the Sculpt Room. 2. Pick a different shader with a color that you prefer. 3. Or if none of the default shaders are ok, then you can create a new shader with any color you like. Simply right-click on any shader and choose "Construct New Shader". 4. Give the new shader a name. 5. Change the colors to whatever you want. 6. Now you have a new shader in the Shader Panel. 7. Apply the shader to your reference mesh and return to the Retopo Room. 8. Just for clarification, all you really need to access is the Shader Panel (which is available from the Windows menu). The Sculpt Room has the Shader Panel open by default, so it is slightly easier to just go there for quick access (instead of opening the Shader Panel in the Retopo Room).
  23. TimmyZDesign

    Where is my shaders?

    Most likely the person who made the instructional video just created a bunch of his/her own custom shaders. Those custom shaders are probably the ones you see in the video. Step 1: Right-click on any shader and choose "Construct New Shader" Step 2: Give the new shader a name. Step 3: Change the settings. Step 4: Now you have a new shader in the Shader Panel.
  24. TimmyZDesign

    Farsthary update channel

    Thanks Farsthary! This looks like it could be good! I like how the user can delete points and it recalculates the mesh instantly. This used in combination with the new QuadStrips, RFill, and the other existing tools could probably add up to some major time-saving! I'm hoping that it will end up being more efficient to work with this instead of messing with the fully automatic retopo routine. I can't wait to try it out!
×