Jump to content
3DCoat Forums

Hammers

Advanced Member
  • Content count

    117
  • Joined

  • Last visited

Everything posted by Hammers

  1. Hammers

    3DCoat 4.9 BETA testing thread

    Thanks Sergyi, I am running 10.13.6 so as long as that's the most recent requirement hopefully all will be well. I was able to launch via security preferences to bypass the signing problem, I thought. But fingers crossed, I'll give the next build a try.
  2. Hammers

    3DCoat 4.9 BETA testing thread

    Apologies if this is answered elsewhere. I just downloaded the latest Mac beta 4.9.34, with some trepidation as Catalina was mentioned...and I'm assuming since it didn't launch on my system that Catalina is now a requirement. Are there any plans to release builds that are compatible with previous Mac OSs? I'm pretty much locked, hardware and software-wise to High Sierrra 10.13 or maybe Mojave at a pinch. I have a MacPro 5,1 12 core Xeon 3.06 GHz, 32 GB, Titan X 12 GB (metal compatible), so not a slow machine, and my 3D workhorse, but not officially able to install the latest OS (which would also kill a bunch of other software that I use). Please save me! I'll miss all these new features (especially the happier Blender compatibility), and could be a long time off getting a new machine or building a Hackintosh.
  3. Very similar to this issue from 4 years back, my voxel curve tool is misbehaving badly. I'm on Mac 10.13.6 and 3DCoat 4.8.20 I can create with the voxel curve tool, and use RMB to scale points, or LMB in combination with the E key, but I am unable to use MMB or the W key for moving curve points. Wait, looks like rotate doesn't work either, with R key. Extrude and scale only it seems. Seems like the same bug with a different hat on... https://3dcoat.com/forum/index.php?/topic/16252-solved-curve-controls-not-working-fully/ Edit: I haven't tried a beta for some time it seems, so I'll download that and see how that goes. Stand by
  4. Hammers

    [Solved] More (similar) curve tool issues

    OK all seems ok in 4.8.23, moving right along!
  5. Hammers

    Retopo to UV Room and/or Paint Room

    OK I think my confusion comes from the slight inconsistency between terminology between the UV room (which I'm more used to) and the Retopo room. I think in the UV room as you make changes you Apply the UV set, while in the Retopo room you need to hit Unwrap. Thanks for the help Carlosan.
  6. Hammers

    Retopo to UV Room and/or Paint Room

    Kind of old thread here, but I'm having a similar issue working on UVs in Retopo room, but whenever I rebake to ppp, the uvs revert in the UV room to auto seams, or the old version of UVs I'm not sure. I've deleted the paint object and surface material between bakes, but to no avail. It is not honouring the UVs I've made in the Retopo room...
  7. Hammers

    [Bug] Retopo Problem

    Still a bit confused, As per your screenshot I deleted the paint layers except layer 0. No difference. The surface material is named UVMap and deleting that did the trick. To be honest I find the interrelationships between Surface Material, Paint object, UV set and retopo mesh pretty confusing. Can you point me to a nice explanation of those, for dummies? Anyway thanks for your help. Hopefully I'll google this answer again when I forget next time
  8. Hammers

    [Bug] Retopo Problem

    I'm uploading to dropbox. I did find that workaround as I mentioned. But here is the earlier version. In this version I've already merged the ribcage in the voxel room, and it still doesn't work. But Ideally I would hope you wouldn't have to necessarily. Maybe I'm missing something, but voxel layers shouldn't necessarily correspond to retopo groups etc. Notice that in Retopo, Snap, relax, brush all fail to register the new ribcage voxels. Maybe other tools too? EDIT just retried and setting to 'Snap to Nearest' seems to work, at least with the merged voxels, but not Snap to Outer/Closest along Normal, which would make more sense I would have thought. Thanks for looking! https://www.dropbox.com/s/l6fx6dlv3eyhfzk/SnapBugDemo.3b.zip?dl=0
  9. Hammers

    [Solved] Paint/UV mess after reloading project

    Ugh! Thanks Carlosan, I knew about that one but missed it somehow!
  10. I've just reopened my project from yesterday, and the paint is all messed up. It looks like there's something weird with the UVs, but they seem to still be where I put them. The textures look ok in the 2D texture editor though. And when I switched to the tweak room, the textures look correct. Not so in the other rooms though. I'm using Mac 4.8.04 GL64. But problem is the same loading with 4.8.18B Textures seem to export OK from File>Export object and textures, but I can't continue painting in 3D view.
  11. Hammers

    [Bug] Retopo Problem

    Thanks will do now. OK Still the same in 4.8.18B Additionally I've found that deleting part of the retopo mesh to rebuild even, a lot of the time the new geometry doesn't even conform to the outer surface of the new voxels/sculpt--- e.g. using points/faces to add points, they often fall 'behind' the new sculpture parts. Here's what I'm trying to work on: I imported the retopo mesh from Blender, no problem, brought it's geometry into Sculpt room OK, added ribs overlay layers (using vox layer I think mostly, but also curves for clavicles), then going back to retopo room, can't conform/snap the old retopo mesh to the new ouside surfaces of the sculpts. I've tried merging the voxtree, that didn't help, and tried between surfaces/voxels, also no help. This is weird and frustrating. Normally 3Dcoat is my goto for retopo! OK, I think I've found a workaround. As I already had a Surface material from a previous bake to paint room, If I delete that material, the Snap command etc. work again as expected to the outer surface. This still seems like buggy behaviour though, and only by accident that I discovered a 'solution'. Seems worth looking at don't you think?
  12. Hammers

    [Bug] Retopo Problem

    Just confirming this still with 4.8.16A Mac Brush, relax, snap tools all don't help. Merging visible voxels also no help. This is a bit of a workflow killer...
  13. Yes that's what I was meaning in my previous post too. The principled shader seems to work great with 3dc textures, and an automated material node setup would be sooooo useful and timesaving. I know the node wrangler addon goes some of the way with this idea. Maybe there's some code in there that could be borrowed for this purpose.
  14. Hammers

    Setting scene scale for Blender - 3D-Coat scaling issues

    Ideally it would be great if an applink could manage the scale issues between the 2 programmes
  15. Hammers

    Smart Material scaling and adjustments.

    My gizmo seems to appear disappear fairly randomly and I can't figure out how to get it back when it's gone... any ideas? Also sometimes the preview option panel controls just don't do anything... Not sure if the mac version is less tested than the windows one, but I have so many little random intermittent problems I find it quite frustrating, and I don't usually have time to test and put together bug reports... Makes learning quite tricky
  16. Hammers

    Retopo and UV rooms

    Working on a retopo->bake project. I autopo'd to get my medium poly mesh. I was working on the UV seams when I discovered a hole in the mesh. I went to the Retopo room, repaired the mesh, but the changes weren't propagated to the UV room. So I thought I would try doing the unwrapping in the retopo room, after I discovered I needed to click mark-seams to reveal the UV tools. After baking, I found that the bake was based on my partially made UV room UVs rather than the updated retopo room mesh. Anyone suggest how best to handle this and similar situations? Thanks!
  17. Hammers

    Retopo and UV rooms

    Thanks for the suggestions. I'm still going round in circles a bit, but gradually figuring out the relations between rooms. Javis' video doesn't really mention building/editing retopo meshes based on sculpts, but ah well. Learning stuff is good.
  18. Hammers

    Retopo and UV rooms

    Further to this, I've now managed to bake the hair, and have unwrapped the head UVs in Retopo room and moved them to their own UV set. My understanding is this corresponds with the Surface Material. But I still can't figure out how to get the retopo mesh converted into a paint object, other that the already existing one for the hair. Going round in circles, please excuse all my questions EDIT: I found a way, only by baking both objects at once, which shouldn't be necessary, since it leaves less room for finessing bake settings. Does anyone know a way to successfully bake from Retopo->new Paint object when a different one already exists?
  19. Hammers

    Data types and relationships

    A lot of my confusion in learning 3D coat is exacerbated because I haven't really cracked how the different data types work together in the program. For example, until today, I've assumed that retopo mesh is the same even if you switch to the UV room, but that doesn't seem to be the case. If I tweak the mesh in the Tweak room, it updates in the UV room, but not the retopo room (where I would normally rebake a texture for example.) This is just one of many confusions I've had lately. I think it would be great to have some really clear documentation or flowcharts showing how everything interrelates, for noobs like me. How do UV sets, tiles, retopo objects, paint objects, surface materials etc. link together. What bakes to what, and why? I know the manual explains the basics, but seeing a clearly structured overview would probably help me. Thanks!
  20. Hammers

    [Solved] couldn't bake normal map

    I'm having this issue baking to the paint room too. My shader in the sculpt room isn't even using normal/bumpiness. So I don't know what gives... Edit: Trying with Bake update to Paint Layers, seems to work better, Bake w/ Normal Map has same problem ie. noisy normals.
  21. Hammers

    3DCoat 4.8 BETA testing thread

    @Michaelgdrs This looks cool, but I don't understand how you did it. So you're making objects in the retopo room then baking them somehow to the sculpt room? I haven't been able to figure that out, if that is what you're doing here.
  22. Hammers

    3DCoat 4.8 BETA testing thread

    And just confirmed in Surface mode, Draw tool. Seems like it's just a general strips problem. I'll stop spamming now That said-finally upgraded my Edu to Pro. V excited, and ready to get deeper into this tool!
  23. Hammers

    3DCoat 4.8 BETA testing thread

    Strip voxel sculpting stops working after changing strip alpha. Been messing with strips in voxel room today, using airbrush/build/extrude. I found that after changing the strip alpha around 3 times the tool would stop sculpting. If I change then, say airbrush to build then back again, the tool would function correctly again. Mac 10.12.6, v4.8.03 EDIT: Just tried in surface mode with General Clay LC mode. Same issue between one and three strip changes and tool stops working. Switch tool and back again, all good. Perhaps this is more widespread—I'll keep an eye out and report back if it happens in other circumstances. EDIT2: Tried paint room with brush tool and strips, same thing. Switch to pencil and back -> correct behaviour.
  24. I've just been thinking the same thing. At least the principled shader makes everything much easier to set up.
  25. Hammers

    Maya appLink

    I'm having trouble getting this to work. Using Edu version of 2016, plugin shows in plugin manager but gives me: -------------------------------- // Error: line 1: ApplinkError: file /Users/Stephen/Library/Preferences/Autodesk/maya/2016/plug-ins/3dc_applink.py line 57: Registration failed for <coatExport> command. // // Warning: line 1: Failed to call script initialize function // // Error: line 1: (3dc_applink) // I'm on OSX10.9.5 btw
×