Jump to content
3DCoat Forums

Silas Merlin

Reputable Contributor
  • Posts

    851
  • Joined

  • Last visited

Everything posted by Silas Merlin

  1. when baking color in 3d-coat there seems to always be loss of data, the result is more blurry than the original. I don't mind, but the person I work with does, so I rarely have the opportunity to do that when working with that person. That is why we retexture in the photogrammetry software. otherwise there would be two options : 1. bake from vertex paint or volumetric paint 2. bake from an instance of 3d-coat that has the original scan loaded in paint room, and use the Textures>Texture baking tool to bake to the final cleaned up mesh exported to disk.
  2. I don't know if it matters but here are my settings I don't do the scanning myself, I send the resulting mesh from paint room to the person who does. There are only two small issues in my experience : -the person who does the scanning has his software set up to z-up coordinates so I have to remember to set that up every time. -sometimes my scene loses the z-up coordinates for some unknown reason, so I have to check that the coordinate system is correct after I export. I get the texture back and fix texturing errors, and paint untextured areas.
  3. import mesh with texture in paint room. you can also reimport the albedo as displacement to fake detail, because the next step will not take the normal map into account. go to bake menu and take subdivided mesh to sculpt room. 3d-coat will automatically calculate the number of vertices needed to carry the amount of information in the textures. if that number is above 21 milliion it causes a crash on my machine, so I always lower it to 21 million. Once in sculpt room you can turn the mesh to voxels. Before that you proabely delete paint object and imported textures (this won't delete the vertex color which is on layer 1. If the mesh you are working in is a 3d scan, it is best to keep mesh size and orientation and coordinate system so that you can take your cleaned up mesh back to the photogrammetry software for retexture at the end. (use the volumetric paint only as a reference, not for baking, unless you don't need to output large textures). that's my advice for what it's worth.
  4. Here are my notes from past few weeks/months. I have not been reading this thread anymore, so, I am sorry if some of the following issues have been discussed/addressed already : General issues : Possible problem with "z-up coordinate system", sometimes a project will lose it. Not sure when it happens. possible problem with "treat retopo objects as materials" with "treat materials as separate textures" ticked off. After painting the mesh, if you "update paint mesh with retopo mesh", the painting vanishes. Issues in Sculpt room : IMPORTANT : Voxel mode : "Airbrush" tool, when you left click on voxel object, it causes 3d-coat to freeze for ever. Windows 10 recent builds. Vertex color vanishes when you decimate, and then comes back later (for example with clean surface). Cut off tool in rectangle stroke mode will cut off geometry that is behind the camera, which is an issue because it means you can't use cut off tool in certain situations without first hiding what is going to be behind. If you move a sculpt mesh with "conform retopo mesh" ticked on, and then you undo your action, only the sculpt mesh action is undone. the retopo remains in place. retopo tools : when you are generating the sculpt mesh from retopo room and you save your file, when you reopen the file the generate sculpt mesh box is unticked and the sculpt mesh is now unlinked, which is confusing. ticking the box again does seem to restore the file to the state it was before saving. In any case, "generate sculpt mesh" does work well as it is, however, there is one conflict : Let us say you have in your voxtree an object of the same name as the retopo object you are going to work on. That vox layer contains your high poly or reference. You do not want to lose it. Yet, when you tick "generate sculpt mesh", the mesh in that layer is instantly deleted to be replaced by the generated mesh. I think there are two solutions : -When ticking the generate sculpt mesh box, issue a warning that the original mesh is about to be deleted. -When ticking the generate sculpt mesh box, rename the original layer and create a new one. sometimes when you undo the generated sculpt mesh vanishes When moving vertices with Add/split tool, the generated mesh is not updated on immediately. You have to left click somewhere or switch tools and back for the mesh to update. This is annoying. after using select/transform tool two or three times, it suddenly becomes impossible to select a new vertex. You have to switch tools to make it work again. It is annoying that select/transform tool does not remember stroke mode, it always reverts to rectangle stroke mode. Select tool does not remember stroke mode either, instead, it picks up the stroke mode of the tool you used just before. with edge loops tool it is no longer possible to drag select islands in the uv preview panel, you have to hold SHIFT and click to select more than one island. rectangle mode no longer works on the uv preview panel. Minor issue : Object transform mode does not move the gizmo, only the selection. Feature requests : "Act as vox hide" for Plane tool the ability to unwrap/repack selected islands while leaving in place and respecting existing islands. A second version of "clean surface" which tries to respect straight edges. the ability to move a vertex by world coordinates in the scene the ability to make islands in the uv preview be more transparent, so as to be able to see through when using an actual texture as "custom checker" make the unwrap method automap uses available along with the regular unwrap methods in the left tool bar. (automap is able to unwrap crazy islands which available methods will not be able to unwrap properly, resulting in self intersection) when you save a .3b file that does not have a paint object and you reopen it, an empty object and an empty surface material are created. Once an actual object is baked or imported into the paint room, could this empty object and surface material be automatically deleted, please ?
  5. I know retopo room is not designed for anything above 50k, but... could this be improved ? I do have workarounds, but lately it has become very painful. Here is how you can see the problem : place two meshes on separate polygroups in retopo room with a total of polygons above 500k quads (or 1M tris), preferably on same uv-set Now, try to click on the polygroup that is not currently active : 3d-Coat becomes unresponsive, for many minutes. so, it is possible but it takes a lot of time. Now... try to rename a polygroup (by double clicking on it)... You may achieve to get the text field popup, but you will have to try several times and you have to wait several minutes every time.
  6. I have currently about 30 GB of free space on C: All the projects I have been working on have volumetric paint in them. I am not sure my problem is due to volumetric paint, but I am just assuming it is for no good reason other than this started with volumetric paint and I am using it always. As time goes by (few hours), the disk space shrinks. Eventually, 3d-Coat is unable to save a file. When I am lucky I get this warning, but it is not always the case. (I'm careful and double check before closing, so it's no big deal) In order to free up the space, I have to close the file, and then open a fresh instance of 3d-Coat and close it.
  7. I am working on scans (repairing the high, producing a new mesh, unwrapping it). The current workflow I am experimenting with is to make a low with 50k or so, with quads where it matters most. then mark seams and keep a safe copy of the file at that point. After that, I use "Smooth CC", which subdivides and relaxes the mesh (the people want a dense mesh for their scans) For the current statue, I need to separate the mesh into two polygroups. Because of that, I can't use smooth cc. Instead, I tried to select all and do "smooth selection CC". The problem I notice with that is it does not behave like smooth cc : the resulting subdivided mesh does not snap to the high. My guess is that this is a bug ? the other problem I have is that after subdivide I feel I need to unwrap again, because the uv preview window shows red and blue polygons, which makes me think the unwrap is bad and needs to be done again. I don't know if that is so. Should I keep the unwrap from the low ? Anyway, when I unwrap the subdivided mesh, I encounter a new problem : islands that unwrapped well before subdividing suddenly unwrap badly (overlaps). Again I don't know if that is expected behaviour. (so I go back to the previously saved copy and mark more seams before I subdivide). Not really expecting answers here but advice would surely be appreciated, thank you.
  8. I have some 47GB of free space on C: yesterday I worked several hours with volumetric paint without noticing that 3d-Coat was filling up the disk space (with temporary files, I think). When I saved the work, there was no warning that anything was wrong. 3d-Coat just saved an empty file. Then I did some other things outside 3d-Coat and that is when I noticed that the disk was full. So I decided to close 3d-coat. (my fault, I should have checked the saved file before closing). Disk space started recovering slowly, so I restarted the system but it did not help. Only when I opaned a blank .3b file did the space recover fully. Maybe there could be a warning of some sort when disk space is low ? or a flushing of undo stack or something ?
  9. Ok, I guess that makes sense but.... It was actually an easy way to get rid of volumetric paint when no longer needed. Is there another easy way to do that ? All I can think of is to "merge visible" on a new layer ?
  10. Wouldn't it be a good idea to have a search box for tools, similar to the old spacebar menu in Blender ? search results could include both actual tools and menu items. Also I think I asked for this many times over the years : a search field to filter through smart materials (and shaders, really)
  11. Just saw this in release notes : .44 - Measure tool cleaned up, better visible marks, rotated text that does not intersect with the measure line, possibility to turn off subdivision marks. I reminded me of something. I did not pay much attention lately, but I think people have started using curves like "grease pencil" to sketch a shape in 3d space ? I remember long ago attempting to do this with the measure tool, with the intent to snap to it when creating polygons in retopo room. The experiment failed because it was not possible to predict where the measure tool would create a point in empty space. Again I have not been paying close attention, but if the recent work has been done for the curves to be placed as the user intends in 3d space, maybe this could be extended to the measure tool ? The reason being that curves are quite an endeavour to understand and make use of, kind of cumbersome, whereas measure tool is pretty fast and straightforward to make use of. Please ignore if this makes no sense. EDIT : hmm, checked measure tool just now, it does not seem to be possible to snap to meature tool with add/split. I don't know if that is something that existed before or not. can't remember ?
  12. I do not have "Restore default" in RMB menu for the tool. only a thing called "restore default ordering"
  13. I am trying to use the clusters tool. The other day, I found "clear custers" in the command section and used it. Today, I am unable to make "clear clusters" appear in the commands section, no matter what tool I select. The "Join clusters" tool is either ineffective or it joins all clusters at once. the seams do not change color when hovering over them. When using the "Add clusters" tool, with "auto seams" activated in tool options, there is an island unwrap preview, but this preview shows the whole section of mesh, not the individual islands created by the clusters. I still have this most annoying issue with the add/split tool slowly disintegrating in a session until it becomes unuseable and the session has to be ender and the file reopened.
  14. I am having issues with the add/split tool in .43 I am not sure what triggers it, but after a while some of the brush vanishes, the line that you drag with the brush vanishes... at this point the tool still works, but later the brush becomes similar to points to faces tool and the tool no longer works until 3d-Coat is restarted.
  15. Could Sphere tool please be made to remember settings from session to session ? (Draw from first point, profile...)
  16. how about an "automatic clusters" method, which people then refine using the new join clusters tool ? This ought to tend towards more convex islands ?
  17. Is the work on automap finished ? I think there are still problems. I think you are trying to create bigger islands ? I think yes very small islands are to be avoided most of the time, but those long thin islands are a problem, and also the star-shaped islands. I was made to understand that it is best to aim for convex islands, because when you decimate to create LODs, concave shapes will end up self intersecting. here is an example problematic island on the angel what I mean by "star shaped" Also I think it would be good to try to find straighter paths for seams There are still isolated triangles
  18. Tool appears after doing Windows>Reset this page to default. My guess is that anyone who uses stored workspace like I do, don't see new tools ?
  19. Can someone please share an example mesh for which automap in .40 produces a desireable result ?
  20. .40 automap freezes 3d-Coat on the Angel of Peace mesh. Where is the "Join clusters tool." located ?
  21. Just for information, I finally solved a problem I have had since the integration of paint tools in sculpt room : Soon after, the paint tools disappeared from sculpt room for me and I have been unable to bring them back until today. It so happens that I often "restore workspace" because there is no way to lock the panels in place, which makes it easy to lose your layout by misclicking. So... as soon as I restored my workspace to a workspace that was stored before the appearance of paint tools... they vanished. When you right click in the left tool bar you get the option to "show all tools in this section", but there is no option to "show all sections", therefore I was never able to get the paint tools section back. Today I tried "Reset this page to default" in the Windows menu. This brought the paint tools back in sculpt room.
  22. I look forward to .40 I keep refreshing the first page all day every day. Looking forward to testing the new automap.
  23. @Andrew ShpaginMay I suggest a difficult test for the current state of automapping ? -Interlock two or more squiggles made with 2d-Paint tool -retopo via decimation -automap something like this, up until .39 it is something 3d-coat will automap very badly every time.
×
×
  • Create New...