Jump to content
3DCoat Forums

poeboi

Member
  • Posts

    52
  • Joined

  • Last visited

Community Answers

  1. poeboi's post in Normal Maps Seams Are Visible was marked as the answer   
    Hello!
    From experience looking at pics of model here are some things that might be going wrong
    When you are in paint room, with smooth shade display mode on (the default, hotkey 5) and only have normal map—
    if the model is not an entirely "light gray" all over but also have these inadvertent dark gray spots, it could mean 
    1. it is trying to display some faces the wrong normal direction, e.g. slightly inward even though it should be pointing outward, etc.
    it might stem from the model's file itself, the problem can come from .mtl file accompanying a .obj file or normal information in fbx
    2. normal map preset is somehow wrong, wrong red/green direction, 
    3. the areas that are supposed to be "zero/no depth" do not have the color R/G/B 128/128/255 but sligthly darker!!
    (you can check by just color picking a part of your normal map where there is supposed to be "nothing" and see if you get that color)
    Seams like that in normal map might mean 
    1. that the normal map are very exactly within or "on" the boundaries of each UV island, in example one for the head, cowl, horn etc →
    if the edges are then slightly jagged, it will appear as seams because it can be offset slightly by some pixelation
    this type of problem is less noticeable with higher resolution normal maps
    2. UVs has somehow been smoothed one iteration but normal map is from unsmoothed model with unsmoothed UVs
    3. In the normal map colour information, the contrast in depth information between what is situated exactly on the edge of UV island and outside is too great, causing a slight bump → and seam becomes much more visible
    Here's some things you could try to either troubleshoot or solve it
    1) Export model as .obj only without any materials, delete accompanying .mtl, re-import model into painting with default values. Verify that you get clean, 'light gray' model with no dark patches. Then at least, you know the problem is not 'baked into the model' so to speak
    2) compare the UVs of model, how they appear for the model in 3dcoat and in blender before export of map, do they look different at all? You might have smoothed UVs without being aware of it when importing model into paint room. Making sure they're the same might fix the problem
    3) check that there are no areas of normal map that is supposed to be "zero depth", color R/G/B 128/128/255, but is instead a darker depth value
    4) Try WITHOUT any software preset on normal import, no preset
    and try with one at a time, the various, Invert Red, Invert Green, Swap Red <-> Green settings and observe that you get correct normal display

    Hope any of it can help
    Also reminds me of 
     
  2. poeboi's post in [Solved] Lasso Selection - Adding to current selection was marked as the answer   
    Hello, hope this can help

    It's
    make selection → LMB press first, then while holding LMB, press shift → drag another selection area, release LMB
    (Also works with, LMB press first, then hold CTRL, and release LMB to deselect)
    bYz1Jyxmsd.mp4
×
×
  • Create New...