Jump to content
3DCoat Forums

digman

Reputable Contributor
  • Posts

    4,720
  • Joined

  • Last visited

Community Answers

  1. digman's post in Why are some seams/edges coloured blue when imported into 3D Coat? was marked as the answer   
    ""Is this a problem with the pipeline between Zbrush, Cinema 4D and 3D Coat"". Yes, I think it is. Same thing happens to me using Hexagon. I do not consider this a problem with 3DC but a pipeline problem. 
    Fix is below:
    The blue lines are hard (sharp) edges.
    Choose Select in the left tool panel. Retopo room.
    Select all the edges in the model using the rectangle tool from the e-panel
    RMB and select clear sharp. Shown in picture.
     

  2. digman's post in program crashes was marked as the answer   
    Your system is on the older side.
    A 50 million voxel model takes about 15.5 gig of ram. Information is from the Task Manager in Windows 11. Of course, that includes operating system overhead too.
    You have 16 gig of system ram, plus only 3 gig of video card ram. 
    You though can still use 3DC effectively. 
    Sculpt large areas at lower resolution in voxel mode. Once the main forms are done switch to surface mode where you can have dynamic tessellation, only adding polygons where you need them for the details.
    The model shown in picture is 8 million polygons total in surface mode using 4 sculpt tree layers.  I still have room to add more details and sharpen things up. 
    Though I got 64 gigs of ram and a Nivida 3090 I still think in terms of effective use of my system capabilities. No reason to be wasteful of system ram and video ram if I can reach the detail I am after.

  3. digman's post in problem with text editor was marked as the answer   
    Your first control point for your curve seems to be off plane a few times. I noticed at the last you had it working for a moment.
    Try this to fix your problem.
    Since this is a rectangular type of model and it appears, you are not trying to wrap a text around a corner, have the view lined up correctly before placing your first control point. 
    Press the ESC key to clear the curve.
    Do not start the curve right at the sharp edge of the model. Make sure the cursor is on the correct plane before placing the first control point.
    My picture shows the first control point is starting on the wrong plane. Blue line points to the control point.
    Side Note: Use the e-panel brush shown in the picture. It will help to create the text placement correctly when applying the text. 
    I hope the above is helpful.
     
     
     
     


  4. digman's post in Why is the mirrored side of the texture not the same? was marked as the answer   
    Worked with the stencil on my end.
    Selected to tile the image.
    Which also covers the UV texture editor window
    Scaled the image to the size I wanted. 
    Filled the uv island in the texture editor window.  
    Is your Stencil seamless, I think it would be but asking to be safe. 
    I am not sure why it is not working for you.
     

  5. digman's post in Layers panel was marked as the answer   
    Sculpt tree layers are for your voxels or surface mode object as you know already.
    The layers panel at the bottom is multi-purchase.
    1. In "Surface Mode" you can have non-destructive sculpting layers, The original sculpt layer object is not altered. Shown in the quick limited video but gives you the idea how it works.
    Simple Example: You have a head object completed. Now you can add wrinkles pores etc, non-destructively.  Plus you can add asymmetrical work to the head without altering the symmetrical base head model.  Sculpt layers are indeed powerful.
    2. For surface mode or voxel painting. 
    The above is not a tutorial or the best practice of using the layers panel mentioned above.
    Side Note. Create a simple model and test the sculpt layers out to see how it works yourself. Of course, you are not limited to fine details.
    ------------------------------------------------------------------------------------------------------
    One thing to mention though is never use layer 0, it is for 3DC's internal use.
    When testing the paint mode be sure to select Under the paint room view menu---Show voxels in the painting room. Your voxel or surface mode will disappear otherwise.
     
  6. digman's post in Blending between layers without merging. was marked as the answer   
    Not possible at the moment. 
    Auto pick allows the cursor to select the different layers as you sculpt along automatically but will not blend without the seam showing where the objects meet. The seam cannot be smoothed away merging the two objects seamlessly but keeping them separately at the same time.
  7. digman's post in Filling only 1 UV island, has this become easier? was marked as the answer   
    When you do have stacked uv islands do the belows:
    Preferences---Brushing---Select, Prevent double painting over stacked UV islands.
    Be sure to read the tool tip to understand the reason for selecting.

  8. digman's post in Filling only 1 UV island, has this become easier? was marked as the answer   
    Your uv padding might be set to high.
    Default is 256 pixels in Preferences under the In/Out tab. 
    I set mine at 6 pixels for a 2k map and you can adjust it at anytime.
    ------------------------------------------------------------
    A workaround for selecting a uv island. Useful if you have lots of uv islands.
    Select the triangle brush in the e-panel. Paint a few polygons on the 3D mesh in the area you want to fill till you see which uv island you want to fill completely.
    Then use the fill tool.
    Question. do you have stacked uv islands as well?
     
  9. digman's post in License upgrade question was marked as the answer   
    Goes with my above post.
    The other 3DC user, a good friend said:
    Go to your profile an Upgrade from there. 
    Your results could be different but a possible solution.
  10. digman's post in Controlling curvature baking was marked as the answer   
    I do not think it is possible at this time to control thickness as you stated.
    The below I think depends upon the model or end result on which one is better. A user's call.
    Local Curvature (RGB)
    Local Curvature: You have Intensity and radius controls.
     
  11. digman's post in Importing both high-poly and low-poly mesh that has been retopoed is possible, right? was marked as the answer   
    From another post I answered a few weeks ago. 
    As long as both models occupy the same xyz coordinates it is not hard to do.
    In the sculpt room choose the import tool (left toolbar under Objects) 
    Select Import w/o  Voxelization  then use the Open the Mesh command. Select your hi-poly model. Your model will be placed in Surface mode. 
    Click on apply and then choose a brush to finalize the import. The reason it does not completely finalized the model after pressing apply is if you want more than one copy of the mesh. Also do not "scale the model". It will come in its original scale. If the model is all quads it will just be triangulated.
    Switch to the retopo room.
    Under the Mesh menu at the top, Choose Import. Import your low polygon model. 
    Your low polygon model will appear in the retopo room workspace. Press the Enter key to confirm the import. 
    If your models have the same xyz coordinates, then the low polygon retopo mesh will be at the correct location. 
    I normally have auto snap off as 3DC will snap the low polygons vertices to the high poly model. It really depends upon the model if you want Auto Snap on or off. You can try both ways to see what works better for your low polygon model.
    Auto Snap is the top menu.
    Conform Retopo Mesh is available to you now in the Sculpt Room.
    ------------------------------------------------------------------------
    ## Important##
    Both models high and low must have the same xyz coordinates as mentioned before.

  12. digman's post in Baking multiple objects seperately for future editing was marked as the answer   
    What is not making sense is the normal map detail you see in 3DC should be the same in SP.  Make sure all your normal map import settings are correct in SP and you are working at the same resolution as in SP that the normal map was created in. 
    "Question" are you looking at the voxel, surface room objects in the paint room. Look under the View menu and deselect Show Voxels in Painting Room if it is selected. The voxel and or surface models can overlap and hide the baked painting room mesh.
    Now you will see the normal mapped low polygon model in the paint room to check for quality. If you want one uv set increase the uv set resolution for better quality when baking from the retopo room.
    I do not know if the voxel / surface mode models are appearing in the paint room in your scene so hence the above question.
    -------------------------------------------------------------------------------------------------------
    Once the above is known do the below.
    To make it clear Sequential Texture Baking, or Names Correspondence will not bake and create a normal map for each volume with just one uv set.
    It will prevent occlusion and intersection errors of sculpt room voxels or surface model layers. They will be baked separately.
    Separate your separate voxels or surface mode model layers into more than one uv set as the Sequential Texture baking video says. That video is very old but still does cover the basics. 
    ""Important"" and is a strict requirement the Polygroup layers and Voxel / Surface mode layers must have the same exact name for Names Correspondence to work.
    Picture shows what I mean. 
    I got four poly groups, four surface mode layers, the names are the same and have 4 created uv sets. I used Names Correspondence for baking. 
    I used auto wrap per uv set just to show the workflow.
     

  13. digman's post in How to split body parts if there is an intersection between them? was marked as the answer   
    This post has pegged my interest. 
    What do you do when you have intersecting parts with another part that is close but not intersecting.
    I use a Voxel brush not the voxel hide tool to hide the intersection. You do not have really precise here, not sloppy either. 
    Brush enough material away till you can use a spline to incircle parts of the mesh you want to hide.
    Now brush back the hidden voxel material on the part that is not hidden. You can tell when you start brushing back too much hidden material. If you do np, just use the brush on a lower depth limit to re-hide and then brush it back again.
    Once done, Separate the hidden part to its own layer.
    Clean up some and you are done.
    Picture shows end result of this process after some minor clean up.
    The arms were slightly intersecting each other with a sphere close by.  They are now on separate layers.
    Note. You could have used a spline with a depth limit (setting in the E-Panel as well but I was testing brushing. 
    If you have many parts to do:
    Delete the hidden under the geometry tab.
    Then rinse and repeat the same process.
     
     

  14. digman's post in Trying to make a Interior was marked as the answer   
    I am only offering another a workflow solution. Elemno gave one.
    Edit: removed a sentence. 
    A Workflow solution: No flipping required but a little more work.
    Create the sculpt sphere.
    Use cut and clone tool to cut half away of the sphere. Rotate the cut and clone object 180 degrees, Transform/ move to the inside of the top half of the sphere.
    Slightly scale down the cut and clone object.
    Hold down the Ctrl key and press the Enter Key to cut away the inside of the top half using the cut and clone object. Leave some thickness on the top half sphere.
    Run Autopo on the entire half sphere. 
    Delete the outer polygons as they are not needed.  Do this first before deleting. Under the View menu select backface culling so you do not select any interior polygons.
    Look at my scan settings. You have to manually put in the minus sign baked scan settings In the Show Outer Shell as this is now a one sided interior retopo mesh. 
    Bake to the paint room
     Under the View Menu in the Paint room now de-select Backface culling. easier to view on the eyes the interior of sphere. The paint on the outside is not really there it just appears to be as back face culling has been de-selected.
    First picture shows the interior of the baked half sphere. The outside appears as backface culling is off so it is easier to look at. 
    Second picture is my bake scan settings. 
    Last image is the exported texture map. I just used this unwrapping for testing, You can choose your own.
    I am not saying use the solution, but it is an option. 
     



  15. digman's post in [Solved] Cursor disappearing when leaving the mesh was marked as the answer   
    It is not a bug but how the regular brushes work. 
    Here is a Nav preset. Drop it in the folder shown in the picture.
    The preset will appear in your Nav preset list under Custom Scheme which is under the Camera Icon. Load 3DC and you will see it.
    In this Nav preset you can start in Screen space, once the cursor hits the edge of the model it will start to sculpt. You will not see the cursor in Screen Space till it hits the edge of the model.
    You lose the ability to rotate in Screen Space by your holding down LMB, use ALT and LMB to rotate.
    Picture shows the result. Top 2 strokes with the default Nav preset.  Bottom two with PaintEdge Nav Preset. You see the strokes started sooner as it started at the edge of the cylinder. 
    There might be more I can do but has been a long time since I messed with a Nav preset. Years ago a user had a tutorial on it. I will see if I can find at Youtube.
    Edit: The only item I change in the NAV preset is to disable the LMB function to rotate in screen space, everything else is left untouched.  I watched the Video and that is all that was changed.

    PaintEdge.navigation

  16. digman's post in Projecting Painting Objects' Color Info to Sculpt Objects was marked as the answer   
    "I tested an export of the almost 9 million model with vertex colors from the sculpt room. Opened a new scene in 3DC, imported the FBX model. The vertex colors were there. Of course no metalness or roughness, color only. 
    In order to paint on the vertex model you would have to import it.
    This is to confirm to you it does work. I did not share a picture on that test." 
    ----------------------------------------------------------------------------------------------------------------------
    The last part of my previous post will get what you want. 
    Export the high polygon model with the vertex colors.
    import the the high polygon model with the vertex colors through the New Menu---Vertex Painting   Show voxels in the painting room must be enabled under the view window as the high polygon model will appear in the Paint room.
    Paint your new colors, Switch to the sculpt room to run autopo and to bake for the brand new uv mapped mesh. 
    Side Note once done baking, deselect Show Voxels in the painting room. 
    Picture shows imported high polygon robot model in the paint room ready for more vertex painting.

  17. digman's post in Pose Tool projects though model to face behind was marked as the answer   
    Press E on the keyboard to bring up the E-panel
    Select Ignore Back Faces.
    Check that no symmetry is on. I forgot myself at times.

  18. digman's post in Trouble rotating with sphere brush was marked as the answer   
    Windows version 2024_03 beta. 
    Works both inside and outside of an object on my end. 
    3DCoat default Navigation preset.
    Is your Alt + LMB setup as in the picture.  Both the inside and outside the object boxes need to be checked. Rotate Around Vertical Axis chosen as well.
    Since you been adjusting the Nav settings, do you have a possible conflict? 
    No way to make the sphere brush object based, it is hard coded.

  19. digman's post in Does anyone know how to undo smooth selection on a mesh post save? was marked as the answer   
    I believe there is not. There is no undo history saved with the file, at least I do not think so.
    Only thing I can advise is to have AutoSave turned on in Preferences---General tab. If it was turned on which is on by default, load the last auto save or an earlier one.  You set the timing of the auto saves and how may to save.
    I prefer this manual method. Incremental saving but that is a user's choice.  Before any major operation, I can save an incremental file or just to be safe. The file will be saved under the folder location of your original 3DC file. 
    Ctrl + Shift +S
    If you do not see your autosaves under the File menu----Open recent list, the files are located if using Windows, in the location shown in the picture. 

  20. digman's post in Export all normal data as a displacement map was marked as the answer   
    Not with the Bake w/ Normal Map Per Pixel baking.
    Choose Bake w/ Normal map (Per-Pixel) + flat displacement.  This way you will get a normal map and a displacement map but still be in per-pixel mode which gives the highest quality painting.
    Now, you need to sub-divide the model when baking. Choose the highest or next highest division offered to you in the baking menu. You must subdivide. This is normal when creating a displacement map.  You can still export your low polygon model from the paint room when using the export objects and textures menu or from the Top Textures menu. Now when exporting from the objects and textures menu panel be sure to choose your low polygon model. Your external renderer or runtime will subdivide the model when using the displacement map. 
    The displacement map will be put on a hidden layer in the paint room after baking.  Of course you can hide the normal map and unhide the displacement map to see it to check it. 
    Since you are mainly interested in baking for per-pixel mode I will not discuss Micro-Vertex baking for a displacement map. That is the main purpose of this baking routine. A world space normal map will be created. No normal map layer created. You can still export a tangent base normal map though. If interested in this method, I will explain as well.
    Side note:
    As with all displacement map baking. quads work best and a good retopo layout plus good seams creation layout
     
     
     
     


  21. digman's post in How can I make my brush hard-edged? was marked as the answer   
    I saw you mention your texture resolution is 406 but did you mean 4096. 
    Are you looking closer for this kind of sharper edge as shown in the picture. 4096 texture resolution. Flat shade, No AO and Greyscale Panorama to show clearly the strokes in 3DC.
    Many factors involved here. 
    Texture Resolution, efficient use of your texture space, Linear texture filter which 3DC uses as most 3D applications use some form of texturing filtering. Creating an Alpha that works better for hard edges in 3DC.
    Side Note: Texture filtering will always slightly burr textures as it involves interoperation between neighboring pixels. You can turn it off under the view menu but mostly likely you will want to keep it on.
    Also, like a 2D painting program as you zoom in to your painting you will start to notice the pixel structure. When zooming into your model in 3DC is it the same except we are estimating the zoom amount. 
    ---------------------------------------------------------------------
    Since you are hand painting and not using a PBR workflow do this if not already. 
    Under the View Window select Greyscale Panorama so no color light is cast into your scene.
    Calculate a good Ambient Occlusion map. Something like 48 lights, Sphere +Hemisphere and 4 or 8x anti-aliasing.
    Under the View Menu select Flat shade. This will remove all light from the scene and more or less you will be painting like you are in Photoshop except you need the AO to see the details of your model. 
    No light will be cast on your texture colors you have established so far. 
    Now you do not have to do the above but check it out. Many YouTube tutorials on hand painting recommend it.
    Here is an alpha to test. It is a 3DC extension file. Install it under your File menu---Install---Install Extension. Restart 3DC.
    I set my Falloff at 10% and Focal Shift at 10% 
    Focal Shift is under Edit---Preferences---Brushing. Check Focal Shift. It will appear in the top panel. 
    If you zoom way into your model you will see the effect of Linear texture filtering, just like you zoom into a painting at 400 to 800 percent but we do not show our 2D digital painting artwork at 400 to 800%  
    I hope the alpha will help you some. I found it to work not perfect but better than the default alphas. I created the alpha right inside 3DC with the alpha curve creation tool. 
    -----------------------------------------------------------------------
    Also, you have Under the Edit menu- Edit Projections in Ext. editor like Photoshop or Affinity etc. It will take the current projection and load it into your editor of choice. Use all available brushes in your editor, save the file and your 2D painting will be projected back on your 3DC model.  
    Also, you can paint on the UV set in your editor if you choose one of the other options. 
    I attached the alpha to this post.
    Edit: This alpha works best at 4k and above.

    Hard Alpha.3dcpack
  22. digman's post in How can I make my brush hard-edged? was marked as the answer   
    I saw you mention your texture resolution is 406 but did you mean 4096. 
    Are you looking closer for this kind of sharper edge as shown in the picture. 4096 texture resolution. Flat shade, No AO and Greyscale Panorama to show clearly the strokes in 3DC.
    Many factors involved here. 
    Texture Resolution, efficient use of your texture space, Linear texture filter which 3DC uses as most 3D applications use some form of texturing filtering. Creating an Alpha that works better for hard edges in 3DC.
    Side Note: Texture filtering will always slightly burr textures as it involves interoperation between neighboring pixels. You can turn it off under the view menu but mostly likely you will want to keep it on.
    Also, like a 2D painting program as you zoom in to your painting you will start to notice the pixel structure. When zooming into your model in 3DC is it the same except we are estimating the zoom amount. 
    ---------------------------------------------------------------------
    Since you are hand painting and not using a PBR workflow do this if not already. 
    Under the View Window select Greyscale Panorama so no color light is cast into your scene.
    Calculate a good Ambient Occlusion map. Something like 48 lights, Sphere +Hemisphere and 4 or 8x anti-aliasing.
    Under the View Menu select Flat shade. This will remove all light from the scene and more or less you will be painting like you are in Photoshop except you need the AO to see the details of your model. 
    No light will be cast on your texture colors you have established so far. 
    Now you do not have to do the above but check it out. Many YouTube tutorials on hand painting recommend it.
    Here is an alpha to test. It is a 3DC extension file. Install it under your File menu---Install---Install Extension. Restart 3DC.
    I set my Falloff at 10% and Focal Shift at 10% 
    Focal Shift is under Edit---Preferences---Brushing. Check Focal Shift. It will appear in the top panel. 
    If you zoom way into your model you will see the effect of Linear texture filtering, just like you zoom into a painting at 400 to 800 percent but we do not show our 2D digital painting artwork at 400 to 800%  
    I hope the alpha will help you some. I found it to work not perfect but better than the default alphas. I created the alpha right inside 3DC with the alpha curve creation tool. 
    -----------------------------------------------------------------------
    Also, you have Under the Edit menu- Edit Projections in Ext. editor like Photoshop or Affinity etc. It will take the current projection and load it into your editor of choice. Use all available brushes in your editor, save the file and your 2D painting will be projected back on your 3DC model.  
    Also, you can paint on the UV set in your editor if you choose one of the other options. 
    I attached the alpha to this post.
    Edit: This alpha works best at 4k and above.

    Hard Alpha.3dcpack
  23. digman's post in [Solved] Retopo room <-> UV Room <-> Paint Room was marked as the answer   
    Goes with the above post:
    To make it clear.  Make sure when unwrapping you have all the specific polygroups moved to the specific uv set and that uv set is selected before unwrapping. 
    I got a little wordy in my above post.
  24. digman's post in No S to V Allowed? was marked as the answer   
    Since you imported for surface mode and want to convert to a voxel model, I am talking about that. Of course using the same inner thickness method, you could directly bring the model into voxel mode.
    The model hand is just an open polygon shell.  When importing it from the models pallet, add some inner thickness to it. The setting is in the import panel. I used 0.140 for the inner thickness. Res + 2 to 3 times after importing into surface mode so that when you switch to voxel mode, the model will not have the facet polygon structure. 
    Voxels require thickness to import correctly not just a polygon shell. Surface mode is not a problem as it is polygons...
    After attaching it to your voxel arm and sculpting it fit, run fill voids as the interior of the hand will have a void, thickness yes but a voxel void. 
    Should be able to merge it both ways either directly from surface mode to the voxel layer with the arm or merging it to it's own voxel layer and then merge.

  25. digman's post in No S to V Allowed? was marked as the answer   
    Since you imported for surface mode and want to convert to a voxel model, I am talking about that. Of course using the same inner thickness method, you could directly bring the model into voxel mode.
    The model hand is just an open polygon shell.  When importing it from the models pallet, add some inner thickness to it. The setting is in the import panel. I used 0.140 for the inner thickness. Res + 2 to 3 times after importing into surface mode so that when you switch to voxel mode, the model will not have the facet polygon structure. 
    Voxels require thickness to import correctly not just a polygon shell. Surface mode is not a problem as it is polygons...
    After attaching it to your voxel arm and sculpting it fit, run fill voids as the interior of the hand will have a void, thickness yes but a voxel void. 
    Should be able to merge it both ways either directly from surface mode to the voxel layer with the arm or merging it to it's own voxel layer and then merge.

×
×
  • Create New...