Jump to content
3DCoat Forums
pixo

Weld vertices in Retopo

Recommended Posts

Hello guys,

I just want to know if it's a bug or if it's me.

I can't merge vertices in the Retopo room, from what i read on the forum i'm just suppose to move the vertex onto another one(that's become red).

There's a special stuff to do , to make it works ?

Because it doesn't worked here.

Cheers,

Pixo

Share this post


Link to post
Share on other sites

Usually when I find that this is happening, its because the vertices I am trying to weld are in different groups / layers. Are you certain that this is not also the case for you?

Share this post


Link to post
Share on other sites

I just tryed another time and i can't manage to weld with the "move vertices" tool.

The object is in the same groups,i attached a picture of my problem.

post-12831-0-37365000-1344761358_thumb.p

Share this post


Link to post
Share on other sites

I do not have this problem and I can't see why you would have the problem. I am using Windows 7 64 with Cuda, version 3.7.16A. Perhaps it is specific to your OS or something.

Share this post


Link to post
Share on other sites

Thank you Polygoon, i ll send it to the support.

I'm not under windows this is may be why.

Share this post


Link to post
Share on other sites

Sometimes I need to give it an extra poke and I know it's good when the "Move Vertices" tool moves them as one. I've found the Add/Split tool to be very sensitive to brush size.

Share this post


Link to post
Share on other sites

If you are using Linux, I had the same problem 2 beta versions back...

I do not know what beta version you are using but 3.7.16A fixed the problem for the Linux version 64 bit non cuda...

Share this post


Link to post
Share on other sites

Thank you digman.

I'm using ubuntu 10.04, 3DC 3.7.16A non Cuda , by the way i tried to make work Cuda, but unfortunately the latest Nvidia supported Cuda don't really work ,at least for voxel sculpting.

By the way it's tricky and not safe to try to make it work under linux without knowing it .

I would advice to don't try to make symbolic link to latest nvidia ".so", and to never remove the latest nvidia driver without being familiar to the terminal and linux administration.

Share this post


Link to post
Share on other sites

This is a 3DC 3.7.16A bug , i tried with the stable version and i don't have this problem.I already report it.

Share this post


Link to post
Share on other sites

Sorry to hear that you still have the problem but you have reported it. I'm not a power linux user but I the got 4.0 toolkit cuda installed for Ubuntu 12.04 so I could run Blender's Cycles renderer with my GPU.

Cycles will use my cuda enabled 550 Ti Nvidia card for rendering which is great but 3DCoat will not run the cuda enabled version of 3DCoat, No sweat, I'm not that worried about it.

Yeah, updating video drivers is a pain in Linux for non power users... I'm using 295.49 drivers which works with 4.0 toolkit...

Share this post


Link to post
Share on other sites

Thank you Digman.

By the way peoples should just take care to don't remove the linux driver like suggested in the 3D Coat "how to install Cuda ..." since it's outdated.

Cuda looks to work with the default linux driver.There's some bugs in 3D Coat when you sym link the cuda 4 driver to cuda 3 ,which is normal i guess ... but it almost works, i just had some problems to paint in the voxel room.

Share this post


Link to post
Share on other sites

I can't merge vertices in the Retopo room. I'm just suppose to move the vertex onto another one.

Hello, Pixo! Move the vertex closer to the other one (please see the attached screenshots). To be merged the vertices should be closer. This is the same behaviour like in Windows version of 3D-Coat.

post-848-0-38095800-1344954688_thumb.jpg

post-848-0-34435500-1344954697_thumb.jpg

Share this post


Link to post
Share on other sites

Peoples should just take care to don't remove the linux driver like suggested in the 3D Coat "how to install Cuda ..." since it's outdated.

Please note that the document “How to install CUDA under Linux” states that you should remove the driver only in outdated Linux distros, like Ubuntu 9.04, CentOS 5.5, Fedora 14. In those Linux distros there is no other way to install new driver. The latest Ubuntu’s default driver supports CUDA out of the box.

Share this post


Link to post
Share on other sites

Hello Sergyl!

Thank you but unfortunately this is what i did or i'm totally crazy, which is possible.

I made a video and attached it under mantis with my report.

I use to work under Xmonad , but i tried under Gnome and it's the same.

Hope it can help.

Share this post


Link to post
Share on other sites

You can try deleting your options.xml file, under your Home/3DCoat folder in Linux. Sometimes the file gets corrupted and can cause problems. 3DCoat will make a new options.xml file when you reopen 3DCoat but I always save a backup copy anyway.

I do not think this is the problem but is worth a try at least.

No you are not crazy as I had the same problem but it is working now for some reason...

Share this post


Link to post
Share on other sites

Thank you digman,

But i tried in my home to do:

mv 3D-CoatV3 __3D-CoatV3

Even with the default setting it still doesn't work.

By the way today at work i just received a brand new computer under ubuntu 12.04 with a geforce gtx 670 and one of the latest core i7.

It still doesn't work, by the way i was able to make it work once on one off my colleague computer.

I ll try to investigate why .

Thanks

Pixo

Share this post


Link to post
Share on other sites

Ok, I'm not a power user but I know the mv command is a move / renaming command but what you did is unclear to me...

The only other thing I can think for you to try is to remove the folder "3D-CoatV3" under the "Home" folder in Linux

Also delete the main 3DCoat folder. Unzip the 3D-Coat-V3-7-16A.tar.gz file again.

Now if you decide to do this, you will lose all your personal settings and will have to register the software again.

That is the only way I know of starting out with a clean plate to see if the problem continues, though I believe I'm trying to help a power user so you know a lot more than me. I have done this a couple times myself as the new interfaces changes caused lots of problems if you went back to a beta version before the new interface updates.

You might try this solution with your personal copy first. I believe you bought 3DCoat for you personal use also...

Sergy and Andrew are pretty good about getting things fixed but I always find it funny when they respond with these statements "increase the brush circle size or move the vertices closer together".

Someone new to modelling, yes I could see answering in most basic terms but you are an experienced user in 3D production work. I been using the software for almost 5 years and they will still ask me the dummy questions. I just laugh and them no, I know that already... :rofl:

Share this post


Link to post
Share on other sites

Hello Digman,

Thank you to be so kind.

Don't worry, i actually understand Sergyl and Andrew , because 99% of the problems is in front of the computer and it's true.

Basically i tried to completely remove the 3DC folder (with the preferences of course), change the version to the stable one.

I found nothing to make it works.

I'll try tomorrow on my colleague computer, cause it worked with the stable version.

I don't really know what kind of algorithm they use to weld the vertices,may be it's about the video card precision.

I don't really know at the end, may be it would be good to have a weld function...A kind of select vertex A to weld to B.

So even the dumb guy like me can use it :P

Take care,

Pixo

Share this post


Link to post
Share on other sites

Oki we found the bug.

It works with the mouse controler but not with the tablet pens.

Hope it can help

Share this post


Link to post
Share on other sites

Confirmed, Your tablet pen can now be used to weld vertices...

Wacom Intuos 3

Thanks for the fix :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×