Jump to content
3DCoat Forums
Andrew Shpagin

V4.1 BETA (experimental 4.1.17D)

Recommended Posts

Here's a little bug I cam across. I'm using VoxLayer with Steady Stroke turned on.  If I switch to another tool, then back. Steady Stroke is now off and I have to turn it on again.

Maybe it's remembering your preferences for that other tool? That or someone asked Andrew to have it automatically switch it off when choosing another tool? It's getting pretty hard to keep up with all the small requests like this, cause everyone once in a while you come across something not working the way it used to, and it's all because one or more persons asked for it to change.

Share this post


Link to post
Share on other sites

Here's a little bug I cam across. I'm using VoxLayer with Steady Stroke turned on.  If I switch to another tool, then back. Steady Stroke is now off and I have to turn it on again.

 

There was an old request, may be related ?

 

0001445: Steady Stroke AUTO OFF when press Shift key for quick smooth

http://3d-coat.com/mantis/view.php?id=1445

Share this post


Link to post
Share on other sites

 

The progress bars do not work in the Linux versions of 3DCoat...

 

My question is it  IMPOSSBILE  for the Linux version to have working progress bars. I will accept that fact if it is indeed impossible to code it in.

Please answer one way or the other as it would be appreciated.

Mac too -  progress = spinning beach ball of death.

Mac  - standard convention requires, cmd key should emulate right click.

  • Like 1

Share this post


Link to post
Share on other sites

I noticed also that when working on multiple objects (and multiple UVs) in retopo, ctrl-z always changes the current UV to the default UV. Once burned, twice warned: if you are not alert to this undesirable change, you will find your work is on the wrong UV.

Share this post


Link to post
Share on other sites

I noticed also that when working on multiple objects (and multiple UVs) in retopo, ctrl-z always changes the current UV to the default UV. Once burned, twice warned: if you are not alert to this undesirable change, you will find your work is on the wrong UV.

Yep....and that gets on my last nerve. That is DEFINITELY a bug, cause it didn't start happening until the last several builds.

Share this post


Link to post
Share on other sites

I was getting some crazy lag in 4.0 and 4.1 recently when i would change between tools (Within the same brush set ( i have noticed this also causes lag but that's another issue...)

 

but yeh i would get crazy lag switching from a brush to a eyedropper etc. the only way i managed to resolve it was to rebuild the scene (re import the obj and then import in layer colors psd...) 

 

i couldnt think of what triggered the lag as it was working great all day. The only thing i can think that i did differently was at one point i did a CTRL+P and sent my file to photoshop briefly then back again. not sure if this corrupted anything in the file? No ICC profile was saved at that point .. however i was initially using a psd that had a icc profile embedded? Just thinking out aloud as to reasons for causing it........

 

 

p.s. bug:  psd import still ignores a set opacity % setting in the file for layers. i.e. multiply layer @ 50% opacity will import at 100%  :(

Edited by Boonta

Share this post


Link to post
Share on other sites

I was getting some crazy lag in 4.0 and 4.1 recently when i would change between tools (Within the same brush set ( i have noticed this also causes lag but that's another issue...)

 

but yeh i would get crazy lag switching from a brush to a eyedropper etc. the only way i managed to resolve it was to rebuild the scene (re import the obj and then import in layer colors psd...) 

 

i couldnt think of what triggered the lag as it was working great all day. The only thing i can think that i did differently was at one point i did a CTRL+P and sent my file to photoshop briefly then back again. not sure if this corrupted anything in the file? No ICC profile was saved at that point .. however i was initially using a psd that had a icc profile embedded? Just thinking out aloud as to reasons for causing it........

 

 

p.s. bug:  psd import still ignores a set opacity % setting in the file for layers. i.e. multiply layer @ 50% opacity will import at 100%  :(

Try downloading the latest build (4.1.07B), as Andrew did some work over the past several builds to make 3D Coat more compatible with PS. If that doesn't work, send an e-mail to support@3d-coat.com

 

He's currently working in the Paint Room, so if there are indeed issues in the app...not just an isolated issue on your end (ie., a buggered up OPTIONS.XML file), then it would be a good time to address it

Share this post


Link to post
Share on other sites

Mac too -  progress = spinning beach ball of death.

Mac  - standard convention requires, cmd key should emulate right click.

 

I thought that was Cntl key.

Share this post


Link to post
Share on other sites

I've been wondering for a while now, is 3DC mostly a weekend project for Andrew? Seems like updates are almost always on Saturday/Sunday.

Share this post


Link to post
Share on other sites

I've been wondering for a while now, is 3DC mostly a weekend project for Andrew? Seems like updates are almost always on Saturday/Sunday.

 

3DC build and server uploads are mostly a weekend task.

Share this post


Link to post
Share on other sites

I've been wondering for a while now, is 3DC mostly a weekend project for Andrew?

a weekend project?? I really don't understand the meaning of this question.

Share this post


Link to post
Share on other sites

a weekend project?? I really don't understand the meaning of this question.

 

Ah, I meant is the majority of work is done over the weekend? I'm not actually sure if Andrew works on 3DC fulltime or has another job asside from it.

Not trying to be rude, just seems like that's when Andrew mostly posts and when updates are released.

Share this post


Link to post
Share on other sites

Ah, I meant is the majority of work is done over the weekend? I'm not actually sure if Andrew works on 3DC fulltime or has another job asside from it.

Not trying to be rude, just seems like that's when Andrew mostly posts and when updates are released.

How does the release day of the updates has anything to do with when the work is done?? :)  I dont understand the logic behind your question.

If betas were mostly released on tuesdays would it imply Andrew only work on tuesdays??

  • Like 2

Share this post


Link to post
Share on other sites

Updated to 4.1.08

- Chiesel/flattern got improvement - much more predictble trajectory and better quality. Normals sampling got better algorithm - normals are sampled along trajectory, not in just end spot.

- Noise tool introduced in surface mode with realtime preview and infinite details. Pay special attention to anisotropic mode. It is good for natural stones. In Normal mode it is good planet generator. This tool is only initial iteration for future noise tool, node editor expected there.

- Vertical lathe curve

- ui in primitives polished a bit (tooltips, icons).

- fixed very important problem that was happening sometimes (mostly depending on computer and OS, most frequent on Win 8.1) that was causing strokes screwing.

26 May - 5 June I will be in vacation - we will get rest on villa in Cyprus just with my wife. Romantic time :)

I will be there one day more, so if something awful will be found - I still will be able to fix.

  • Like 5

Share this post


Link to post
Share on other sites

Can't wait to try out these features!  Hope you have a great time with the wife!

Share this post


Link to post
Share on other sites

Also has this small but welcome tweak: http://3d-coat.com/mantis/view.php?id=1170

 

----

 

Speaking of moving layers, the current visual indicator for where the layer is to be dropped has always seemed sort of inexact to me. It highlights the layer that the one being moved to bill be next to, but it doesn't specify if it'll be dropped above or below it. A line between the layers showing exactly where it'll be dropped instead of a highlight seems to me like it would make far more sense:

 

HucC9Ps.jpg

Edited by PolyHertz
  • Like 4

Share this post


Link to post
Share on other sites

Any chance on a Linux build of this version before you go on holiday?   :)

 

Jason

Share this post


Link to post
Share on other sites

Thanks for the upgrade Mate,

Love the new Noise Maker.

Have a great Holliday.

Share this post


Link to post
Share on other sites

Bug ?

 

Preferences

Show import thumbnails in start page

Select Surface mode

Head

 

Noise Generator Tool

 

Realtime Preview (<-- typo warning*)

 

Switching

ON

OFF

ON

Crash

---------------------------------------------------------------------

Noise destroy symmetry if isnt in VIEW MODE, any setting to avoid it ?

post-10142-0-28652300-1400977153_thumb.j

post-10142-0-15998300-1400977359_thumb.j

 

//edit

a save/load option will be cool

 

This is freaking time saver...

TY VERY MUCH !!

 

post-10142-0-06527400-1400979845_thumb.j

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×