Jump to content
3DCoat Forums
Andrew Shpagin

V4.1 BETA (experimental 4.1.17D)

Recommended Posts

Tweak UV vertices in Retopo Room is working well ?

here destroy the geometry moving ghosted vertices to anywhere

----------------

And delete one retopo layer group delete faces of another layer

Share this post


Link to post
Share on other sites

Feature request.

Is it possible to make the selected uvisland in retopo or uvroom to be more neon bright color? :D

Highlight is too soft imo.

Share this post


Link to post
Share on other sites

Two questions.

Is there a way to give the preset brushes a own name?

There is a field that i could give the brush his own name, but after reopening 3d coat, i see the original name of that brush and not my custom name.

I love to save incremental, is there a way to change the SHIFT+CRTL+S to only CRTL+S and in the other way for normal saving?

Edited by Malo

Share this post


Link to post
Share on other sites

I love to save incremental, is there a way to change the SHIFT+CRTL+S to only CRTL+S and in the other way for normal saving?

Hi,

try to first delete the hotkeys by hovering your mouse over the menu item and pressing BACKSPACE. Then press END and assign a new one :)

Share this post


Link to post
Share on other sites

Thanks, works.

Now i need only help with the custom name of my brush presets.

Share this post


Link to post
Share on other sites

Thanks, works.

Now i need only help with the custom name of my brush presets.

right-click on the preset and choose "rename" or double-click on the current name. Same way you can change the layer name anywhere in the application

Share this post


Link to post
Share on other sites

right-click on the preset and choose "rename" or double-click on the current name. Same way you can change the layer name anywhere in the application

Yes, but if i close 3d coat and open it again, the custom name is gone and the preset brush use the original name again.

I use the LiveClay brush, i modify it, i save it, i rename it into Malo, everything looks OK, i close 3d coat, i open 3d coat, and i see LiveClay instead of Malo in my presets.

Something goes wrong on my side, but what?

Share this post


Link to post
Share on other sites

Yes, but if i close 3d coat and open it again, the custom name is gone and the preset brush use the original name again.

I use the LiveClay brush, i modify it, i save it, i rename it into Malo, everything looks OK, i close 3d coat, i open 3d coat, and i see LiveClay instead of Malo in my presets.

Something goes wrong on my side, but what?

That is strange, indeed. Try clicking the little triangle/drop list in the upper right hand of the panel and choose "save preset file." When you leave the app and come back, see if that doesn't store it permanently.

Share this post


Link to post
Share on other sites

Seems like updates on Mantis have almost stopped completely over the past week or so, Andrew on break or maybe working on something big?

Share this post


Link to post
Share on other sites

Seems like updates on Mantis have almost stopped completely over the past week or so, Andrew on break or maybe working on something big?

It's usually an indication that he's working on something substantial...when he goes quiet for a while. Nevertheless, he did accommodate one feature request. That is an icon to clear all paint layers, in the Paint room. When you try to merge a model from the Retopo Room, sometime is takes multiple attempts/adjustments to get a satisfactory result. But before making another attempt, you should clear all the objects and paint layers in the Paint room beforehand. Up until now, that could be very tedious to do. It's not uncommon to have to delete several paint layers..and you could only do so one at a time.

This should be a one click process.

Share this post


Link to post
Share on other sites

If that's the case, I wonder if it's an indication that whatever he's working on has to do with the Paint Room? Would like to think all the talk about the paint room a few pages back got his attention.

Share this post


Link to post
Share on other sites

That is strange, indeed. Try clicking the little triangle/drop list in the upper right hand of the panel and choose "save preset file." When you leave the app and come back, see if that doesn't store it permanently.

I got it,

After if rename a custom brush, i have to klick on update preset, too.

Then it would be loaded on a new startup.

Thanks for the help.

Share this post


Link to post
Share on other sites

It's usually an indication that he's working on something substantial...when he goes quiet for a while. Nevertheless, he did accommodate one feature request. [..]

It is amazing see Andrew really progressing with 3D-Coat. In sharp contrast to Silo, where its developers created disaster after disaster with super buggy product and angry + leaving customers. Most of Silos features were excellent ideas, the program worked well 6-7 years ago. Realization of new features were carried out the worst way, resulting in a catastrophe and people intensely hating the developers.

Its nice to see Andrews integrity and how the people stand at his side. Plus Andrew isn't just promising features, he realizes them, progressively making a new tool more useful and handy. Also if a number of users miss big features as wishlist in 3DC, it seems that is because Andrew intelligently must have calculated to use his development time to create another feature that he deemed more useful for more people.

If the Pilgway expansion means employing another skilled programmer i think the wishlist finally gets coded to 3DC.

Edited by mercy

Share this post


Link to post
Share on other sites

BUG:

I have found that 3DCoat continuously opens files (ports) but doesn't close them as stated a few posts ago, it seems that 3DCoats limit before you get the "Too many files open" dialog when you try to save is just over 1000 (1028), I reached this limit by just leaving 3DCoat open over night.

Please, Andrew or Sergyi, can you fix this, without this being fixed there is NO way I can use your program.

T.

Share this post


Link to post
Share on other sites

The beta builds were labeled "Version 4 BETA" BEFORE the official release of Version 4. Now that Version 4 has been released, the current beta builds are ALSO labeled Version 4? That does not make any sense to me. The beta builds should not be labeled Version 4 both before and after the official release of Version 4. The reason why this is a problem is that the users who buy the software think that there is a a stable Version 4 release. But apparently there was never a final Version 4 release. It seems as though it is always in beta.

This was also a problem with Version 3.7 because Andrew attempted to turn off the Version 3.7 features for the release of Version 4. This was very confusing, because the builds that came out AFTER the 3.7 release were ALSO labeled "Version 3.7" so everybody thought they were just getting tons of free updates to the software, but in fact those builds were meant to be Version 4 Beta builds...

Now that whole problem is happening again because the current betas are still labeled Version 4. If Andrew is not ready to call the new beta builds Version 5, then how about 4.5? Anything but Version 4.

Share this post


Link to post
Share on other sites

My point of view

Any software need patches

Autodesk release Subscription Advantage Pack and subscription support

Modo with V7

Blender

I found the v4 number just label all the features that was in beta stage, and now are suited with the new version.

And to # every patch with a .00.0X sounds logical

in another way, for me 3DC support is very strong and receptive

regards :)

Edited by carlosa

Share this post


Link to post
Share on other sites

That keep being brought up. Andrew should just start a new thread for the v4.1 beta once the first major changes happen (which might be underway atm).

Share this post


Link to post
Share on other sites

3DCoat continuously opens files (ports) but doesn't close them

http://3d-coat.com/mantis/view.php?id=1195

please add +1 ty

Thanks for submitting the bug report Carlosa, I have so much on my plate at the moment I just didn't have the time to submit it myself, I am using ZBrush at the moment because it never causes any problems and I get my work done, BUT I would rather use 3DCoat.

T.

Share this post


Link to post
Share on other sites

Updated to 4.0.05. It is BETA, after approving may be marked as stable. But there was a lot of changes, needs some testing.

- Many surface brushes got 2 new parameters - Normals sampling and Buildup. It is very important for convenient and predictable sculpting.

- New major feature (Split&Joints) in 3D-Coat for 3D-printing: http://pilgway.com/files/SplitNJoint1.png http://pilgway.com/files/Joints2.png

- Lathe tool (one of primitives) - http://bit.ly/14Int9B , other example - http://bit.ly/19Og3YZ

- New principle of pinching introduced - "Angulator" tool. See there - http://www.3d-coat.com/files/Angulator.png

- Primitives/Models may perform intersection or splitting of objects in scene

- Primitives functionality and UI improved, now you may choose boolean operation type - http://www.3d-coat.com/files/SplitPrim.png

- Very nice and convenient grids and snapping improvements! Look there - http://bit.ly/121Xozk , http://bit.ly/17EjLDW

- Lute brush - http://pilgway.com/files/Lute.png

- Spherical/Cylindrical mapping introduced for masks and materials - http://bit.ly/165Lats

- Now every tool in voxel room may be duplucated or hidden via RMB: http://bit.ly/12a9wiS . It allows to replace and customize existing tools

- If ptex scene has multiple objects, it is now possible to export ptx files separately, one ptx file per object. Colored specular/emissive export for ptex done too.

- Several mantis reported problems fixed.

As soon as it will be checked just a bit, I will send sources to Linux/Mac compiling.

  • Like 2

Share this post


Link to post
Share on other sites

Those complaining about download speed are right. I didn't try since this issue appeared but instead of the 20-30 minutes download I now get a 1h10 mins. Weird.

[EDIT] My bad: bad configuration of a rps. It's back to normal speed.

Share this post


Link to post
Share on other sites

Updated to 4.0.05. It is BETA, after approving may be marked as stable. But there was a lot of changes, needs some testing.

- Many surface brushes got 2 new parameters - Normals sampling and Buildup. It is very important for convenient and predictable sculpting.

- New major feature (Split&Joints) in 3D-Coat for 3D-printing: http://pilgway.com/files/SplitNJoint1.png http://pilgway.com/files/Joints2.png

- Lathe tool (one of primitives) - http://bit.ly/14Int9B , other example - http://bit.ly/19Og3YZ

- New principle of pinching introduced - "Angulator" tool. See there - http://www.3d-coat.com/files/Angulator.png

- Primitives/Models may perform intersection or splitting of objects in scene

- Primitives functionality and UI improved, now you may choose boolean operation type - http://www.3d-coat.com/files/SplitPrim.png

- Very nice and convenient grids and snapping improvements! Look there - http://bit.ly/121Xozk , http://bit.ly/17EjLDW

- Lute brush - http://pilgway.com/files/Lute.png

- Spherical/Cylindrical mapping introduced for masks and materials - http://bit.ly/165Lats

- Now every tool in voxel room may be duplucated or hidden via RMB: http://bit.ly/12a9wiS . It allows to replace and customize existing tools

- If ptex scene has multiple objects, it is now possible to export ptx files separately, one ptx file per object. Colored specular/emissive export for ptex done too.

- Several mantis reported problems fixed.

As soon as it will be checked just a bit, I will send sources to Linux/Mac compiling.

Cool. Thanks, Andrew..

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×