Jump to content
3DCoat Forums
Schoening

Steam Version, Problems..

Recommended Posts

I don't know what is going on... First of all, the CUDA version has started to crash every time.

And secondly, My mouse no longer rotates and can be used for anything but to use the brush..

I can't pan, move scale or do anything with the mouse, except when I press CTRL, and when I release the control button, it moves back to default..

I am sure that I have not changed any settings.. I also deleted and reinstalled it, but nothing works.

I would appreciate some help, since it did cost quite a few Euro for the commercial version that I bought..

Cheers

Share this post


Link to post
Share on other sites

Hi!

So you are able to use 3d-coat a while. It dosen't crash right after starting the program. Were you able to use CUDA version normally before this issue started to happen and

if you use non cuda version does it work? Could you also give info what kind of computer do you have with specs.

Share this post


Link to post
Share on other sites

Toshiba Laptop

64 bit windows 7 Home Premium

8GB ram

AMD a8-3500m apu with Radeon HD graphics 1.50GHz

I tried most version now.

All the same.. I am going to try on another PC perhaps it works there.. Very strange that it worked in the start

Share this post


Link to post
Share on other sites

Have similar problem. I tried to run 3d-coat from steam application and it does not stared even.

So, then i downloaded last stable version from this site and used license code from the steam.

Now It works.

Share this post


Link to post
Share on other sites

Toshiba Laptop

64 bit windows 7 Home Premium

8GB ram

AMD a8-3500m apu with Radeon HD graphics 1.50GHz

I tried most version now.

All the same.. I am going to try on another PC perhaps it works there.. Very strange that it worked in the start

Ahh...there's the problem. CUDA is at this time strictly an NVidia technology, so if you have an ATI/AMD graphics card, you cannot use the CUDA version. OpenCL is still a bit too immature for many developers, but maybe Andrew will visit that at some point in the V4 cycle. I've been trying to get him to update and expand CUDA's usage in the application, but I think he's had bigger fish to fry. There is a relatively new technology that might make it easier for him to use the code he currently has and convert it from CPU to GPU multi-threading. It's called OpenACC. In a nutshell, the programmer adds directives (hints) in their current code...instead of having to re-write everything.

Another technology that may be considered is OpenSubdiv, recently released from Pixar...which supports CUDA and OpenCL. In the mean time, CUDA is nice,but it still has somewhat limited application in 3D Coat. Most of the application relies on CPU multi-threading...which took a lot of work on Andrew's part. So, on your laptop, it's probably not going to matter a lot anyway. The more CUDA cores you have the more it benefits. Most Laptop GPU's are much, much lighter in the number of Cores they have, compared to their desktop counterparts. I had an i7 model with an Ati card and it performed pretty well without CUDA.

Share this post


Link to post
Share on other sites

Toshiba Laptop

64 bit windows 7 Home Premium

8GB ram

AMD a8-3500m apu with Radeon HD graphics 1.50GHz

I tried most version now.

All the same.. I am going to try on another PC perhaps it works there.. Very strange that it worked in the start

As Don already mentioned, but is worth mentioning again; CUDA is Nvidia exclusive. It will not work with ATi video cards. 3DC will still perform quite well without CUDA of course, it only enhances some of the brushes and operations in voxel mode. Nothing more. :)

Share this post


Link to post
Share on other sites

This is all well and nice, but it still does not explain why I can only use the "movement tools" when I hold CTRL down and it immediately resets when I release CTRL..

The 64Bit version OpenGL does NOT crash. So that part worked, Thx :)

But it still resets and cant use move tools..

Also, Voxels seem to work fine even without CUDA.

Gonna run it on my desktop today. Has a good Nvidia card

Share this post


Link to post
Share on other sites

It works on my Desktop PC !

Also in CUDA.

It also looks "better" in the desktop, that is to say it looks like on my laptop before it got buggy. Images on the Brushes etc.

So how do i change those settings, because it might be in the settings...

Reinstalling didnt do it

Share this post


Link to post
Share on other sites

It works on my Desktop PC !

Also in CUDA.

It also looks "better" in the desktop, that is to say it looks like on my laptop before it got buggy. Images on the Brushes etc.

So how do i change those settings, because it might be in the settings...

Reinstalling didnt do it

That is an odd problem. Never had that occur before. I would try to delete the Options.XML file (My Documents > 3D Coat)...as it sometimes causes bug-like behavior if it gets corrupted somehow. Then make sure you have installed the latest drivers for the graphic card. I will just tell you this. ATI/AMD is pretty notorious for not behaving well with some CG apps. I was a long time AMD/ATI user (bang for buck reasons), and had issues with some apps I was using and no amount of research online would help me resolve the issues (for example, Combustion particles would not work at all and much of the UI had annoying glitches like you described).

I heard others mention that AMD was bad about not working right with many CG apps...so I went down to Best Buy, picked up the best NVidia card I could find in my pricerange > installed it and bam! All those problems disappeared. Haven't even considered buying an ATI/AMD card since.

That's not to say that you can't work at all with CG apps...but don't be surprised when you have issues arise like this. 3D Coat played nice with the i7 laptop I had (Radeon card with 1MB VRAM), but I will still try to steer around them in future purchases. I think they are just so focused on games, that they could care less if game cards work with CG apps. Their mindset is that if you want this sort of reliability with professional CG apps., you should buy their expensive workstation cards.

Another thing you could try is setting the navigation preset to something else...like Maya. Also, I try and disable the Navi-Zone (little boundary on the outer edges of the viewport). It's annoying to me, so I go all the way to the bottom of the big panel for navigation customization, and uncheck it. You can see some of this in the following video:

Share this post


Link to post
Share on other sites

Ill try this later thx :)

I got the pc for half price, and it was a good buy. I used to be a big Radeon fan because of some rumours about the nvidia transistors burning up after 2 years used (Did on my old Nvidia)

Share this post


Link to post
Share on other sites

Even with deleting EVERYTHING, it still effs up :s

Am I able to download the Linux version with a Steam Licence? Because then I would try to run it on my second OS. (Ubuntu)

EDIT: Editted for language. Family friendly please, there are people of all ages on the forum. Thanks. -Admin

Share this post


Link to post
Share on other sites

Try downloading the latest V4 Beta build from this forum (first page in the V4 Beta thread), and if you get a prompt for your registration #, try the one you got from Steam. If this problem persists, try a screen recording (JING is free and you can upload directly to screencast,com, to store your video), and contact Andrew (support@3d-coat.com). If you have a critical bug, he usually drops what he's doing to try and help squash it. It may seem a bit of a hassle, but recording on screen gets results a LOT faster than otherwise. Hard to tell what the nature of the problem is, oftentimes, without seeing what process is occurring when the issues arises.

V4 Beta thread:

http://3d-coat.com/forum/index.php?showtopic=10395&st=0

Jing:

http://www.techsmith.com/jing.html

Share this post


Link to post
Share on other sites

Not even V4 will work properly.

Recap:

The problem is that I only can Rotate, Zoom, and Move while CTRL is Down, or when I use the movement buttons for this. And once I release CTRL or the buttons it RESETS to the start position.

Share this post


Link to post
Share on other sites

In that video with the Elmo Fudd viking, the guy who's narrating has an arrow that he clicks on, to allow the visual style of the buttons in the various rooms to be changed, so that they're icon, description, or combination of those. I have the latest version of 3D coat (3.7.08B), but I don't have those options, so is this something not available any more, or is it cuda only, or some other thing please?

Share this post


Link to post
Share on other sites

In that video with the Elmo Fudd viking, the guy who's narrating has an arrow that he clicks on, to allow the visual style of the buttons in the various rooms to be changed, so that they're icon, description, or combination of those. I have the latest version of 3D coat (3.7.08B), but I don't have those options, so is this something not available any more, or is it cuda only, or some other thing please?

Those are only available in builds from 3.17 or newer. You should go ahead and download the latest V4 Beta. A V3 license will currently work on it, or even if you're using the 30 day demo.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×