Jump to content
3DCoat Forums
ajz3d

A few questions about... (see tags)

Recommended Posts

I have a few questions that have been puzzling me for several days now:

  1. Retopo Room: How to hide a wire-frame that lies on back faces? If you look at the first image, you can clearly see that the wire-frame is still visible even though it should be obscured by polygons in the foreground. It doesn't matter how transparent I set the retopo mesh to be.
  2. Render Room: Is it possible to move the DOF plane or scale it? When there's a large model to be rendered, the DOF plane appears to small. This means I cannot accurately set my camera focus on the eyes for example (see: second image). Also, if only a part of the model is to be rendered (with the rest of it hidden), like a head, then after closing up on it, you can't even tell how the focus is set because the DOF plane is completely out of sight.
  3. Render Room: How do I set a centre of rotation for turntable renders? Is it always at zero world coordinates? Is it possible to set it to model's centre of mass or to a custom location?

Can anyone help? :)

post-12523-0-21273100-1354457363_thumb.j

post-12523-0-98832800-1354457379_thumb.j

Share this post


Link to post
Share on other sites

To attempt to answer no 1. I did a little mini sculpt to try and reproduce your issue.. but I couldn't. However, I did find 'backfaceCulling' in the View menu. Does that make any difference when you toggle that setting?

Share this post


Link to post
Share on other sites

I don't think the wireframe should be rendered when its hidden behind other polygons no matter what bf culling is set to. It looks like something completely not dependent on this option.

I can't check the state of Backface Culling until my turntable render is complete, but I'm almost sure I have it enabled.

Share this post


Link to post
Share on other sites

Please, take a look at this:

I'm toggling here between perspective and ortographic views. Notice what happens.

In perspective, you can see wireframe even on backfaces. In orto, there's no wireframe at all (even worse!).

Sorry, it's the other way around:

In orto, you can see wireframe even on backfaces. In perspective, if your camera is far enough, you will see wireframe. But if you zoom in, it will disappear. It has something to do with zdepth. I'll post a video showing this issue ASAP.

Share this post


Link to post
Share on other sites

Ok, I just spent 20 mins loading the default manikin into the Voxel room and recreating your retopo mesh. I cannot recreate your issue. I have tried toggling settings, not only in the drop menus but in the preferences as well.

Unless someone else comes on and finds a solution I would be asking you questions like, what version are you using, what operation system are you using, do you have the latest drivers install for your graphics card. Do you have any non-default software settings applied to your graphics card.

Other than that, you may have to open a bug report in Mantis.

Ricky.

Share this post


Link to post
Share on other sites

Thank you Ricky for your time. I appreciate it.

My OS is Win7 Pro x64, card is GF 9800GTX and no, I don't have the newest drivers for my graphics card. But I'm not too eager too update them, as up to now every single 3D application worked perfectly on them and I simply don't want to break anything.

The problem occurs on both CUDA and non-CUDA DX version of 3D Coat V4 Beta6D.

Oh, and 'ere goes the video:

For a change - I used a non-CUDA version.

In the first half of the video I'm using ortographic camera. Note the wireframe behind the foreground polygons.

In the second half I have switched to perspective. The wireframe disappears after zooming in. If I decrease the z-bias, it appears again. It's almost like polygons are obscuring the wireframe

P.S. Looks like both OpenGL versions work just fine (but man, they're slow!). So the issue must be somehow tied to DirectX!

Share this post


Link to post
Share on other sites

P.S. Looks like both OpenGL versions work just fine (but man, they're slow!). So the issue must be somehow tied to DirectX!

Which would indicate a driver issue, probably? Do you have the latest DirectX installed?

Share this post


Link to post
Share on other sites

1- Clipping distance start/end

The feature has already been added...

You can adjust the near clipping plane under Preferences / Viewport / Near plane modulator

2- this model is big O_o

Try to transform it to keep inside the grid size, DoF size...

Why?if model is big... the default light need MORE strength -intensity- to lighting the far zones... but have to much strength over the near zones... burning the final render

3- Open Camera menu -top right-

Rotate around... there is some options

Share this post


Link to post
Share on other sites

I think I fried my rig. I was fooling around in the Render Room at 1 fps and suddenly everything froze. Now my PC keeps restarting itself every five or seven seconds. It won't even display the manifest. Either it's something with mobo capacitors, PSU or CPU. What a bad luck. :cray:

I've managed to check your suggestions though. Unfortunately 1) only clips the polygon display when you zoom in very closely towards the mesh. With lower values polygons disappear faster than with higher values. So sadly it didn't fix the wireframe problem.

2) Yes, but it's a workaround. What if you have a real scale model and you have to keep its scale consistent when moving it between the apps?

3) Yup, there are camera rotation options and I have been using them extensively for a long time. The thing is, they seem to be ignored during automatic turntable sequence rendering in the Render Room. For example, if I use a "Rotate around current pick point" (which means that the model will rotate around last known cursor position over the mesh), the mesh in the Render Room rotates as it should. But just press the Render button to render the turntable sequence, and the centre of rotation is suddenly located elswhere. Also, the model "moves" some place else within the camera frame. It almost feels like the rotation axis and model position was hardcoded for sequence rendering.

I would investigate this further, but from obvious reasons I won't be able to do it in the next several days, until I either buy a new machine, repair the old or it magically repairs itself (same thing happened to my rig a week ago, but somehow it started to work again).

Oh, and thanks for the tip with the lighting in 2). I will test this as soon as I can. :)

Share this post


Link to post
Share on other sites

Considering the wireframe problem in Render room... I don't have one neither in Persp nor Ortho mode (see attach)

I'm on Win7 Pro 64-bit using v4 BETA6B 64bit CUDA GL. My graphic card is GTX 460 SE (driver version 301.42)

BF culling is used to see double-sided "flat" polygons or not-closed meshes

post-896-0-11975000-1354619191_thumb.jpg

Share this post


Link to post
Share on other sites

Thanks Daniel.

I don't have any wireframe problems with CUDA/non-CUDA GL versions as well. These versions (apart of being quite slow on my card) are working without problems.

It's the CUDA/non-CUDA DX64 that gives me a headache..

One more thing I can think of trying, is to test whether the wireframe issue was present in the latest V3 build. I'm not sure, but I think I've started to notice it since one of the V4 Betas. Or perhaps I was too absorbed by working in other rooms to realise that something is not right with those wires in Retopo.

Maybe it's a general issue with 9800 GTX/GTX+ cards?

By the way, Daniel. How is the GTX460 performing in 3D Coat? I'm planning to purchase this card (or GTX285) in the near future. I heard they're one of the last mainstream nVidia cards with a decent OpenGL support.

Share this post


Link to post
Share on other sites

I have this issue too, I posted to Mantis long ago...

It is not fixed because Andrew is probably not able to reproduce...

I don't know what is causing this...it happens with any model work on ,

I constantly needs to play with zoom in/out + fov values to get wireframe to display properly in retopo room.

Zbias does not really help. I need to zoom out to a certain distance then lowering Fov to simulate a "zoom in".

Also its not posssible for me to do retopo work in ortho I see backfacing wireframe everywhere.....

Im using gtx280 on a x64 Dx build

Share this post


Link to post
Share on other sites

Yep :( DX problem! Reported to Andrew

about GTX 460... i can't tell much as I don't have other graphic card to compare (I had 9800GT, but I don't remeber its performance already). It works OK for me. Sorry, can't help

Share this post


Link to post
Share on other sites

I just found your reports:

http://3d-coat.com:8...view.php?id=352

http://3d-coat.com:8...view.php?id=351

Yup, that's it.

Could you please check if you have this bug in CUDA/non-CUDA OpenGL versions? I bet those are OK.

Andrew attached 2 files there http://3d-coat.com/mantis/view.php?id=352

,copy both in main 3DCoat shader folder.

It fixed the issue on my side.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×