Jump to content
3DCoat Forums
HorribleGoat

Material/UV Export bug

Recommended Posts

Hi,

got back to 3dCoat after a while and ran into some trouble with the latest 3D Coat build and model export.

I have a character model with multiple UV maps, and for some reason different amount of materials.

Now the problem is that when exporting the .obj it has the UVs are mapped correctly, BUT the color/specular/normal maps are exported by the UV in 3d Coat (as has been in previous versions i've used) and the UVs are grouped by the MATERIALS in the .Obj

In my case at least UV map =/= Material

as some of the materials are spread between 2-3 UV maps.

I've got 7 UV maps and 8 material groups and currently am at loss.

4.00 BETA7 is my version, though im going to see if this is a problem with the old trustworthy 3.7..

update

Oh yes and actually it does not batch export all the textures either. Only those that have 1 UV on 1 Material. I can export those manually (what i did before) and apply them on the model but the UVs and Materials are not grouped right.

This of course could be me and using the old Milkshape3D, but as it has worked before.. :I Also 3.7.18S(DX64) produces same results.

Edit..

So what I need is materials regrouped by the UV maps, has this been possible before or am I just dreaming?

Share this post


Link to post
Share on other sites

Some testing on the matter.

First I opened up the .3b I have of the model and saved the UV (7 UVs total) in the UV-tool tab, then I took the exported obj and removed all materials from it and re-exported it as a new obj and imported it anew to 3DCoat. Now I had a clear model with 1 Automated UV set and 1 Material. Then I created 6 more empty UV sets (total of 7) and as new UVs were created the program also made corresponding materials for them. Then I opened the Old UV I had saved on top of it.

Results were promising at first as the all the 7 uv sets had all the pieces where I wanted them and the materials responded to hide/show testing and all seemed to be in place. I hit the apply UV and it crunched some numbers I'd suppose and I opened the paint tab to see if it worked..

It sadly didn't. In the paint room only the models eyes were visible and everything else seemed to be wrapped around them. Then I switched back to UV tab and the Uvs were total mess and the preview showed the model had turned into a psychedelic Cthulhu monster.

I am probably only one with this but help would be appreciated. I'll keep updating if I come up with anything.

Edit-

In the UV room I noticed that the Materials are all wrong again, though they were as they should be when I loaded the Old UVs, and nothing changed when I Applied the set, they seemed to have broken when switching back to paint room. Now all UV sets are under the first material again.

Also was able to produce a error message stating that there might be a corrupted XML file somewhere with the UV tools.

One more thing.

The exported OBJ contains A huge number of new groups of small pieces named with a name of the material they try to use. However this is not helpful as Material =/= UV tile. Where they named by the UV tile they are using, I could quite easily manually fix this, but righ now it is pretty hard.

post-6772-0-14284600-1355735210_thumb.jp

Share this post


Link to post
Share on other sites

Hi carlosa!

Yes I'd say this is exactly what my problem is related to. The thing is some materials are now spread on multiple UV sets in 3DCoat but 1 UV set should only be assigned to 1 material.

Share this post


Link to post
Share on other sites

Manually editing the material/ UV set assignments of the multi UV materials fixed it, but if anyone else happens to run into something like this I'd like to know if the reason is ever uncovered.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×