Jump to content
3D Coat Forums
alvordr

[Solved] Baked Occlusion All Black

Recommended Posts

For some reason I sometimes get baked occlusion coming out all black. Is there something I need to do or undo to fix this?

Share this post


Link to post
Share on other sites

The first thing that comes to my mind is ray casting length set to a far too great number. This theoretically could result in blackness if model is of small scale.

It might be also inverted normal vectors, but if you're able to paint on the model then you can scratch that, I think.

Also, perhaps the model doesn't have UVs?

Other than that, I don't know.

Share this post


Link to post
Share on other sites

which shader base do you use for baking ?

Share this post


Link to post
Share on other sites

Picmat_Carpaint. But I used it for other objects in that very scene that worked fine.

I eventually just rebaked with different projection settings. I bet it was a cage thing.

Share this post


Link to post
Share on other sites

After some experimentation, I've found it's the rays and bake settings. Sounds reasonable, but I had to test it. Your rays need to be able to "fit" inside the inner and outer bake. It's not necessarily what you might think. For my scene, my inner was 1.5 and outer was 3 and my rays were put at 10. Before that the rays were at 20 and I got all black. Hope this helps.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×