Jump to content
3DCoat Forums
ohsnapitsjoel

Setting scene scale for Blender - 3D-Coat scaling issues

Recommended Posts

Hi again (I'm posting a lot of new threads in the last couple days...), I have another newbish question.

I know the commands exist for changing the scene scale in 3D-Coat, etc., but I'm not sure how to use them such that I can get Blender and 3D-Coat to play nicely together in terms of model scale. Using default settings in 3D-Coat and Blender, if I export a mesh from Blender for voxel sculpting, it's infinitesimally small in 3D-Coat. Then when I export a model from 3D-Coat, it's enormous in Blender. This is the case with or without using the applink addon.

I wouldn't otherwise mind, but I like using Blender's retopo tools on sculpts, and the mismatched object scaling creates a hitch in my workflow when hopping back and forth between apps for various tasks.

Share this post


Link to post
Share on other sites

Here is a way that is easy once you have set it up...

The default 3DCoat dimension scale is 1 meter... you can check to be sure under the voxel menu / define measurement units.

Create a 1 meter cube in another application. I have included one here as a attachment.

Merge the cube into a new 3DCoat scene in surface mode. Be sure to close out 3DCoat and then reopen to get the default scene dimension and scene scale before merging the cube. Very Important

Do not scale the meter cube at this time. press enter to apply and an say yes to keeping the object scale. It does not matter that it is tiny at this moment.

Rename the vox tree layer to something like (one meter cube).

Now hover your mouse cursor over the layer on the far right and an icon will appear. Left click and hold the mouse button down,now drag the layer into the models panel. You will see a (+) at the end of the models panel. Drop the layer there.

First part done and now on to the next part.

Make sure Blender's scene scale is set one meter.

Be sure that you have closed and reopen 3DCoat before doing the below.

Merge the one meter cube into your 3DCoat scene by left clicking on the cube's icon in the model panel. Do not merge any objects prior to this operation.

Next scale the meter cube up to a size you can work on and press enter to apply and be sure to say yes on keeping the scale and dimensions of the object when the dialog box appears.

When you export the object or objects you create they will be correctly exported out at the meter scale which will match Blender's meter scale...

That is the purpose of the dialog box, so we can increase the scene scale in 3DCoat for ease of working on our models but upon export the true dimensions of our object have been remembered and will be exported at those original dimensions.

Your scene is now set up for creating your models at the proper one meter scale for working painlessly between 3Coat and Blender.

Note. You also can scale that meter cube up to a working size and save that scene as a default scene for starting all your models that will be used in Blender. That way you would have a scene where you would not have to merge the cube each time and scale it up... You can keep the cube in the scene as a reference point knowing that it is one meter in size.

I have included a one meter cube, Checked it in Blender to be sure...

This method works, if you run into a problem you just missed a step. Yes a video tutorial would help, If I find the time....

EDIT: I should have said just hover your mouse cursor over the layer and then left click on the icon, correction done...

post-518-0-92544700-1359575994_thumb.png

Blender Scale.zip

  • Like 1

Share this post


Link to post
Share on other sites

i used to scale the exported obj x10

sometimes i use blender applink too

http://3d-coat.com/f...?showtopic=6706

hi! thank you for the response; that won't really solve my particular issue though :\ if possible, i really need to set the scale from within 3D-Coat, because of the particulars of my workflow. i'd like to find a way (assuming this is even possible) to keep the meshes the exact same scale when bouncing them back and forth between Blender and 3D-Coat.

Share this post


Link to post
Share on other sites

Here is a way that is easy once you have set it up...

The default 3DCoat dimension scale is 1 meter... you can check to be sure under the voxel menu / define measurement units.

Create a 1 meter cube in another application. I have included one here as a attachment.

Merge the cube into a new 3DCoat scene in surface mode. Be sure to close out 3DCoat and then reopen to get the default scene dimension and scene scale before merging the cube. Very Important

Do not scale the meter cube at this time. press enter to apply and an say yes to keeping the object scale. It does not matter that it is tiny at this moment.

Rename the vox tree layer to something like (one meter cube).

Now hover your mouse cursor over the layer on the far right and an icon will appear. Left click and hold the mouse button down,now drag the layer into the models panel. You will see a (+) at the end of the models panel. Drop the layer there.

First part done and now on to the next part.

Make sure Blender's scene scale is set one meter.

Be sure that you have closed and reopen 3DCoat before doing the below.

Merge the one meter cube into your 3DCoat scene by left clicking on the cube's icon in the model panel. Do not merge any objects prior to this operation.

Next scale the meter cube up to a size you can work on and press enter to apply and be sure to say yes on keeping the scale and dimensions of the object when the dialog box appears.

When you export the object or objects you create they will be correctly exported out at the meter scale which will match Blender's meter scale...

That is the purpose of the dialog box, so we can increase the scene scale in 3DCoat for ease of working on our models but upon export the true dimensions of our object have been remembered and will be exported at those original dimensions.

Your scene is now set up for creating your models at the proper one meter scale for working painlessly between 3Coat and Blender.

Note. You also can scale that meter cube up to a working size and save that scene as a default scene for starting all your models that will be used in Blender. That way you would have a scene where you would not have to merge the cube each time and scale it up... You can keep the cube in the scene as a reference point knowing that it is one meter in size.

I have included a one meter cube, Checked it in Blender to be sure...

This method works, if you run into a problem you just missed a step. Yes a video tutorial would help, If I find the time....

EDIT: I should have said just hover your mouse cursor over the layer and then left click on the icon, correction done...

AHAAA! thank you again, digman :) wonderful!

Share this post


Link to post
Share on other sites

If you create a model first in Blender to export to your default 3DCoat Blender scene, set the export settings for the obj file down to 0.01 in the obj's export scale option.

Remember to change the scaling back to 1.0 when needed.

There is a little bit of scale difference when you import and then export that object back to Blender and I am not sure why yet unless it has to do with not being able to set the scale to "0" in Blender as you can in other programs for exporting obj files...

Share this post


Link to post
Share on other sites

Any current thoughts on maintaining scale between 3D-Coat and Blender these days? I'm using the Applink and would love to hear some current thoughts or be directed towards a tutorial.

Share this post


Link to post
Share on other sites

It is considered good practice to build your models and worlds to a real-world scale. This simplifies the import and export workflow for both Blender scenes and interoperability between Blender and other 3d packages or external game engines.

You need to set the scene unit scale in Blender to 0.01 to get correct result.

Units.jpg

Share this post


Link to post
Share on other sites

Thanks @Carlosan but that's not the issue here as we've been working in Metric Scale 1.0 in Blender for years and exporting via FBX scale 1.0 into Unreal without issue. The issue I'm having is that when I export something from Blender into 3D-Coat it comes in looking like it's displayed at a molecular scale and I have to scale it up in order to work on the object instead of being able to set a complimentary scale that appears the same between both apps.

Share this post


Link to post
Share on other sites

@Carlosan So if set Geometry / Define Measurement Units to Units / Meters before I import my object via Applink into 3D-Coat it comes in with the right scale.

What would be helpful is to figure out how to set the units to meters as my default as that's what I'll always be working in?

Share this post


Link to post
Share on other sites

I use by default this settings to avoid any scale issues exporting from Blender to another apps.

Scale.jpg

Share this post


Link to post
Share on other sites

Set your 3DC scene scale to 100 and the units to meters. This will match Blender's metric scale 1 to 1. 

A 2 meter cube in Blender will import as a 2 meter cube in 3DC and the other way around. I just did another test both regular exporting and using the applink, it is working on my end.

Create a default 3DC scene creating the settings above and whenever you are working between Blender and 3DC you have a scene file already to use. 

There are a couple of applinks out there for 3DC to Blender, I have not tested extensively. 

 

Share this post


Link to post
Share on other sites

Sorry to resurrect an old thread but i am currently trying to set my new export/import pipeline from blender to 3d coat and after reading for 2 hours i am still not sure how to proceed correctly.

I work in cm in blender since meter is too big to work on tiny objects and i want to export to 3d coat and re import in blender with same scale.

Share this post


Link to post
Share on other sites
On 1/20/2018 at 11:11 AM, Carlosan said:

I use by default this settings to avoid any scale issues exporting from Blender to another apps.

Scale.jpg

 

  • Like 1

Share this post


Link to post
Share on other sites

×