Jump to content
3DCoat Forums

Tiny, real world scale object in the Voxel Room


Recommended Posts

  • Contributor

Hello guys. I have a problem with a small, real world scale model imported into Voxel Room. First, some facts.

The model is 6x2x0.9 cm in size. It will act as:

- a volume on which I intend to sculpt several small details that I want to appear on displacement map,

- retopo mesh that I will use for displacement baking and texture painting.

I imported the object with Merge without voxelizing to keep the details and shape. Also, subdivided it four times before importing.

3D Coat is set to centimetres and measurements I performed on the object after importing it are correct.

I said "no" to:

This is the first time you have tried to merge an object into the scene. Do you want to keep the initial scale and position of the object for export later? If you click YES, 3D-Coat will preserve the dimensions of the object for export later of the voxel mesh, retopo mesh and the painted object.

because the last time I did that and scaled up the volume in the Voxel Room, the retopo mesh I imported later didn't scale up automatically to fit it. So I ended up with big volume and tiny retopo mesh meaning I was stuck. I'm not sure I understand what this option is for.


- The model is tiny when viewed in the viewport and behaviour of some tools and commands is strange.

- Navigation was hard until I reduced horizontal and vertical speeds of some events.

- Zooming in works only up to a point.

- Camera clipping occurs to early. Tweaking Near plane modulator doesn't seem to affect anything (is it implemented?).

- Text tool doesn't work properly. It squeezes fonts vertically because the distance between control points of a curve are too small.

- Converting surfaces to voxels (even after typing the value of over 3 million voxels) breaks the volume like if there wasn't enough voxels. I tried fiddling with Voxels->Define measurement units->Voxels per unit, but it looks like this setting doesn't affect the scene in any way.

Tried cranking up/down the SceneScale but that also didn't help. It's like with Near Plane Modulator - it doesn't seem to do anything.

Do you guys have any advice when working with small real scale objects?

Link to comment
Share on other sites

  • Advanced Member

Hey ajz3d, I know you tried the scene scale but this seemed to work for me. To resolve my issue I made sure that the grids matched in 3d coat and your other 3d program. I did this to give me reference to scale. To get the objects close in size relative to the grids, I had to put a scene scale in 3d coat of 100. Also, After I had imported the mesh though and changed the scale it updated in the viewport. This might give you better performance overall in 3d coat.

The quote you are questioning is saying that if you import a mesh from another program and want to go back to that other application, later in the pipline it will preserve the scale you created it at (in your other 3d program).

Link to comment
Share on other sites

  • Contributor

Thanks Ebitz.

I guess next time I'll give scene scale another try.

What I did this time is I imported the model at original scale, said "no" to the question about scale and scaled it manually ten times using numerical input. After I was done adding details, I scaled it back the same way. It's important to preserve the pivot point of the main VoxTree group so the model doesn't get translated on scaling.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...