Jump to content
3D Coat Forums
Geta-Ve

Random seams are split in Maya

Recommended Posts

Not quite sure why this is happening, but when I export my UV'd mesh from 3D Coat as obj / fbx (haven't tested other formats), there are seemingly randomly split seams in my uv's. Seams that are definitely not present before I export from 3D Coat. I have imported UV'd meshes from other applications before, ZB, Wings, Headus, etc, and have never had this problem before.

Any help would definitely be appreciated!

Thank you! :)

Share this post


Link to post
Share on other sites

There are some export options and also options in the Preferences that you can change. For example, try choosing "padding".

Share this post


Link to post
Share on other sites

Hey Timmy! Yeah, I was messing around with some of the exporting options, but as far as I could tell none of them changed the outcome. What I did find out however is that I believe the issue to be related to hard edges, either on Maya's side or when exporting from 3D Coat.

Apparently all of the broken UV's were in places where my model had been given hard edges, or the normals were borked. I fixed this by importing the model into Wings3D, softening all of the edges and then exporting back out into Maya. It is definitely not the ideal solution, but currently I have no other explanation or solution. lol

Thanks!!

Share this post


Link to post
Share on other sites

It's what I am using. ^_^

Suppose the next logical step would be to install the stable and try that out, but eh.

Upon import, you have some options (in the Import Options dialog) to keep UV or Auto UV...as well as smoothing UVs or not. Maybe selecting KEEP UV's and FULL UV SMOOTHING. It's really hard to diagnose problems like this without some kind of screen grab or screen recording. It's like asking a Lab assistant to come help....blindfolded. You can click ALT+SHIFT+S to instantly create a screen capture and upload it to 3D Coat's server. You can save it and attach it in the post or copy the URL link.

Another helpful option, especially if you are going to contact support (support@3d-coat.com), is to use JING, which is a free screen recording app and will give you the option to store the recording to their free hosting site (screencast.com). I think something is wrong with the UV's (the way they came in or they were mistakenly converted to AutoUV's. One good way to inspect and even work on the UV's is to go to the TEXTURES menu > UV Texture Editor.

You can skip to the 15:45 mark for coverage of the Texture Editor:

Share this post


Link to post
Share on other sites

If you're doing the Retopo work in the Retopo room (and not Autotopo), then you can go to the Retopo menu in the Retopo room and make sure Mirror mode is on. Assuming you're using symmetry, this can help make sure the vertices snap together.

Share this post


Link to post
Share on other sites

Hey Guys!

Thank you so much for the responses! As I said it is definitely related to hard edges / face normals, so my workaround is groovy for now. I think it was probably caused by a funny model import into 3DC. I may test a bit more later on and try to figure things out. :)

Cheers!

Share this post


Link to post
Share on other sites

Hey there! Just wanted to give another update that I am 100% sure that 3D Coat makes seams where hard edges are present on a model. I've tested this out with two cubes, one with hard edges and the other without. Is there any export option within 3D Coat to disable this functionality? Because I currently have alot of hard edges on a model and do not wish the seams to be split at said parts.

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×