Jump to content
3D Coat Forums
marggob

Проблемы с картами нормалей при открытии

Recommended Posts

Итак господа. У меня вопрос.

Почему карты нормалей полученные из 3d-coat выдают такую вот какашку в Blender. Сравнение на картинке.

UP. Попробовал засунуть модельку в Unity - там гораздо лучше, но артефакты всё равно присутствуют.

post-2369-0-25442700-1367868690_thumb.pn

Share this post


Link to post
Share on other sites

Подозреваю, что это блендер некорректно файлы кушает. Но всё таки как-то не кошерно получается.

Share this post


Link to post
Share on other sites

А что стоит в Настройках?

Стояло другое, но это ни чего не изменило. да и каналы я всё равно в фотошопе инвертировал в ручную так, как мне нужно. Проблема кажется в группах сглаживания...

Share this post


Link to post
Share on other sites

а сама текстура нормали правильно выглядит?

Естесно. Сам же видишь, что в Unity она нормально встала. И ещё. если сперва засунуть модельку в Blender, а потом уже блендеровский файл в Unity - в нём получается та же шляпа, что и в Blender.

так что всё таки дело в кривом импорте нормалей в Blender.

Share this post


Link to post
Share on other sites

У меня тоже проблема с 3dCoat + blender

Не могу победить один глюк, может кто поможет……
Модель создавалась в 3D-coat. UV развёртка и запекание normal map в нем-же. При импорте в 3D max все нормально, при импорте в другие 3D редакторы тоже (рис1). Но вот когда дела касается Blender, а в него как раз и нужно импортировать – начинаются артефакты. А именно: На текстуре normal map отчетливо просматриваются UV швы, как в 3D, так и при рендере (рис2) , хотя в других 3d редакторах этого не видно.

Пожалуйста помогите 2-ой день уже мучуюсь!

post-34686-0-79361800-1370360190_thumb.j

post-34686-0-74282400-1370360197_thumb.j

Share this post


Link to post
Share on other sites

У меня тоже проблема с 3dCoat + blender

Не могу победить один глюк, может кто поможет……

Модель создавалась в 3D-coat. UV развёртка и запекание normal map в нем-же. При импорте в 3D max все нормально, при импорте в другие 3D редакторы тоже (рис1). Но вот когда дела касается Blender, а в него как раз и нужно импортировать – начинаются артефакты. А именно: На текстуре normal map отчетливо просматриваются UV швы, как в 3D, так и при рендере (рис2) , хотя в других 3d редакторах этого не видно.

Пожалуйста помогите 2-ой день уже мучуюсь!

А что стоит в Настройках?

Attached Thumbnails
  • post-896-0-88702600-1367912829_thumb.jpg

P.S. можете сцену из Коата отослать на инспекцию на workflow@3d-coat.com, хотя думаю, что дело в инвертированном канале (должно решаться выбором экспорта нормалей для Майя, Блендер в Настройках)

Share this post


Link to post
Share on other sites

скорее всего есть разница в отображениях нормалей по какой-то из осей. Пример в синеме чтобы карта нормалей из 3D coat корректно отображалась, необходимо включить поменять направления по Y. Проверил то же на 3d max 2012, а так же mudbox 2012 проблема везде одинакова, решается тоже одинаково (единственно в мудбоксе нет отдельно для этого галки, нужно график по зеленому (RGB - XYZ соответственно) каналу поменять на зеркально противоположный) возможно проблема решается путем изменения настроек в префах, не проверял

Edited by maxtab

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×