Jump to content
3DCoat Forums
Sign in to follow this  
Bloodsong

Working Steps Same, Results Different

Recommended Posts

okay, i thought i had a methodology worked out that worked for me, but... going through the same steps is giving me different results. is it me, or is this some kind of bug i need to report?

OVERVIEW:

i'm trying to make a morph for a poser figure. problem number one for poser obj's is that they are incredibly microscopic compared to the universes of other 3d tools. problem number one for making morphs is keeping the vertex order and count of the object the same.

here are the exact steps i followed, and the anomalous results i got from them.

Version: 3D Coat V4.00.b15AGL

========================

ROUND ONE

TEST 1: No Symmetry

  1. Start in Surface Modeling Mode (i figured this would preserve the obj surface without mucking around in all those voxels)
  2. Open/Import the base OBJ file.
  3. The Transform Tool is selected when the OBJ is brought into the scene. Move the Gizmo Only to 0,0,0. Scale 200% five times. (Note: my scaling math is off during this part of the test, so of course the position and scale of the resulting morph is FUBAR, but i'll include it here for the sake of completeness.)
  4. Select the Surface Tool: Expand
  5. Click 2x on the Right Forehead (i'm using a head model base)
  6. Select Adjust: Transform Tool (note: if I select the Transform Tool I saved in my presets, it tries to change me to voxel mode)
  7. Move Gizmo Only to 0,0,0; Scale 0.25% five times. (yes, totally WAY wrong.)
  8. Export OBJ, hit Cancel on mesh density reduction.

TEST 1: Results

  1. Load Morph Target in Poser; turn on Attempt Vertex Correction.

yeah, the scaling is FUBAR, but... the important thing, the vertex order is clearly correct (I can see the shrunken, misplaced head is not exploding).

However... i don't see the lump on the forehead. ??? it just looks like the base object.

TEST 2: Mirrored

Since I know Sculptris totally FUBARs the vertex order when going into symmetry mode, i'm testing symmetrically painted morphs separately.

  1. Undo the Previous scene 5x, until the object is un-shrunken, and undo the forehead lump.
  2. Turn On Symmetry X.
  3. Use the Surface Tool: Expand 2x on the forehead. Two lumps are created.
  4. Repeat the same (incorrect) de-scaling and exporting as TEST 1.

TEST 2 Results

  1. Load the Morph Target in Poser. This time, turn OFF Attempt to Correct Vertex Order (just to test)

Results are the same... exactly the same. First, hooray! the vertices are all in the correct order and the morph doesn't explode. Secondly... uh... still no lumps on the forehead.

EXPERIMENT ONE

  1. Undo the file back to the base head that was scaled up and has lumps.
  2. Attempt the de-scaling 4x, then 1x, try to figure out where my percentage math is screwed up.

EXPERIMENT ONE Results

the 4x descaled head was still a pinhead. the 1x descaled head was too high/large (naturally), and also exploded.

NOTE: why is it now exploding, when before it was perfectly fine?

ROUND TWO

at about this time, i figured out my scaling routine is wrong. duh. yeah, so sue me, i'm not a math major. i calculated if i just scaled the object up 1000%, then i should scale it down 2.5%

TEST 2.1

  1. Start new scene, go to New Surface Scene.
  2. Import the base OBJ file.
  3. Use the Transform Tool (gizmo at 0,0,0) to Scale 1000%.

PROBLEM: why is the object not scaling up where i can see it, like it just did before? (okay, doing 200% 5x vs 1000% 1x is probably different, but... that different?

if i hit the scaling at 1000% again, then the object was large enough to see. did it ignore my first scale-up? did i put it in wrong?

i restarted 3dcoat a couple of times, because it appeared to not be working as expected.

TEST 2.2

i decided to scale up 2000% and scale down 1.25%. here are my notes on this attempt:

2000 scale doesnt do anything.
doing it again, sizes up.
hitting undo doesn't undo.
switching tool (pose) asks to merge;
saying no just blanks out the scene... ARGH.

(okay, stupid newbie mistake: always say yes to merge)

okay 2000% not really doing 200% x 10, but i can see it if i zoom in a lot. onward.

merge yes works. camera can zoom-all and rotate bounding box.

  1. Turn on Symmetry X.
  2. Surface Tool: Expand 2x on forehead.
  3. Resize (Gizmo @ 0,0,0) 1.25%
  4. Export OBJ, Cancel on reduction.

TEST 2.1 Result:

PROBLEM: target geometry has wrong number of vertices.

38,246 vertices instead of
38,290

it has

112,857 polygons instead of
38,354

and it is all triangulated! (which the original OBJ is not.)

NOTE: i have not changed my import/export/sculpting/scaling methodology. why am i now getting wrong number of vertices results?

i checked the original exported mirror test obj. it, too was triangulated, and it, too, had almost twice as many polygons as the original OBJ file, but... it had the correct number of vertices in the correct order.

PROBLEM: when i imported the obj into poser, the head was not the right size/position as expected (could be my scaling math. i used to have a program that did poser obj scaling and de-scaling, but i no longer have that.) however, i DID see the knobs on the forehead, unlike previously.

TOO LONG; DIDN'T READ:

importing and exporting an object for a morph resulted in a morph that worked, except the sculpting that was done on it did not appear.

exporting the same object again resulted in a morph that exploded.

importing and exporting an object again, in a new file, using the same methodology as before, resulted in a morph that didn't work because of wrong number of vertices. but did have the sculpting appear on it.

bloodsong needs help scaling an object up to work on it, and then back down so it is in its original size/space (it is not centered in the universe) for export.

what, exactly, of my system specs do you need and where can i get a dump of them for you?

thank you for your extreme patience.

Share this post


Link to post
Share on other sites

You don't want to export objects from the Voxel room for morph targets....period. If you have a low poly model to start with Import that into the Retopo Room > hit ENTER to commit it to a Retopo layer > go to Voxel Room > Merge tool or FILE menu > Merge object > in TOOL OPTIONS panel, select pick from Retopo Room. Now you have both a high res version and a low res version to bake all your details down to.

If you want to use the Voxel tools to create Morph target that will be applied to your low poly version, make sure to check "Conform Retopo Mesh" at the top of the UI, when either the MOVE, POSE, or TRANSFORM tool is active. 3D Coat will conform/shape the low poly along with the high poly. It's a killer feature when you need it.

Share this post


Link to post
Share on other sites

The name has recently changed from "Update Retopo Mesh" to "Conform Retopo Mesh"...so it's easier for new users to intuitively know what the option does.

Edited by AbnRanger

Share this post


Link to post
Share on other sites

all righty!

that methodology also fixed my scaling problem!

unfortunately, i really want to use the surface sculpting tools to create morphs. i did manage to export the retopo-to-voxels object from the voxel room with proper scaling and right number of vertices. just... in the wrong order. which is hopeful.

but that's another topic for another time.

thanks a bunch!! i still have a lot to learn!

Share this post


Link to post
Share on other sites

When sculpting, the changes are usually light enough that you could easily re-snap the whole mesh to conform to those changes, or use the Brush tool (hold the SHIFT key to smooth) and as you move an area, it snaps only what is under your brush. The reason Conform Retopo Mesh only works with those three tools is because they are used to make large scale edits. With brush strokes it's not really required to have that enabled, and it would only slow the brush speed down.

Nevertheless, that might be a good example of why the basic Surface mode brushes should be mirrored over to the Tweak Room....for better/easier Morph target work. Sign up to Mantis and place a feature request there

www.3d-coat.com/mantis

...maybe Andrew can get to it in the V4 cycle. I think it would be a good idea, even if one can make it work with the tools that are already in the app. The Sculpting tools between the Tweak Room and the Paint Room are plenty sufficient for Morph target creation. Some of use have asked for similar functionality, but Andrew decided it was better to focus all the sculpting development in the Voxel Room.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×