Jump to content
3D Coat Forums
Sign in to follow this  
alvordr

UV Seams Showing Up In UDK

Recommended Posts

Hello, all. I created this bread yesterday and put it into the UDK. It looks fine in most applications, and even in UDK's Static Mesh preview, it looks fine (see image 1). However, when I put it in a scene, I can see where the UV seams are on the model (see image 2). I exported with Smoothing Groups on from 3ds Max to try to fix this, but no use. Anyone have any ideas on why this is happening and/or how to fix it?

BreadUDKPreview.jpg

BreadUVSeams.jpg

Share this post


Link to post
Share on other sites

Did you try to invert the green channel of your normal map texture?

The normal map is differently handled from engines to engines.

Nice breads!

Share this post


Link to post
Share on other sites

Another thing to look at is your normal export settings under the Preferences menu. It is just a suggestion as you had not stated you tried that already...

That is great looking low polygon bread, nice job...

post-518-0-57746100-1372084462_thumb.png

Share this post


Link to post
Share on other sites

@Garagarape

A good thought and I tried it, but no luck.

@Digman

I didn't bake out the materials, so perhaps I should try that instead of the standard export.

Share this post


Link to post
Share on other sites

Nope, the trick to fixing this was:

...a setting I never bothered to mess with before, as I didn't realize what it did. If you select your material in the browser, double click, properties, and uncheck the "Allow Lightmap Specular" option, this fixes the odd angular problems I saw in the mesh. However, I lost the specularity, altogether, until I used a dynamic light. This uses more instructions for the dynamic lighting, but I believe saves on the lightmap specular instructions. I can't say anything of the "behind the scenes" benefits, but it definitely looks better.

Now it looks like this:

BreadUDKFixed.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×