Jump to content
3DCoat Forums

3DCoat Wishlist


Carlosan
 Share

Recommended Posts

  • 1 month later...
  • Advanced Member

Time to vent a little bit... I have been fighting with 3d coat painting for awhile now, specifically how 3D Coat works with my tablet and pressure. I am getting to the point where I just want to stop using it altogether. Its inconsistent, sometimes the full pressure effect even though im putting little to no pressure at all, this makes blending a nightmare (hand painted textures), other times the quality of the strokes are just not very good (or sharp). I dont know if its also due to 8 bit imagery from 3d coat but the lack of smooth value blending also becomes very noticeable. So what I am forced to do is go back and forth to Krita (via external editor feature) and paint there (where the strokes, values, blending, its all consistent and accurate). I dont want to have to do this... so I guess you can say the resolved feature I am requesting is... really polish up and fine tune the texture painting. Something is just off about it which is really ruining the quality of my hand painted textures.

(just to add, I have a dual set up with a cintiq and an intuos. Due two a beefy machine I can go up pretty high with the texture resolution, UVs are not tiny). Outside of 2d editors behaving properly/consistently, Mari Indie has also given good results. This is definitely something with 3d coat.)

Link to comment
Share on other sites

  • Contributor

Time to vent a little bit... I have been fighting with 3d coat painting for awhile now, specifically how 3D Coat works with my tablet and pressure. I am getting to the point where I just want to stop using it altogether. Its inconsistent, sometimes the full pressure effect even though im putting little to no pressure at all, this makes blending a nightmare (hand painted textures), other times the quality of the strokes are just not very good (or sharp). I dont know if its also due to 8 bit imagery from 3d coat but the lack of smooth value blending also becomes very noticeable. So what I am forced to do is go back and forth to Krita (via external editor feature) and paint there (where the strokes, values, blending, its all consistent and accurate). I dont want to have to do this... so I guess you can say the resolved feature I am requesting is... really polish up and fine tune the texture painting. Something is just off about it which is really ruining the quality of my hand painted textures.

(just to add, I have a dual set up with a cintiq and an intuos. Due two a beefy machine I can go up pretty high with the texture resolution, UVs are not tiny). Outside of 2d editors behaving properly/consistently, Mari Indie has also given good results. This is definitely something with 3d coat.)

Are you by any chance experiencing the problem I described here: http://3d-coat.com/forum/index.php?showtopic=18337 ?

Edited by ajz3d
Link to comment
Share on other sites

  • Advanced Member

Are you by any chance experiencing the problem I described here: http://3d-coat.com/forum/index.php?showtopic=18337 ?

 

Yep, thats the latest issue to plague me with 3D Coat. Always having to restart 3D Coat. Reinstalled intuos drivers. Even before this new issue the quality of the strokes felt a bit inconsistent, just not so extreme as with now.

Link to comment
Share on other sites

  • Advanced Member

Then the only advice I can give is to keep looking for a driver that works for you. For me it was 6.3.11w3 and my problems stopped after installing it. The driver that will work for you might be different though. :(

 Thanks, I'll try rolling that far back... or hold off for a 3dc update and just use Mari for now. Just too many problems with 3DC in general, really makes it hard to enjoy using the software.

Link to comment
Share on other sites

Feature wise, everyone already knows that I really want changes to the paint room. Layer groups, transferable layer masks, and the removal of the 'feature' that deletes and makes it impossible to have paint outside UV shell borders, all being at the top of that list.

 

So it's been two years since I last commented in this topic, and things really haven't changed that much it seems. We got layer groups, but the other two things I mentioned still haven't been addressed :(

 

I've actually been using ye olde BodyPaint3D again just so get access to PS compatible layer masks (I also like having layer thumbnails and optional true projection painting directly in the viewport). It's fine for hand painted textures, even if it took me several days to get around all the bugs.

 

Layer groups and PBR getting added were cool, but past that I'm feeling rather disappointed in 3DC's development after all this time.

Edited by PolyHertz
Link to comment
Share on other sites

  • Member

Trackball rotation a la Modo. Once you get used to it, there is no way back. Also, the smart material preview tends to reopen too much often. It can be frustrating to be closing it every time it's pop up. A fill by connected  and some basic loop selection for masking would be very welcome.

  • Like 2
Link to comment
Share on other sites

  • 3 months later...
  • 3 months later...
  • Member

Referenced fbx import. Sometimes, having this will make things  so much easier. Example,
Exporting an "exploded morphed" mesh,
bake,
export unmorphed.
Done
The good thing about this, would be having several fbx. Marmoset, Max, Modo have this so i thing this may help to have a cleaner pipeline.

Link to comment
Share on other sites

  • 2 months later...
  • 3 months later...
  • Advanced Member

I am really missing Smooth Shade view with the wireframe on top in Sculpt room. I need to see shade view and wireframe together when I work on model with textures. The color of the wireframe needs to be adjustable.

Link to comment
Share on other sites

  • Member

There is this very annoying but somewhat specific problem I get from time to time.

When I finish retopologizing a symmetric model with symmetric UVs, and when later I move it into the paint room and select triangulate, the triangulation WON'T be symmetric. This will mess up completely the bake later (I bake in Marmoset). I hope that could be fixed, since also, shape wise, in lowpoly characters a flipped differently triangle can make the model obviously less symmetric.

  • Thanks 1
Link to comment
Share on other sites

  • 2 weeks later...
  • Member

I've got a display issue on UV seams in paint room (parasite  pixels that i can't rid of ) 
And this bug wasn't in 3dc 4.5

The texture was baked in Zbrush, touched up in 3d coat 2021 ( i wasn't able to get rid of white pixels )
And, when i load the model in 3d coat 4.5, white pixels are gone
image.thumb.png.af7c01722e2d7d1574f863481aad11bc.png

Edited by Frimasson
  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
  • Advanced Member

I  still hope to separate material from UV set .

At current I make some cloghings mat.. each clothings have 5 or 6 sections as different material group (or shader group or mat slot, call as you like)

but all material are gathered as one UV unit. (no over wrapping), about this case. I need to decide work flow A or B

A simply gather as one UV set, so it remove all material group = I really hastle again to make section for each material in 3d coat (but in original app, they have material group)

B use material group as UV set, it means, each mesh will generate 5 or 6 UV sets then 3d coat generate all textures for each UV set. as different name. (get huge data)

So we need type C

3d coat use material group as material section, but it keep to use same UV of original mesh. so one UV set may contain 2 or 3 or 5 material as group.

 

Link to comment
Share on other sites

  • Advanced Member
1 hour ago, milhouzz said:

please fix the extrude/build,..... in voxels mode :) really wish this will be working again soon as it s such a basic function 

thanks guys

Can you describe? To me voxel work fine but in surface extrude partly working with alphas

Edited by sprayer
Link to comment
Share on other sites

  • Member
1 hour ago, sprayer said:

Can you describe? To me voxel work fine but in surface extrude partly working with alphas

my problem is extrude,build and any tool in the same "category", i cannot extrude using either lasso, rectangle or any of the selection tools, doesn't seem to work.

I also don t see the direction menu when i want to extrude at the top

Link to comment
Share on other sites

  • Advanced Member
7 minutes ago, milhouzz said:

my problem is extrude,build and any tool in the same "category", i cannot extrude using either lasso, rectangle or any of the selection tools, doesn't seem to work.

I also don t see the direction menu when i want to extrude at the top

Please report about that here.

And you may report other bugs, Andrew now focused on bug fixing.

build tool work with lasso by the way

Link to comment
Share on other sites

  • Member
30 minutes ago, sprayer said:

Please report about that here.

And you may report other bugs, Andrew now focused on bug fixing.

build tool work with lasso by the way

reported it here thanks.

really odd i tried latest update from yesterday and none of those tools work with the lasso...hope this will be fixed soon!

  • Thanks 2
Link to comment
Share on other sites

  • Carlosan changed the title to 3DCoat Wishlist
  • Carlosan unpinned this topic
  • Carlosan pinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...