Blender Applink "Simple3DCoat" (Fork of the official)


mifth
 Share

Recommended Posts

Hi all,

Simple3DCoat addon is for Blender+3DCoat production. This is a fork of the official one made by Haikaikalle .

Blender 2.93+

3DCoat4+

 

Features:

  • Set the Exchange Folder of 3DCoat manually.
  • Custom Textures Path for export/import.
  • Export/Import through Obj/Fbx formats.
  • ExportMaterials, ApplyModifiers checkboxes.
  • No PBR Materials support. Sorry.
  • Simple to Use :)

 

Screenshots:

1R2ihSA.png

 

image.thumb.png.55c043169fe19f63a4cf2052d9b98b9d.png

image.thumb.png.4bbaa65b08d4c7d04f0dc548e367b261.png

 

image.thumb.png.955a4097c633a63d4a1f6c264e4187fd.png

image.thumb.png.633d32deb7fcc91269ff3940bbdbdaba.png

 

How To Use:

- Enable the Addon and set the Exchange Folder.

- Export/Import models back and forth. :)

 

Download:

Sources: https://github.com/mifth/mifthtools/tree/master/blender/addons/2.8/io_simple_3dcoat

Latest MifthTools Master Download (ZIP): https://github.com/mifth/mifthtools/archive/master.zip

 

Enjoy.

  • Like 1
  • Thanks 2
Link to comment
Share on other sites

  • 2 weeks later...
  • Member

Is there a way to get this to work?

I've tried both the default add-on, and this one, on both Windows 7 and Mac, and neither one of them do what I thought it would do.

It does export the model to the directory I selected, but it does NOT launch 3d-coat.

Am I missing some sort of setting that needs to be changed in 3d-coat itself?

Link to comment
Share on other sites

Is there a way to get this to work?

I've tried both the default add-on, and this one, on both Windows 7 and Mac, and neither one of them do what I thought it would do.

It does export the model to the directory I selected, but it does NOT launch 3d-coat.

Am I missing some sort of setting that needs to be changed in 3d-coat itself?

 

As @carlosan said you need to open 3DCoat.

And Exchange directory should be set correctly. In Windows it should be "Documents/3DCoatV4/Exchange". And you should save Exchange directory with Ctrl+U. I'll make a video tutorial soon.

Edited by mifth
Link to comment
Share on other sites

  • Member

Well, I sort of got it working.

I found that the choice I was making, voxel primitive, didn't seem to work, no matter whether 3D-coat was opened, closed, whatever, even though all I had open in blender was the default cube.

It will export the .obj, but nothing shows up in 3D-Coat if you make that choice.

If I choose pixel painting, it works well though.

Do I have to clear the model out of the folder to export another model?

 

I also couldn't seem to get it to work completely with other voxel settings, and the scaling of the object in 3D-Coat seems to vary with what choice you make for export, which seemed weird, should be the same .obj I would think.

Link to comment
Share on other sites

On 12/18/2013 at 3:19 AM, Redbeer said:

Well, I sort of got it working.

I found that the choice I was making, voxel primitive, didn't seem to work, no matter whether 3D-coat was opened, closed, whatever, even though all I had open in blender was the default cube.

It will export the .obj, but nothing shows up in 3D-Coat if you make that choice.

If I choose pixel painting, it works well though.

Do I have to clear the model out of the folder to export another model?

 

I also couldn't seem to get it to work completely with other voxel settings, and the scaling of the object in 3D-Coat seems to vary with what choice you make for export, which seemed weird, should be the same .obj I would think.

 

Possibly this will help you:

H0kmeBk.png

 

WWpi52I.png

  • Like 1
Link to comment
Share on other sites

  • 2 months later...

This was working for me in Blender 2.69 but here on the eve of 2.70 (2.69.11 is precisely my build) - Simple is no longer working for me, but the original applink does still. I'm on Windows 8 64bit using 3D Coat 4.0.16

 

I have 2.69.11 Linux build. All works ok. Do you get any error when press "ExportObjects"?

- Make sure you set Exchange folder in the addon settings.

- Try to get latest sources from here https://code.google.com/p/blender-addons-by-mifth/source/browse/#hg%2Fio_simple_3dcoat

Link to comment
Share on other sites

  • 1 month later...
  • 4 months later...
  • 5 months later...
  • 2 months later...
  • New Member

All I'm getting is "No selected objects or bad excange folder!!!" Exchange folder is set and I tried removing every UV-map, material, texture, vertex group and armature and still the same message. 

 

If I start a new project and export the 'default-cube' it works OK.

Link to comment
Share on other sites

  • 1 month later...
On 6/14/2015 at 4:10 AM, Randy said:

The add-on installs ok for me. I change the exchange address, but the drop-down doesn't appear unders SCENE. If I uncheck "Simple" and check "3d-Coat Applink" it shows up. Blender 2.74 / Both Mac & Win8.1 

 

I moved it into 3dViewport T Panel.

 GKj008U.png

Link to comment
Share on other sites

  • Member

I am having a problem where if I export an object from Blender to 3D-Coat using Simple3DCoat Applink and the Mesh As Voxel export type, then when it imports it comes in with the last imported object's transform, rotation and scale.

Here is a video explanation of the problem that I am having.

 

Why is this happening? Where is the info being stored that tells 3D-Coat to import with the last used transform, scale or rotation and more importantly, how do I clear that data so that I can start fresh?

 

Thanks for your help,

Bryson

Link to comment
Share on other sites

  • 3 weeks later...

I am having a problem where if I export an object from Blender to 3D-Coat using Simple3DCoat Applink and the Mesh As Voxel export type, then when it imports it comes in with the last imported object's transform, rotation and scale.

Here is a video explanation of the problem that I am having.

 

Why is this happening? Where is the info being stored that tells 3D-Coat to import with the last used transform, scale or rotation and more importantly, how do I clear that data so that I can start fresh?

 

Thanks for your help,

Bryson

 

 

Dunno know. Try to press ResetOrigin in 3dc when you import the model. Or download latest version of 3dc.

 

Here is my test:

Link to comment
Share on other sites

  • 2 weeks later...
  • Advanced Member

Yes its there but shorter as in just Export type (DROPDOWN) list and 2 buttons Update and Transfer. All the rest that use to be there is gone as in / apply modifiers,texture path,export type, im thinking I need to set the exchange folder to 4.5.03a ? IN 3DCOAT there use to be a option when the app-link was set in the drop down list under file I think to send it over. As long as I know the app-link works with these 2 versions I will keep at it. Thanks for your time Carlosan 

Link to comment
Share on other sites

  • Carlosan changed the title to Blender Applink "Simple3DCoat" (Fork of the official)

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share