Jump to content
3DCoat Forums
Tim007

Voxel sculpting is very slooow -v 4.1-

Recommended Posts

Hi,

 

I wanna try 3D Coat, because my friend tell me its really great! So I install trial and seems cool, but I have one big problem:

 

I put a predefined medium sphere to the viewport, made it 4 times higher res and try to sculpt in voxel mode. It was sooo slooow, I think like 1 frame per sec. Its really terrible. Even when go to a higher level, it stop for like 5 seconds. I dont know why, I have pretty decent computer (i7 2600K at 4,4GHz, 32GB RAM 2133MHz, GeForce GTX 780 3GB, win 7 x64). ZBrush is super fast, but I hate it :-) and wanna try 3D Coat. But I dont know why, its really slow. My friend tell me he can do that without any problem. Sphere with 4 times higher resolution, its still not so detailed and 3d coat told me use only 1.26GB RAM, so its simple I think. Any other software works fine, so I dont know what to do. Can anyone help me please...

 

Thanks a lot for any tips.

 

Tim

 

Share this post


Link to post
Share on other sites

voxel mode = dynamesh equivalent

 

dont surpass 1M by layer.

Use it for fast block / boolean modeling

 

for fine detail... use surface mode

 

at end for high details sculpts... use Live clay mode

Share this post


Link to post
Share on other sites

Ok, but how is possible that my friend, who told me about 3D Coat, try same thing - sphere 4 times subdivided, and has everything fast. Or am I missing something?

Share this post


Link to post
Share on other sites

will you please test the version DX no CUDA

3d-CoatDX64S.exe

 

... are you testing the v4.01 or 4.14 beta ?

Share this post


Link to post
Share on other sites

4.1.04A downloaded from homepage here.

 

Now I test polygonal sculpting, make a sphere with 10M polys and live clay mode is slow to, when I paint on a whole object. But when sculpt with textuer, it still doesnt have detail. And when go higher, I think subdiv never end, still thinking. Its realy weird.

 

Iam testing noCUDA version now, its same.

 

When I go with sphere from one milion polys to 15 milion polys, it stop for maybe 10 seconds. Is this normal? And it has every time some weird triangulation after subdivision, not a smooth surface.

 

And still take it about 2 - 4 GB of ram.

Share this post


Link to post
Share on other sites

10M 15M  a base mesh model ?

 

is high to begin

 

dont think 3DC as a ZB clone, it isnt

 

hope this help

Share this post


Link to post
Share on other sites

It should work fine, especially with an Intel i7, as the brush engine is highly optimized using Intel's TBB (Thread Builing Blocks) library, and then if you use the CUDA version it should work. Try working with the default Human object from the splash screen. Nevertheless, why would you possibly need 15mill on a sphere? Even in Mudbox, and ZBrush, you don't just jack up the resolution a crazy amount from the start. You start at lower resolutions and build up your rough forms. When you are sculpting on a 15mill+ poly object, you are typically sculpting much smaller details.

 

Plus, it's hard as Hades for us to tell what's really going on in the scene, without so much as a screengrab (ALT + SHIFT + S) or screen recording to go by. You wouldn't ask a college instructor or lab assistant to come help with an issue on a project in college , without their being able to look at the screen and see what is going on. It is much the same, here. You're asking us to diagnose the problem blindfolded. My guess is the scale is way too big. When you are in voxel mode, scale matters. The bigger the object is in scale the bigger the resolution it has.

 

Also, much of the development emphasis the past 3-5yrs has been in Surface mode, for pure sculpting purposes. As Carlos said, Voxels have their place to do boolean type operations and building up rough forms, and you can sculpt fairly well up to the high res stages, but it's not designed for uber-high detail. Surface mode is the best platform for most sculpting tasks in 3D Coat, now. 

Share this post


Link to post
Share on other sites

Yes, but if simple sphere is so slow, how I can make something difficulty.

I try to make a video and post it here, no problem. I think someone who uses 3D Coat for a long time will know if its normal or its slow from what I said. But I make a video and will see.

Share this post


Link to post
Share on other sites

Yes, but if simple sphere is so slow, how I can make something difficulty.

I try to make a video and post it here, no problem. I think someone who uses 3D Coat for a long time will know if its normal or its slow from what I said. But I make a video and will see.

Use....Surface.....Mode.

Share this post


Link to post
Share on other sites

Here is a video, so please tell me if its normal or not. Or what Iam doing wrong. But its super slow on that computer, so I think its not normal. And two things: first, even after subdivisions takes low ram I thing, dont know why, I have 32 GB RAM. And second, after subdivision, you can see some triangulation on a sphere, dont know why, dont look ok to me either. Thanks for any tips.

 

https://www.dropbox.com/s/lcs1ekd8nwlalp6/3DCoat.mp4?dl=0

 

Video is in fullHD, so please download it, dont play it from dropbox because its terrible.

Edited by Tim007

Share this post


Link to post
Share on other sites

Again....you jacked the resolution way too high. There is no need to do this. You block out your base forms and add resolution as you go. You can toggle wireframe on by hitting the W key, and see that it's just a ridiculously high res level

Share this post


Link to post
Share on other sites

You keep ignoring the fact that we are telling you that VOXEL MODE IS NOT DESIGNED FOR UBER HIGH DETAIL WORK. Use Surface mode if you have to go that high.


140960233426.jpg

Share this post


Link to post
Share on other sites

Do you see video to the end? Iam using surface mode after voxel mode. Play 5:12. I think this is surface mode and as you can see, its so slow I barelly can draw. You have it super fast with same amount of polys. Or cant you see the difference?

Edited by Tim007

Share this post


Link to post
Share on other sites

After doing the same thing you did, it was pretty fast on my end, when using the build brush, but I did notice that it's slower when using the Absolute draw mode (5th from the left in the E-Panel). I tried for a long time to get Andrew to recompile the CUDA code for 3D Coat, to CUDA 5-6, but he doesn't believe it's worth all the time spent having to do so, when the focus has long been in Surface mode. Even the 15mill polys, it was slow only with a particular brush mode, and all the others were pretty decent.

Share this post


Link to post
Share on other sites

Do you see video to the end? Iam using surface mode after voxel mode. Play 5:12. I think this is surface mode and as you can see, its so slow I barelly can draw. You have it super fast with same amount of polys. Or you cant see the difference?

Yeah.....you cranked up the brush size to a ridiculous size, on a uber-high res model. It's ridiculously fast in most of my experiences, when used the right way. Even in Mudbox and ZBrush, your don't use those large of a brush size on a model that dense.

Share this post


Link to post
Share on other sites

I just showed you on a 15mill poly model, that even in Voxel mode, it works pretty well. Maybe you can send the video to support@3d-coat.com and ask Andrew why it's so...slow, using uber large brush radius on uber dense models. Some brushes are faster than others. The reason why Voxels aren't crazy fast is because the app has to calculate the volume changes and remesh the object on the fly. I guarantee you, that you can't do in ZBrush with Dynamesh what you are trying to do in 3D Coat

Share this post


Link to post
Share on other sites

Ok, I believe, that voxel is not super fast, but I think it hasnt to be so slow. And in video, you can see on 5:12, that is slow in surface mode. I know, brush is large, but hey, that sloooow?

 

I notice one more thing its just looks really weird to me, maybe this is why its so slow. Look at short video, how model looks after subdivision:

 

https://www.dropbox.com/s/h6tp9iw0yacq6u3/subdivision.mp4?dl=0

 

Is this normal, looks like mess it up.

 

Share this post


Link to post
Share on other sites

You need to learn the tools BEFORE you try to test its limits. You are not using them the right way, and you can't assume that everything you do in an app should be instantaneous and lightning fast. That is not the case in ZBrush or Mudbox, either. If you try to crank up the SubD levels to ridiculous levels and use crazy large brush sizes they will slow/bog down as well, if not crash.

 

You were, at one point, trying to show that 3D Coat was slow, by using a LiveClay brush (which has to calculate dynamic subdivision and sculpt simultaneously) You cannot just haphazardly use them on an uber dense model and expect lightning fast results. Like Voxels, there is a dual calculation taking place with each stroke. If you have "REMOVE STRETCHING" turned on, that is 3 separate calculations the app has to make with each stroke. With a regular Surface mode brush, there is less to calculate and that's why they are insanely fast.

 

Again, learn the tools first, before you try and push it's limits. ZBrush and Mudbox are the same way in this regard.

Share this post


Link to post
Share on other sites

Ok, I believe, that voxel is not super fast, but I think it hasnt to be so slow. And in video, you can see on 5:12, that is slow in surface mode. I know, brush is large, but hey, that sloooow?

 

I notice one more thing its just looks really weird to me, maybe this is why its so slow. Look at short video, how model looks after subdivision:

 

https://www.dropbox.com/s/h6tp9iw0yacq6u3/subdivision.mp4?dl=0

 

Is this normal, looks like mess it up.

 

You notice how with one brush it's crazy fast and another, it is slow. Doesn't that tell you that you must not be doing something right?

Share this post


Link to post
Share on other sites

Because you are not using them right. You don't even know what it is you were using. That's why LiceClay brushes are separated into their own section of the tool bar. I'm not going to waste anymore of my time. I've already wasted more than necessary to make my point, with video demonstrations showing that it is NOT slow...when used correctly.

Share this post


Link to post
Share on other sites

OK, maybe, I try something and my friend try that too and tell me, that its ok on his computer, this is why Iam asking.

 

And yes, I have to look on some videos, you are right. :-) I just want to know if everything is ok.

 

But please did you look on a second video? Isnt it weird how it subdivide a mesh?

Share this post


Link to post
Share on other sites

3dcoat is not a subdiv program.

You don't need to subdiv level by level. Voxels are adaptive you're not limited to a cage, you deform as you go, so take your time make the most of your resolution before going higher.

Surface mode can start very low poly, in fact it's better to NOT import voxel high res in surface mode as surface mode allow you to add details where you need them and all the extra uncessary poly in "simple" areas are a waste of ressources.

If you want to import voxel into surface mode like Carlosan: medium res is high enough, you don't even need to tap into 1Million polycount to do that.

 

In your video what you see is voxel resampling transfered to surface mode,it's normal you don't NEED to do that to get higher res, and if you're worried about poly repartition,go to voxel>Clean surface, but the poly repartition is not a problem as you'll discover by brushing the surface with liveclay tools or surface tools+ remove stretching option

Share this post


Link to post
Share on other sites

OK, maybe, I try something and my friend try that too and tell me, that its ok on his computer, this is why Iam asking.

 

And yes, I have to look on some videos, you are right. :-) I just want to know if everything is ok.

 

But please did you look on a second video? Isnt it weird how it subdivide a mesh?

Sorry for getting a little flustered there. I was doing what I could to help and it seemed for naught. The only thing you need to be concerned about when you toggle wireframe on, is if it seems too dense for what you are trying to do. You can ask any experienced ZBrush or Mudbox artist and they will tell you likewise....that you need to keep your subD levels low starting out, and only when you feel like you don't have enough resolution to do what you want, do you increase it accordingly. You can't just dive into an app like this, ZB and MB, and start pushing it's boundaries, to see where it will break. You need to have a general grasp of the tools you are using, first. Some may require a little tweaking of the settings to get the behavior you want. And LiveClay brush dynamically subdivide or reduce, so you have to be a little careful using them. There is a very good section on it in the Manual, that explains it very well.

Share this post


Link to post
Share on other sites

Since this video was recorded, when you switch between Voxel Mode to Surface Mode, 3D Coat will automatically optimize the mesh for Surface mode sculpting, but in the case you mentioned, I guess during the resampling, it voxelizes it temporarily. Maybe Andrew can automate the resample tool to optimize the mesh a bit, at the end of the process. In the mean time, as Beat mentioned, you can choose "Clean Surface" from the Voxel menu, after a resample, or the SMOOTH ALL tool (Tangent smooth will optimize the whole mesh while preserving the shape of the mesh).

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×