Jump to content
3DCoat Forums

[SOLVED] Can't access some Sculpt Room Surface tools

Recommended Posts

  • Member

In the Sculpt Room => Surface Mode I can't access some tools from the Tool Palette whose section headers are collapsed and can not be expanded.

There was a discussion on one of the forums started by Carlosan about the Left Tool Panel using tabs and I suggested:

You can already collapse/expand tools under a tool heading section by clicking the triangle to the left of the heading. Perhaps right clicking the triangle would expand the current section of tools, but collapse all the other sections?

which I still think is a good idea.

I later went back to Voxel mode with some of these Surface Section Headers (LC and Objects) still collapsed. I exited 3D-Coat several times, and it also crashed a couple of times while doing some internal rendering for output. That was yesterday. Today when I returned to Surface mode of the Sculpt Room these sections are still collapsed and will no longer expand. The little triangle to the left of the Section Header changes from pointing down to pointing to the right when I click on them, and the other section collapse and expand as normal, but it will not expand the LC and Objects sections. In addition, bringing up the Quick Access Tools with the Space bar shows all the tool sections that are expanded but only shows the Headers and not the tools of the LC and Objects Sections that are collapsed, so I can't access these tools that way.

So far I tried un-installing and re-installing with no success. I also looked through some of the XML files and the system registry to see if something jumped out at me, but nothing obvious did, although I suspect the problem is in an XML configuration file.

This is in Version: 4.1.17 all editions, and it also happens with the stable release.

Thanks for your help with this...

Link to comment
Share on other sites

After uninstalling, delete all of the directories for 3DC in My Docs. Reboot, then reinstall 4.1.17 and try it vanilla (without any of your custom presets, layouts, etc.). That should work, though this is the first time I've ever heard of this happening, so it could be something else entirely.


Make sure backup any of your settings, tools and so on that you want to keep before doing so.

Link to comment
Share on other sites

Hi Robert! I'm really glad that worked out, at least we know a temporary fix for the issue. I think it would probably be best to keep the report open so Andrew can at least take a look at it. Hopefully it can be prevented from happening in the future.

Link to comment
Share on other sites

  • Member

Just a follow up. I shut down 3DC, renamed "...\Documents\3D-CoatV4" and restarted 3DC without rebooting or reinstalling. This obviously created a backup of my configuration. Restarting 3DC re-created the necessary default "Documents" directories/files, and fixed the problem.


I then slowing restored most (not all) of the old/backup "Documents" content, testing in-between to see if I could find the culprit, and I couldn't.


Since this process recovered the use of my sculpt tools, I no longer worried about loosing the use additional tools. I tried collapsing some of the tool section headers and exiting 3DC, to see if this would re-create the problem. It didn't.


So perhaps it was some of the render crashes that caused the original problem, not exiting with the tool section headers collapsed as I originally assumed.

Edited by RobertH
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...