Jump to content
3DCoat Forums
Sign in to follow this  
elindell

custom Mask jagged normals in paint room

Recommended Posts

Hello, I working on figuring out a good workflow to create tileable normal maps for use in unreal engine. In 3d coat I'm in the paint room trying to use 2d images that I create as masks to paint on normal depth. When I try it I seem to get some sort of banding in the depth. It's hard to explain so hopefully these sample give an idea. Is there some setting I'm missing or a specific file format to import that would smooth these out? 

 

I can't upload the original mask I used since its over 10meg but here's one at half res to show what I was working from. The mask I used was 2k and the UV map I was painting on was also 2k. The mask I created was uploaded from a png file.  Any ideas? 

 

Thanks

 

 

post-38575-0-58984400-1412711227_thumb.j

post-38575-0-22768100-1412711237_thumb.j

post-38575-0-91638800-1412711244_thumb.p

Share this post


Link to post
Share on other sites

Hello

 

paint room

Shift+M

post-10142-0-11413500-1412711675_thumb.j

 

select TILE

post-10142-0-02934800-1412711687_thumb.j

Share this post


Link to post
Share on other sites

Thanks for responding carlosan, unfortunately that doesn't really address my issue, I'm having quality issues with the depth layer created in the paint room when using a custom mask. Please look at the pictures I posted, instead of a smooth rise I'm getting those steps. 

Share this post


Link to post
Share on other sites

sorry misunderstood

 

i tested you file in 3DC and another software... all give me bad results

post-10142-0-48116700-1412733122_thumb.j

 

will you please test with another image ?

 

ty

Share this post


Link to post
Share on other sites

Thanks for testing, I've tried numerous texture, anything with a soft gradient result in a pretty noisy depth, even one of the default mask (mask sample 1 and 3 here)

I tried to use 16 bit mask but those don't work at all in 3d coat. 

I will keep testing and if I find a solution will post, maybe there's a setting that increases sampling of masks somewhere? 

 

post-38575-0-98924100-1412789457_thumb.j

post-38575-0-12369600-1412789459_thumb.j

post-38575-0-96037900-1412789459_thumb.j

post-38575-0-47887200-1412789553_thumb.p

Share this post


Link to post
Share on other sites

The grey scale have 256 colors

 

if i change the mode to Indexed -external paint app-, the jagged shapespost-10142-0-49428200-1412791311_thumb.j are more noticeable

 

------------------------------------------

I found this info

 

I had this problem recently. When you use masks you need ridiculously high polycounts to get smooth edges when you inflate the details. There are 2 things you could try....

1. Mask with the intensity like you were doing but use the size slider instead of inflate. Then use pinch and smooth to sort out any jaggies. This takes while and you're never going to get perfect edges

2. Something that worked quite well for me was creating an alpha from the design (just turning it onto a black and white image) 
Hope thats a help

Share this post


Link to post
Share on other sites
Sign in to follow this  

×