Jump to content
3DCoat Forums
Andrew Shpagin

V4.5 BETA (experimental)

Recommended Posts

I will look in the manual .....i just want the simple pic- mat grey that was there before, and maybe the clay coloured one also.

What do you mean by existing copy? Do you mean fiddle about with one of the new shaders...

Sorry , Im just a basic user that is rapidly losing interest in all this 3d suff.and  hasnt used 3d coat for 4 months. Those fancy shaders do nothing for me.

Exactly. Just use right click on the default shader, make a copy and change your options like color etc. It is really easy.

Share this post


Link to post
Share on other sites

The adjusted 3D spline results in problems with complex shapes. See my attachment please. Can this be corrected?

post-955-0-20323700-1460381389_thumb.jpg

Share this post


Link to post
Share on other sites

Any news about sculpting layers or multi-monitor support?

I don't think so. I think we all have bogged Andrew down with a barrage of smaller requests. :D  As for Multi-Monitor support, I thought Andrew said that would require MAJOR structural work = not likely to get done anytime soon, with so many other things on the To Do list. As a consolation, you can simply scale/stretch your UI across two monitors. It works pretty well and affords much the same functionality....that is more real estate, where you can have your Texture Editor and panels on 2nd Monitor and all 3D viewport on your primary monitor 

  • Like 1

Share this post


Link to post
Share on other sites

How does the RFill Tool and QuadStripTool work? Are they supposed to work on these builds? The QuadStripTool draws a stroke, thats all I can get it to do, did I miss the instructions ? :)

Share this post


Link to post
Share on other sites

RFill fills holes in a very nice way.

QuadPaint Tool works by creating closed curve shapes and use Apply then.

 

Both tools are unstable! Be careful.

 

I don't know how to use Quadstrip. I guess it is in an pre alpha stage. Better don't touch it.

  • Like 2

Share this post


Link to post
Share on other sites

""""""""Quadstriptool works by APPLY""""""""""""

 

Mine has no apply. Just clear.

I'm not touching any of those tools until they are out of Beta, to be honest. I tried them recently, and like Chris just said...it's best to leave them alone for now.

Share this post


Link to post
Share on other sites

If you find bugs or something doesn't work the way you expect, please do file a report on Mantis. It is very helpful to the developers. :)

Sent from my SM-G900P using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

""""""""Quadstriptool works by APPLY""""""""""""

 

Mine has no apply. Just clear.

Sorry. I meant QuadPaint.

Share this post


Link to post
Share on other sites

Hi everyone, I'm trying to split each material into UV sets....  I can see "Surface Materials" show up fine and propagates according to my object surfaces/material list. However I was expecting UV sets to also be propagated. What am I missing...? 

 

Is there a way to populate "Surface Materials"  list to the > UV Sets? I'm probably not doing something correctly. Do I need to have existing UV coordinates on each vert? Do those UVs need to be in different quadrants (a la UDIM)?

 

 

Our past workflow has been to break up the object into many different objects, each object representing a UV Set in 3D Coat. This is a pretty archaic and slow workflow so I was jacked up and excited to see "New import option for PPP - import each material as separate UV set" in the latest beta description.

Share this post


Link to post
Share on other sites

I think you must create a new retopo group for each material so that as you retopo an object, your polygons can be separated by material.

Share this post


Link to post
Share on other sites

For those contemplating using VoxHide, it has problems:

 

post-1430-0-21302200-1460653423_thumb.pn

 

This makes retopology of mouth cavities very problematic, You can save if your object is symmetrical. At first I thought I had hidden a part in perspective mode and tried to restore it in orthographic mode but correcting for this gave a similar mis-match.

 

I have a bad mesh in the lower part of the mouth cavity but hiding the top half of the head would leave no safety net as it isn't symmetrical in Y. :(

 

 

Share this post


Link to post
Share on other sites

Agree with Philbraaten

 

If i import a model with Material IDs, will be helpful if 3DC automatically set Layer Groups by Material iDs and assigned to UVsets. 

And export the finished work in the same way, to assigned folders renaming textures and custom select paths

 

paint room, surface material, painted object, uv room... the user need to switch switch switch... a more relaxed workflow could help a lot

  • Like 1

Share this post


Link to post
Share on other sites

Agree with Philbraaten

 

If i import a model with Material IDs, will be helpful if 3DC automatically set Layer Groups by Material iDs and assigned to UVsets. 

And export the finished work in the same way, to assigned folders renaming textures and custom select paths

 

paint room, surface material, painted object, uv room... the user need to switch switch switch... a more relaxed workflow could help a lot

 

Its a MUST especially when all other apps out there use ID maps .

Hopes are high for this and its really easy to be achieved.

Share this post


Link to post
Share on other sites

Could not agree more. I've asked Andrew for this many, many times. To be honest, it makes 3DC unusable in quite a number of pipelines. I've had companies flat out refuse to use the tool because of this feature (or sometimes this is the straw that broke the camels back scenario). It's a huge problem that 3DC breaks the intended design of the file. Especially when more than one person is working in the pipeline.

 

This, compounded by a few other niggling issues like this, turn studios to other tools. Mari has come up many times as an alternative, and that is much more expensive. Lost users. Lost revenue. Bummer.

  • Like 1

Share this post


Link to post
Share on other sites

My previous post about VoxHide has a solution. Always Unhide in the same perspective/orthographic mode that you started with and it works as expected.

Share this post


Link to post
Share on other sites

I think you must create a new retopo group for each material so that as you retopo an object, your polygons can be separated by material.

 

I'll try this! 

 

 

UPDATE: OK this could work if I had to retopo the import.... but...  that's not really the case for us at this stage of the pipe. We have prop and set assets being built in different software and the polycount is already pretty efficient. Anyway, nothing would go into the retopo group because there's nothing to retopo. 

Edited by philbraaten

Share this post


Link to post
Share on other sites

Ok ,Having a nightmare now. I have just re installed Widows Vista . So I have a completely clean computer... tried to install Beta 34 but wont run because of some sort of "application  error"

Should I have installed an earlier version first.  or any vital software I should have..( I have the latest nvidia driver.) My first re install I downloaded all 119 updates for windows ,but 3dcoat would not run, so I re installed again but have not installed the updates yet ,thinking that might have something to do with it.

 

Clueless now.

Share this post


Link to post
Share on other sites

Ok ,Having a nightmare now. I have just re installed Widows Vista . So I have a completely clean computer... tried to install Beta 34 but wont run because of some sort of "application error"

Should I have installed an earlier version first. or any vital software I should have..( I have the latest nvidia driver.) My first re install I downloaded all 119 updates for windows ,but 3dcoat would not run, so I re installed again but have not installed the updates yet ,thinking that might have something to do with it.

Clueless now.

The latest versions do not support Windows Vista.

Sent from my SM-G900P using Tapatalk

Share this post


Link to post
Share on other sites

Yeah I tried it on my Vista machine. It mostly works, but I got lots of random crashes. I also noticed that sculpting in voxel mode doesn't work, only works in surface mode.

I'm still gonna upgrade that machine. I'm done with Vista.

Use no-cuda version

Please drop a line to Andrew

may be you need Microsoft Visual C++ redistributables

Share this post


Link to post
Share on other sites

Ok ,Having a nightmare now. I have just re installed Widows Vista . So I have a completely clean computer... tried to install Beta 34 but wont run because of some sort of "application error"

Should I have installed an earlier version first. or any vital software I should have..( I have the latest nvidia driver.) My first re install I downloaded all 119 updates for windows ,but 3dcoat would not run, so I re installed again but have not installed the updates yet ,thinking that might have something to do with it.

Clueless now.

Beta 34 worked on my Vista machine but I had to use the non-cuda version to get voxel sculpting to work (as Andrew suggested). I had all Windows Vista updates installed. I think you also need DirectX 9 loaded (if it isn't already).

Also don't load the Nvidia GeForce driver 364.72 because it supposedly has some bad bugs. Roll back to a previous version. I read somewhere 314.22 is ok.

Share this post


Link to post
Share on other sites

×