Jump to content
3DCoat Forums
Andrew Shpagin

V4.5 BETA (experimental)

Recommended Posts

One bug I do know exists only in build 4.5.36 is a pretty big one. When you export your model, 3D Coat doesn't export any maps....just the mesh. It was brought to Andrew's attention yesterday, so hopefully there will be a quick fix for it. Was a result of the export options dialog additions, somehow.

Do you mean the old way of exporting textures?

The new export constructor works fine.

Share this post


Link to post
Share on other sites

Do you mean the old way of exporting textures?

The new export constructor works fine.

I couldn't get any maps to be exported at all. Even deleted the Options.xml file > restarted and tested with the robot preset, and got nothing. Pretty sure Andrew tried it on his end and found the same thing

Share this post


Link to post
Share on other sites

EDIT...just re-installed 4.5.36 and it appears that the bug only occurs when "Use Export Constructor" is NOT checked. I'm certain it did not work at all last night....in either mode, cause I ran several tests to see what conditions it would work and not work. But for some strange reason, at least it partially works now

Share this post


Link to post
Share on other sites

EDIT...just re-installed 4.5.36 and it appears that the bug only occurs when "Use Export Constructor" is NOT checked. I'm certain it did not work at all last night....in either mode, cause I ran several tests to see what conditions it would work and not work. But for some strange reason, at least it partially works now

Since the constructor has been implemented in 4.5.35 I did not see a point of using the old export method, hence I didn't try it at all.

I've been texturing objects in 4.5.35-36 for the last two days, and so far the only issue I encountered with the constructor, is when I didn't supply an export path in the Output mesh field and textures got exported God knows where. Since then I always have some path in that field, even if ExportGeometry is set to false.

 

Speaking of constructor, I believe these options are now obsolete:

post-12523-0-59273700-1461446216_thumb.p

Edited by ajz3d

Share this post


Link to post
Share on other sites

A button to reload Stencils folder contents would be nice. For the time being I have to delete and add the existing folder again just to update its contents without having to restart 3D-Coat.

Share this post


Link to post
Share on other sites

Smart Materials seem to ignore the Additive Painting flag and always use additive painting instead, even if this flag is set to false.

post-12523-0-54668200-1461452253_thumb.p

Share this post


Link to post
Share on other sites

Smart Materials seem to ignore the Additive Painting flag and always use additive painting instead, even if this flag is set to false.

attachicon.gifscreenshot_16-04-24_00_56_31.png

 

 

I believe this is intended from a change made in build 4.5.34. Here's the text:

 

- When you paint with smart materials depth channel will replace current one on this layer instead of constant growing.

 

 

I'm not sure why it was implemented. I just turned the additive depth off. Now we have no control over it. Maybe Andrew can elaborate.

  • Like 1

Share this post


Link to post
Share on other sites

Hi, This is the shader I like to use in beta 19 ....can I use this exact shader in beta 36 ? If so, can it be installed from somewhere. Or do I have to emulate it by altering the supplied pbr shaders to try and match it.

I've spent ages having a go , I can get it grey but it lacks that certain sharpness of the one I like.

ta.

post-9171-0-36299800-1461614768_thumb.jp

Share this post


Link to post
Share on other sites

Hi, This is the shader I like to use in beta 19 ....can I use this exact shader in beta 36 ? If so, can it be installed from somewhere. Or do I have to emulate it by altering the supplied pbr shaders to try and match it.

I've spent ages having a go , I can get it grey but it lacks that certain sharpness of the one I like.

ta.

No. The new shader model does not support this as I know. But you can create a new shader from the default und set the values to be very similar to the old one.

An alternative could be to convert the old shaders to the new shader model. But I guess they will still not look the same like in v19. To convert them there is an option to be found in the "Edit" menu item, it is the last item in the list.

Share this post


Link to post
Share on other sites

Thanks , I will have a look at that convert shaders thing the next time I install a latest beta.I have altered a current shader but feel I only got it about 80 percent there . I just dont like the way they look for sculpting,( yes ,I have used the new contrast button!)  I like the zbrush grey look.I will use the 19 beta for now, I am not doin' much these days anyway so when I do get round to some thing I dont wanna really be fiddlin. around with shaders.

Share this post


Link to post
Share on other sites

Don't forget to lock the environment for sculpting and set the greyscale panorama. This help a lot.

Share this post


Link to post
Share on other sites

. To convert them there is an option to be found in the "Edit" menu item, it is the last item in the list.

it is for converting Materials not Shaders....

Share this post


Link to post
Share on other sites

Can someone please tell me how I get the non-CUDA version back? I always run the non-CUDA version. The CUDA builds create artifacts in the voxel volumes that never happen in the CPU builds. I also have always found the CPU version to be more stable, and performance is great on my dual-xeon machine. There must be a way the user can override this, right?

Share this post


Link to post
Share on other sites

The contrast button locks the environment, but I dont think I tried the greyscale thing. I went thru all the panaramas and some of those are basically greyscale ( the studio looking ones) . I will take a look at that .Thanks Taros. And At least I dont have to look at that convert shader thing now.....which actually says convert materials....thanks Artman.

 

Out of curiosity, what type shader setup  do other folk use in the latest beta for sculpting ?

Share this post


Link to post
Share on other sites

it is for converting Materials not Shaders....

Ow. OK. Thank you Artman.

Share this post


Link to post
Share on other sites

Can someone please tell me how I get the non-CUDA version back? I always run the non-CUDA version. The CUDA builds create artifacts in the voxel volumes that never happen in the CPU builds. I also have always found the CPU version to be more stable, and performance is great on my dual-xeon machine. There must be a way the user can override this, right?

Is there no 3D-CoatDX64S.exe in your application folder?

Share this post


Link to post
Share on other sites

Is there no 3D-CoatDX64S.exe in your application folder?

Nope, I just did a clean install of the latest build and these are no longer included. According to the release notes, this is by design?

 

21.04.2016 4.5.36 [beta]

- Export constructor polished. Included a lot of presets for export for main engines and renders.

- Incremental render turned off for "Connform retopo mesh" mode for corret view.

- Minimal radius for spike/snake/muscle removed.

- CUDA and no-CUDA version unified, now all choice performed automatically.

 

Edited by nervouschimp

Share this post


Link to post
Share on other sites

MMM. So last night while I was fiddlin' about with these shaders .( see previous posts above.) I had Beta 19 installed .( this has the shader I like.) So I installed Beta 36. I do this by just clicking on the icon of 3dcoat of the down load I have on my computer, which I assume replaces any previous version I have installed. So click on my Desktop icon and Beta 36 loads up .....fiddle around with the shader using the tips given to me earlier by you helpful lot. I still cant get it to my satisfaction,so gave up  and went to watch telly for an hour. When I came back to it I opened 3dcoat and Beta 19 loaded up instead of 36 but with that new splash screen that 36 has , the one that just says 3dcoat in grey on it. So had a look in the start menu and clicked on 3dcoat in there and managed to load up 36 again?

  So the jist of it is, I had two versions available at the same time. I thought when you installed it , it replaced the previous version you had. Just to be on the safe side I reinstalled Beta 19....now beta 36 has gone.

I am just wondering if I install 36 again will I continue to have two versions.This could be useful for me , but I  am wary of conflicts and licencing rules.

  Any one else have this?   ( when I install I always use default locations, so pretty sure I have not installed it in two locations.)

 

Sorry for the ramble ...if none of that made sense just ignore me....... :wacko:

 

 

Edit . I just noticed I have the screw thread primitives in 19. I thought these came in later. So how does that work, would they have been installed in a folder when I tried a newer beta then just remained there when I rolled back to 19? Any other new stuff in my 19 beta?

Edited by stusutcliffe

Share this post


Link to post
Share on other sites

Nope, I just did a clean install of the latest build and these are no longer included. According to the release notes, this is by design?

OK. My last clean install is some time ago. I have overlooked that. Sorry. It is something pilgway should check definitely.

Share this post


Link to post
Share on other sites

Can someone please tell me how I get the non-CUDA version back? I always run the non-CUDA version. The CUDA builds create artifacts in the voxel volumes that never happen in the CPU builds. I also have always found the CPU version to be more stable, and performance is great on my dual-xeon machine. There must be a way the user can override this, right?

 

 

Nope, I just did a clean install of the latest build and these are no longer included. According to the release notes, this is by design?

 

 

OK. My last clean install is some time ago. I have overlooked that. Sorry. It is something pilgway should check definitely.

 

 

Can we be given back the choice of CUDA/non-CUDA, please.

 

 

It is still optional. The only place CUDA is used anywhere in the program is in the Sculpt Room, so from within the Sculpt Room go to the menu Geometry>Use CUDA, and untick it. All done. No more CUDA.

  • Like 3

Share this post


Link to post
Share on other sites

It is still optional. The only place CUDA is used anywhere in the program is in the Sculpt Room, so from within the Sculpt Room go to the menu Geometry>Use CUDA, and untick it. All done. No more CUDA.

Thanks. Will it remain a permanently unchecked option or do we need to go through the process on every start?

Share this post


Link to post
Share on other sites

Thanks. Will it remain a permanently unchecked option or do we need to go through the process on every start?

 

Hi!

 

It remains unchecked between sessions.

Share this post


Link to post
Share on other sites

""""""""""""""Cuda only in sculpt room. Uncheck in geometry menu""""""""""""""""""""""""""""""""""""

 

That solved my issue. I was expecting the "auto choice" mentioned in the release notes.

 

Anyway........................

Share this post


Link to post
Share on other sites

""""""""""""""Cuda only in sculpt room. Uncheck in geometry menu""""""""""""""""""""""""""""""""""""

 

That solved my issue. I was expecting the "auto choice" mentioned in the release notes.

 

Anyway........................

 

It is ticked automatically if your video card supports CUDA. If it doesn't support CUDA, it isn't ticked. That's where the "automatic" part comes into play. Pretty straight forward really.

Share this post


Link to post
Share on other sites

×