Jump to content
3DCoat Forums
Andrew Shpagin

V4.5 BETA (experimental)

Recommended Posts

I just checked, and some of my old bug reports are still open, so I'm just going to drop my notes/bug reports here. I apologise, but I won't put more work into it, as that just leads to me being dissapointed when it ends up being ignored.

-The Fill Tool's 'colour tolerance' only works for the diffuse/albedo channel. While the name does seem to imply this, it should at least work on the other channels when you're displaying those directly (like when pressing 3 for Gloss only)

-The 'Glossiness Brightness' slider in the Layer Blending panel doesn't have an effect.

-The 'Contrast' slider in the Layer Blending panel should probably go to -1? Right now we have to type it in.

Clone Stamp problems:

-Gloss&Spec channels paint transparancy (like when your source-point is on the edge of the mesh) as black. The colour channel correctly leaves this transparent.

-The colour channel always ends up being brighter than the source!

-Transform/Copy tool's preview is extremely bright. The tool does appear to work correctly, it's just the preview of what you're going to stamp.

-Spline Image Tool only has inputs for Depth, Color and Glossiness textures. Depending on workflow, it's missing Specular or Metalness. And currently it paints the 'glossiness' texture into the metalness map, and paints black in the gloss channel.

-I had some issues with freezing, but haven't tried to reproduce them in Beta 5 yet. If I do, I'll update this or make a new post.:Undo sometimes freezes random parts, but only when I've used freeze in the file previously and unfrozen everything again. (I tried,and can't reproduce it. If it happens again I'll let you know)

-Colourpicking (v) doesn't pick up metalness.

EDIT: changing sliders in the Layer Blending panel doesn't work with undo/redo.

 

Edit: As shown here, using the lasso (or other shapes) Stroke Mode results in only a small sliver around the edge of the shape being painted. The PBR Material Preview shows what it should have looked like.

Thanks for feedback, working over it.
  • Like 2

Share this post


Link to post
Share on other sites

BETA5.

Putting paint layers into folder makes their glossiness and metalness disappear. Fortunately, removing them from the folder makes those two channels reappear.

Can anyone confirm this?

Fixed in beta 7 (coming soon)
  • Like 1

Share this post


Link to post
Share on other sites

Andrew, is it me or the lock concept of panorama is broken ?

I mean I can only rotate about 180° of the whole panorama. Making some setup impossible (main light facing the scene for instance).

 

Btw if using "not locked" mode and switching to vertical gradient rotating the env map is not possible anymore, while in locked mode it is. Can you make it possible in both ? 

Sometimes you just want the lighting and not be distracted by the photos.

 

Btw other issue, I must add that I mainly work with sculpts directly so that may work with proper uv mapped models:

Picker doesn't get the glossiness/metalness parameters. While it did in the past with regular specularity.

 

Also another issue I encounter and I'm pretty sure I'm not the only one: sometimes I fill a part with a pbr mat, and want to use the same mat on another part: I can't remember which mat I used. Is there a possibility that you add an indicator somehow to the used mat while using picker ?

  • Like 1

Share this post


Link to post
Share on other sites

Andrew, is it me or the lock concept of panorama is broken ?

I mean I can only rotate about 180° of the whole panorama. Making some setup impossible (main light facing the scene for instance).

 

Btw if using "not locked" mode and switching to vertical gradient rotating the env map is not possible anymore, while in locked mode it is. Can you make it possible in both ? 

Sometimes you just want the lighting and not be distracted by the photos.

 

Btw other issue, I must add that I mainly work with sculpts directly so that may work with proper uv mapped models:

Picker doesn't get the glossiness/metalness parameters. While it did in the past with regular specularity.

 

Also another issue I encounter and I'm pretty sure I'm not the only one: sometimes I fill a part with a pbr mat, and want to use the same mat on another part: I can't remember which mat I used. Is there a possibility that you add an indicator somehow to the used mat while using picker ?

Yes, Yes and +1

Edited by digman

Share this post


Link to post
Share on other sites

I is just me, or preview is broken now for most of pbr maetrials? Texures are not rendered in preview. Also this orange wood shader looks bit weird on model, compared to reference ball. But maybe it is just matter of mesh difference.

142154525454.jpg

Share this post


Link to post
Share on other sites

Another bug I found:

3DC_Brushbug%20%281%29.png

3DC_Brushbug%20%282%29.png

 

The first one shows the result of using this brush alpha with the Depth & Opacity stroke mode, the second one is using Stamp Drag.

Edited by Mighty Pea

Share this post


Link to post
Share on other sites

You may send file to support. But it is better if sharp edge of knife will get split normals, othervice angle between normals will be big and 8-bit/channel normalmaps will suffer.

Already sent

Edited by Cleitus

Share this post


Link to post
Share on other sites

Not sure if anyone else is getting this problem,...but I'm having a problem with the 'nav bar' dying on me when I've been painting using pbr materials after a bit,..and actually its happening about every 5-10 minutes now..So the problem is that I can't enlarge, move or rotate the textures, it simply doesn't react...Anyone have an idea how to fix this? 

 

thanks,

 

-Josh

Share this post


Link to post
Share on other sites

Voxel room Import to Separate Instance appears to be broken, beta 6.

 

 

Maybe it's not broken. It works if Import w/o Voxelization is checked.

Edited by bisenberger

Share this post


Link to post
Share on other sites

Updated to 4.6.beta7

- Convert old materials should work correctly

- several clone tool problems fixed: clone from outside area, correct blensding of color and gloss/metal, "through all volumes" works correctly.

- Import gloss/metal has now channel picking dialog.

- thumbnails will refresh more adequately - when layer or it's blending options are changed.

- Blending options for layers are oganised better, opetions separated into sections, gloss and metalness has now same options.

- In lock panorame mode screen refreshed when you rotate panorama. But panoramas management is still under construction....

edit: forgotten point(s)

- layers folder support metalness/gloss

  • Like 2

Share this post


Link to post
Share on other sites

Updated to 4.6.beta7

- Convert old materials should work correctly

- several clone tool problems fixed: clone from outside area, correct blensding of color and gloss/metal, "through all volumes" works correctly.

- Import gloss/metal has now channel picking dialog.

- thumbnails will refresh more adequately - when layer or it's blending options are changed.

- Blending options for layers are oganised better, opetions separated into sections, gloss and metalness has now same options.

- In lock panorame mode screen refreshed when you rotate panorama. But panoramas management is still under construction....

Clone tool works AMAZING !!! congrats, really big issue solved. :)

We can now use it to properly break or reorganize painted pbr details across model.

 

Also Layer Blending modulations all work on export now!! 

(for users who did not notice,previously all layer blending modulations to glossiness would not find their way into the map on export.

It only affected glossiness display from inside 3DC....was really important to fix imo.)

 

edit:awesome !! Layer folders comaptibility with glossiness/metalness fixed too. (you forgot to add it to beta7 fixes list)

Its getting really close to a solid 4.5 build.

 

now almost only Clip masking issue missing....do you have idea how to fix?

------------------------------------------------------------------------------------------------------------------

to other users:

I cannot use the Transform gizmo inside the PBR preview window. Preview disappear or is displayed wrongly if I use gizmo instead of nav bar or

if mouse/stylus cursor enter pbr preview widow while scaling/moving using the nav bar.

I am the only one with this issue? Can other user confirm please?

Share this post


Link to post
Share on other sites

Clone tool works AMAZING !!! congrats, really big issue solved. :)

We can now use it to properly break or reorganize painted pbr details across model.

 

Also Layer Blending modulations all work on export now!! 

(for users who did not notice,previously all layer blending modulations to glossiness would not find their way into the map on export.

It only affected glossiness display from inside 3DC....was really important to fix imo.)

 

edit:awesome !! Layer folders comaptibility with glossiness/metalness fixed too. (you forgot to add it to beta7 fixes list)

Its getting really close to a solid 4.5 build.

 

now almost only Clip masking issue missing....do you have idea how to fix?

------------------------------------------------------------------------------------------------------------------

to other users:

I cannot use the Transform gizmo inside the PBR preview window. Preview disappear or is displayed wrongly if I use gizmo instead of nav bar or

if mouse/stylus cursor enter pbr preview widow while scaling/moving using the nav bar.

I am the only one with this issue? Can other user confirm please?

Thanks!

Actually masks clipping already resolved after publishing beta7 build.

I will browse last 3-4 pages to find all reported issues to make all clean.

Share this post


Link to post
Share on other sites

New PBR features are awesome. Some suggestions for new PBR Editor:

 

Drag/drop maps between channels - often diffuse/depth/spec etc use the same map.

 

Depth slider should go negative or have other options (subtract/replace/etc)

 

PBR window doesn't hold it's position - jumps to screen center when new options resize the dialog.

 

Auto-seamless on texture maps - either by mirroring or edge blend e.g. http://registry.gimp.org/node/28112

Edited by jamie

Share this post


Link to post
Share on other sites

Andrew, is it me or the lock concept of panorama is broken ?

I mean I can only rotate about 180° of the whole panorama. Making some setup impossible (main light facing the scene for instance).

 

Btw if using "not locked" mode and switching to vertical gradient rotating the env map is not possible anymore, while in locked mode it is. Can you make it possible in both ? 

Sometimes you just want the lighting and not be distracted by the photos.

 

Btw other issue, I must add that I mainly work with sculpts directly so that may work with proper uv mapped models:

Picker doesn't get the glossiness/metalness parameters. While it did in the past with regular specularity.

 

Also another issue I encounter and I'm pretty sure I'm not the only one: sometimes I fill a part with a pbr mat, and want to use the same mat on another part: I can't remember which mat I used. Is there a possibility that you add an indicator somehow to the used mat while using picker ?

Now it is "concept" but I see it's disadvantages.

Picker will be fixed, but recovering material is impossible. The possible thing is to store last material (or list of materials) used on given layer - just like primitives history.

Share this post


Link to post
Share on other sites

bug: If I select any of the default start up objects for per pixel painting and click Cancel  3dcoat stop responding then crash a few seconds latter.

Share this post


Link to post
Share on other sites

if import a model for ppp, but cancel... sometimes crash too

Share this post


Link to post
Share on other sites

I'm getting a dark AO map every time I generate,...is there a setting I should be aware of to avoid this?  See the attached image for what I'm talking about,..my AO along with my textures I paint have this dark brown tint...

 

thanks again,

 

-Josh

 

post-2039-0-60430700-1421711521.jpg

post-2039-0-60430700-1421711521_thumb.jp

Edited by jdoublej

Share this post


Link to post
Share on other sites

@Andrew

What did you think about Fill Layers like in Substance Painter?

Would it be possible to store the Material in a layer that we could change and modify it on the fly?

  • Like 1

Share this post


Link to post
Share on other sites

×