Jump to content
3DCoat Forums
Andrew Shpagin

V4.5 BETA (experimental)

Recommended Posts

Object in paint room disappears when using the brush tool in stamp/ stamp drag mode, making it hard to use (4.5 Beta13A).

Confirmed.... Same problem here for objects baked from the retopo room. Show voxels in paint room is turned off...

The bug does not happen if you import a model for PPP mode... no voxel model in the sculpt room.

Share this post


Link to post
Share on other sites

In Paint Room, I find the object will disappear when in orthographic viewing mode, toggle to perspective view mode then the object shows up again.

This seems to be a workaround, but, the object disappearing may considered as a bug also.

Share this post


Link to post
Share on other sites

In Paint Room, I find the object will disappear when in orthographic viewing mode, toggle to perspective view mode then the object shows up again.

This seems to be a workaround, but, the object disappearing may considered as a bug also.

 

 

I've tried a number of things, no luck reproducing this one. Could you elaborate a little more? Which build are you using? OS? Video card? Paint Objects, Sculpt Objects or both?

Share this post


Link to post
Share on other sites

I've tried a number of things, no luck reproducing this one. Could you elaborate a little more? Which build are you using? OS? Video card? Paint Objects, Sculpt Objects or both?

 

Sorry for the ambiguous post previously, the issue I've been encountering is with per pixel Paint Objects which baked from Retopo Room only while Sculpt Objects show up fine in paint room.

 

To reproduce the issue at my side:

1. Bake any Surface Object in per pixel mode.

2. Hide all Surface Objects then go straight to the paint room.

3. Toggle viewing mode to orthographic and the Paint Objects will be disappeared.

4. To get all Paint Objects back to showg up, the viewing mode need to be switched to perspective viewing mode. 

 

I'm on Windows 7, 4.5 BETA13A.

Share this post


Link to post
Share on other sites

Sorry for the ambiguous post previously, the issue I've been encountering is with per pixel Paint Objects which baked from Retopo Room only while Sculpt Objects show up fine in paint room.

 

To reproduce the issue at my side:

1. Bake any Surface Object in per pixel mode.

2. Hide all Surface Objects then go straight to the paint room.

3. Toggle viewing mode to orthographic and the Paint Objects will be disappeared.

4. To get all Paint Objects back to showg up, the viewing mode need to be switched to perspective viewing mode. 

 

I'm on Windows 7, 4.5 BETA13A.

I could reproduce your steps if I hide the surface mode object in the sculpt room but left "Show Voxels in Paint Room" (View Menu) selected after baking. Deselecting Show Voxels in Paint Room fixes the problem on my end... 4.5 Beta 13A

This might not be a bug but just how 3DC works. If you hide the model in the surface mode but not deselected the above, the viewport in the paint room does not work correctly.

The normal workflow is to deselect Show voxels in the paintroom after baking or before baking. This leaves the surface object not hidden in the sculpt room but only hidden in the Paintroom. The reason the surface mode object appears in the paintroom is for vertex painting (poly painting) without the need of a uv set...

You may of course still file a bug report and if possible Andrew could make it so it will work both ways...

 

EDIT: I tested 4.1.17D The above problem does not happen so it must have something to do with the new PBR style of rendering in the Paint Room. A possible bug as there is another case of disappearing mesh that Wilson66 posted about and I confirmed also.

Edited by digman

Share this post


Link to post
Share on other sites

I could reproduce your steps if I hide the surface mode object in the sculpt room but left "Show Voxels in Paint Room" (View Menu) selected after baking. Deselecting Show Voxels in Paint Room fixes the problem on my end... 4.5 Beta 13A

This might not be a bug but just how 3DC works. If you hide the model in the surface mode but not deselected the above, the viewport in the paint room does not work correctly.

The normal workflow is to deselect Show voxels in the paintroom after baking or before baking. This leaves the surface object not hidden in the sculpt room but only hidden in the Paintroom. The reason the surface mode object appears in the paintroom is for vertex painting (poly painting) without the need of a uv set...

You may of course still file a bug report and if possible Andrew could make it so it will work both ways...

 

EDIT: I tested 4.1.17D The above problem does not happen so it must have something to do with the new PBR style of rendering in the Paint Room. A possible bug as there is another case of disappearing mesh that Wilson66 posted about and I confirmed also.

Thank you for your elaboration and issue's confirmation. :)

Share this post


Link to post
Share on other sites

Toggle viewing mode to orthographic

 

will you please press shift+a ?

post-10142-0-37191700-1425949591_thumb.j

post-10142-0-79907400-1425949180_thumb.j

post-10142-0-30285200-1425949182_thumb.j

Share this post


Link to post
Share on other sites

Toggle viewing mode to orthographic

 

will you please press shift+a ?

attachicon.gifframe.jpg

Beta13A is now back to the old naming convention which is "Show Voxels in Paint Room" Whether this is intentional or not I do not know.

@ Carlosan, I made sure my surface mode object was centered in world space. The object is visible in ortho mode.

 

Below is from my testing.

Make sure show voxels in paint room is selected before baking. It as you know is selected by default but good to check.

Bake a surface mode model for PPP from the retopo room.

Next go to the Sculpt Room and hide the surface mode model using using the voxlayer tab "eye" icon.

Now Go back to the paintroom Your baked mesh has disappeared.

DeSelect Show Voxels in Paint Room and your baked mesh reappears.

This was not the case for 4.1.17D which leads me to think it is a bug.

Picture shows version 13A with the Show Voxels in Paint Room back again... I did a complete clean install of Beta13A.

post-518-0-15167400-1425968311_thumb.png

Edited by digman

Share this post


Link to post
Share on other sites

Beta13A is now back to the old naming convention which is "Show Voxels in Paint Room" Whether this is intentional or not I do not know.

@ Carlosan, I made sure my surface mode object was centered in world space. The object is visible in ortho mode.

Below is from my testing.

Make sure show voxels in paint room is selected before baking. It as you know is selected by default but good to check.

Bake a surface mode model for PPP from the retopo room.

Next go to the Sculpt Room and hide the surface mode model using using the voxlayer tab "eye" icon.

Now Go back to the paintroom Your baked mesh has disappeared.

DeSelect Show Voxels in Paint Room and your baked mesh reappears.

This was not the case for 4.1.17D which leads me to think it is a bug.

Picture shows version 13A with the Show Voxels in Paint Room back again... I did a complete clean install of Beta13A.

There is something wrong with the distro version of the UI, looks like Andrew isn't using the latest one I sent to him. I'll seems it to him again and let him know about the issue.

I checked out the latest build without my edits and found some other ones that are older/out of date as well, so thanks foe the heads up!

Share this post


Link to post
Share on other sites

Sorry for the ambiguous post previously, the issue I've been encountering is with per pixel Paint Objects which baked from Retopo Room only while Sculpt Objects show up fine in paint room.

To reproduce the issue at my side:

1. Bake any Surface Object in per pixel mode.

2. Hide all Surface Objects then go straight to the paint room.

3. Toggle viewing mode to orthographic and the Paint Objects will be disappeared.

4. To get all Paint Objects back to showg up, the viewing mode need to be switched to perspective viewing mode.

I'm on Windows 7, 4.5 BETA13A.

It's no problem at all, thanks for elaborating. It'll help narrow down reproduction. I'll give it a go. [emoji4]

Share this post


Link to post
Share on other sites

Following Gilbertman & Digman steps

cant replicate

sorry

 

4.5 13A - CUDA - DX64 - Win7

 

//David, if you need a skype destop share to test 3DC in my comp, point me. NP.

Share this post


Link to post
Share on other sites

In sculpt room, create a new voxel object. Zoom in close to the object, and use the Move tool. It causes the object and grid to 'flicker'.

 

No flickering is happening when the viewport camera is at a certain distance from the object, also more flickering is happening in perspective mode (orthographic mode only flickers on first click, while in perspective mode the viewport continues to flicker while holding down the mouse/ pen button).

 

Viewport seems to flicker more the smaller the brush radius is.

Edited by wilson66

Share this post


Link to post
Share on other sites

Hi

Cant replicate the flickering, sorry

post-10142-0-06247200-1425996724_thumb.j

 

Switch Geometry > incremental render on or off, change something  ?

post-10142-0-90455900-1425996817_thumb.j

 

Will you please test version dx cuda/no cuda and GL ?

 

ty

Share this post


Link to post
Share on other sites

I can't replicate the problem now myself, very strange. Don't know what was going on, I will try to reproduce it.

 

My report here and on Mantis can probably safely be ignored for now.

Share this post


Link to post
Share on other sites

Following Gilbertman & Digman steps

cant replicate

sorry

 

4.5 13A - CUDA - DX64 - Win7

That is interesting. This is a reproducible bug each and everytime I test. The paint room baked mesh disappears and then reappears according to the steps posted.

Edited by digman

Share this post


Link to post
Share on other sites

In sculpt room, create a new voxel object. Zoom in close to the object, and use the Move tool. It causes the object and grid to 'flicker'.

 

No flickering is happening when the viewport camera is at a certain distance from the object, also more flickering is happening in perspective mode (orthographic mode only flickers on first click, while in perspective mode the viewport continues to flicker while holding down the mouse/ pen button).

 

Viewport seems to flicker more the smaller the brush radius is.

 

I can reproduce it, and it does seem to happen with smaller brush sizes more often than larger. But it can also happen with larger ones, just not as often.

Share this post


Link to post
Share on other sites

post-10142-0-91260900-1426023793_thumb.j

 

my tests were done using a QUADRO FX 580

Share this post


Link to post
Share on other sites

GeForce GTX 760 here.

 

DX, 4.5.13A build.

Share this post


Link to post
Share on other sites

I think something is going buggy with the 3D viewport as we now have reports on, flicking in sculpt room, render room, disappearing mesh using a spline tool and disappearing baked mesh when show voxels is selected or changing  from perspective to ortho mode. That is at least worth a good look see from Andrew.

Edited by digman

Share this post


Link to post
Share on other sites

GTX 650

cuda DX64

 

mesh YES disappear at orthographic mode IF surface model at sculpt room is hide AND show voxels in paint room is ON

 

BUT appear IF sculpt room > show poly object in sculpt room is ON

Share this post


Link to post
Share on other sites

Heya :)

Since this is the first time iam posting i would like to take a second and express how much i love this software and how incredible its development speed/quality/interaction is. Andrew and his guys seem to be really pushing it.

 

On a more thread related note i did come across an error in the recent 4.5 beta builds but iam not quite sure if it is me doing something wrong or the software.

For me the Texture Offset Tool seems to be not working correctly.

Steps to reproduce:

 

1.) File -> Import -> Image Plane (choose nothing or color/normal maps, settings seem not to matter, also there seems to be some strange artifacting going on).

2.) In Paint Room: Modify Image or leave as is.

3.) Textures -> Offset Tool (again settings seem not to matter)

 

At which point the texture plane turns invisible.

Can anyone confirm this issue? I had it in all 4.5 builds i tried so far.

Share this post


Link to post
Share on other sites

painting freeze masks was visible in 13A.... Can you make "Freeze Degree" pressure sensitive though please. this is a must have to paint smooth mask transitions

Edited by Boonta

Share this post


Link to post
Share on other sites

In sculpt room, create a new voxel object. Zoom in close to the object, and use the Move tool. It causes the object and grid to 'flicker'.

 

No flickering is happening when the viewport camera is at a certain distance from the object, also more flickering is happening in perspective mode (orthographic mode only flickers on first click, while in perspective mode the viewport continues to flicker while holding down the mouse/ pen button).

 

Viewport seems to flicker more the smaller the brush radius is.

 

Mine works fine.

Share this post


Link to post
Share on other sites

×