Jump to content
3DCoat Forums

Recommended Posts

There is a bug again if you import using voxeling,

the imported object doesn't have the pivot in the center.

We had this again before 4.5 release.

 

 

Share this post


Link to post
Share on other sites

Ok OpenCl disappeared again from roll out.  :blink:

I get error message : "can't get the number of OpenCl platforms" as soon as I select the Occlusion tool.

Im trying with the robot sample so its not because its too heavy file.

Yesterday it worked(well,not always...but it was always visible in roll out) but today its not there anymore.

I did not change anything from yesterday.(4.5.09)

Hi! Please try this update/fix (for 3DCoat 4.5.09 x64 only):

 

* Fixed black result problems;
* Optimized videomemory for per-vertex AO mode;
* OpenCL initialization use only latest dll from Khronos Group.
(The results currently can be white if deficiency of videomemory, I will try to fix this problem soon.)
 
Thanks for testing!
Edited by carrots

Share this post


Link to post
Share on other sites

BUG: Cannot colour pick from the Texture Editor window if object is hidden.

 

Why is this necessary?  Can we have it changed please.

Share this post


Link to post
Share on other sites

 

Hi! Please try this update/fix (for 3DCoat 4.5.09 x64 only):

 

* Fixed black result problems;
* Optimized videomemory for per-vertex AO mode;
* OpenCL initialization use only latest dll from Khronos Group.
(The results currently can be white if deficiency of videomemory, I will try to fix this problem soon.)
 
Thanks for testing!

 

still getting "can't get the number of OpenCl platforms" as soon as I select the Occlusion tool. :(

Even with the Default Robot file....

I would like for more users with NVidia graphic cards to report on this.

Maybe my graphic card is dying or somethin....

2 days ago everything worked fine with the new driver....

The only thing I did is changing UI a bit...very strange.

Finally,I dont think that makes the "entire" build unsafe as its only one feature in the whole program

and even maybe releasing the build with this issue will provide more feedback from other users

that may lead to solution...

Share this post


Link to post
Share on other sites

AO baking artifacts:

 

AO_art.png

 

When using the 'name correspondence' option in the baking menu, other objects in the scene should be ignored to avoid artifacts. Doesn't work with AO baking though. Above is the bake using name correspondence (clearly visible "shadows" from surrounding objects), below another bake of the same scene without that option but manually hidden surrounding objects.

 

Or is this correct behavior/ only for normal maps?

Edited by wilson66

Share this post


Link to post
Share on other sites

AO baking artifacts:

 

AO_art.png

 

When using the 'name correspondence' option in the baking menu, other objects in the scene should be ignored to avoid artifacts. Doesn't work with AO baking though. Above is the bake using name correspondence (clearly visible "shadows" from surrounding objects), below another bake of the same scene without that option but manually hidden surrounding objects.

 

Or is this correct behavior/ only for normal maps?

I agree, all the work done on AO in the Paint Room should be mirrored to the BAKE menu in the Retopo Room, and it should be available for PPP w/ Displacement and MicroVertex as well. That way, the user can take advantage of the Sequential Texture Baking, using "Naming Correspondence."

 

In the mean time, you can just skip the AO baking when merging objects into the Paint Room, and just do it all in the Paint Room. But it won't work with normal maps, you may say. Andrew changed that just before 4.5 was released. It now takes advantage of normal maps during AO baking. So, that is a pretty BIG feature, in my opinion.

Share this post


Link to post
Share on other sites

Noise stays on General Clay even when Noise checkbox is unchecked. In order to disable the noise, one needs to bring down its sliders to zero first.

To reproduce, select General Clay, enable Noise, increase its amplitude and tweak its scale, then finally disable the noise and start sculpting. The noise will remain enabled.

Edited by ajz3d

Share this post


Link to post
Share on other sites

Self-intersection Detection (General Clay) creates holes (with Merge and Repel actions) and spikes (Repel action) in the mesh. Also, Repel makes a garbled mess out of the surface.

Reproducible on a default sphere.

 

post-12523-0-98846500-1438885240_thumb.j

Share this post


Link to post
Share on other sites

I don't think it's a bug, because the checkbox says Apply Realtime, so it's applied immediately after you tweak any of the parameters. The noise remains editable until you close the options window or switch to other tool. Though I admit that it's confusing and I got fooled many times by this mode thinking it's just a preview. :)

Anyway, the Apply button gets hidden now once you enable Apply Realtime.

 

And speaking of Noise tool, sometimes it becomes non-undoable for no reason. It happened to me several times during the last hour.

Edited by ajz3d

Share this post


Link to post
Share on other sites

still getting "can't get the number of OpenCl platforms" as soon as I select the Occlusion tool. :(

Even with the Default Robot file....

I would like for more users with NVidia graphic cards to report on this.

Maybe my graphic card is dying or somethin....

2 days ago everything worked fine with the new driver....

The only thing I did is changing UI a bit...very strange.

Finally,I dont think that makes the "entire" build unsafe as its only one feature in the whole program

and even maybe releasing the build with this issue will provide more feedback from other users

that may lead to solution...

artman, please try this version:
 
from now programm first initialize OpenCL.dll from device vendor, if failed - program try find OpenCL64.dll from vendor, and if failed again - program automaticaly try use DLL from Khronos Group.
One of these has to work properly.
 
WARNING: Necessarily you need to delete OpenCL.dll and OpenCL64.dll from 3DCoat instalation folder. (Keep only cOpenCL64.dll).
 
in this update also fixed: error painting on AO layer after calculation...
 
Thanks!
Edited by carrots

Share this post


Link to post
Share on other sites

 

artman, please try this version:
 
from now programm first initialize OpenCL.dll from device vendor, if failed - program try find OpenCL64.dll from vendor, and if failed again - program automaticaly try use DLL from Khronos Group.
One of these has to work properly.
 
WARNING: Necessarily you need to delete OpenCL.dll and OpenCL64.dll from 3DCoat instalation folder. (Keep only cOpenCL.dll).
 
in this update also fixed: error painting on AO layer after calculation...
 
Thanks!

 

now it says ; "Error 2:can't get the number of OpenCl platforms.Method 0."

really wish i could help you more. :(

I'll ask user Jose Conseco he has gtx 660 too.

 

Edit: I've sent him a message...we'll see,

AbnRanger does not seem to have any problem since he updated the driver.

With latest driver it was working too on my side but it stopped working after a day

...right after I changed UI a bit...maybe it is related.

Share this post


Link to post
Share on other sites

now it says ; "Error 2:can't get the number of OpenCl platforms.Method 0."

really wish i could help you more. :(

I'll ask user Jose Conseco he has gtx 660 too.

 

Edit: I've sent him a message...we'll see,

AbnRanger does not seem to have any problem since he updated the driver.

With latest driver it was working too on my side but it stopped working after a day

...right after I changed UI a bit...maybe it is related.

I have GTX 660 too, but there work very fine. And i can't reproduce this problem.

Very sorry... ):

Share this post


Link to post
Share on other sites

I haven't had any issues with OpenCL on my GTX460 (although I run on Linux).  From the error it definitely looks like a driver issue, as it looks like it can't find the OpenCL libs.

 

Is there a way to specify which GPU to run on?  I have two, so it would be nice to be able to choose my other one that I don't use for the displays.  

Share this post


Link to post
Share on other sites

Is there a way to specify which GPU to run on?  I have two, so it would be nice to be able to choose my other one that I don't use for the displays.  

Yes, I plan to add this option

Share this post


Link to post
Share on other sites

now it says ; "Error 2:can't get the number of OpenCl platforms.Method 0."

really wish i could help you more. :(

I'll ask user Jose Conseco he has gtx 660 too.

 

Edit: I've sent him a message...we'll see,

AbnRanger does not seem to have any problem since he updated the driver.

With latest driver it was working too on my side but it stopped working after a day

...right after I changed UI a bit...maybe it is related.

Maybe you already tried this, but re-install the latest driver, and at the beginning of the install, choose CUSTOM. After you proceed, there should be a small checkbox at the bottom left with the text "CLEAN INSTALL." That removes the old completely and installs the new. Then see if you still get that error message in 3D Coat.

  • Like 1

Share this post


Link to post
Share on other sites

Greetings , 

 

one small request please that will serve all the community.

 

Can you kindly post hot-fixes link and a small description at the first page like usual?

 

Changes:

3.08.2015 4.5.09

- OpenCL tweaked to solve existing problems.
- Started refactoring. And seems it leads to functionaliny tweaking as well. Uncluttering allowed to use "On plane" in surface tools. It is in "Flattern tool" that may be really uselul.

 

HOTFIXES bla bla bla

 

Description : Solves bla bla bla

Share this post


Link to post
Share on other sites

Gpu AO is not working for me now, but worked in previous release...

Anyway render result from hemisphere AO bake is not normalized correctly:

SkyLf4n.jpg

Sphere AO bake ao looks ok, but hemisphere and hemi+sphere are to dark. I used standard blend mode for AO layers.

Edited by JoseConseco
  • Like 2

Share this post


Link to post
Share on other sites
JoseConseco,

Thanks! Hemisphere really darken by 20%. I fixed it.

 

Which specific versions 3D Coat has worked OpenCL and what versions don't worked?

What video card you have installed?

Any error messages you received?

Share this post


Link to post
Share on other sites

Maybe you already tried this, but re-install the latest driver, and at the beginning of the install, choose CUSTOM. After you proceed, there should be a small checkbox at the bottom left with the text "CLEAN INSTALL." That removes the old completely and installs the new. Then see if you still get that error message in 3D Coat.

Thanx,its working again now. :)

(But it worked fine when I installed driver the first time....then stopped working for no reason after a day or 2.)

Lets hope its still working in a few days...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×