Jump to content
3DCoat Forums

Recommended Posts

Actually same exists in "stable" 4.5.03.

3D-Coat become so huge and deep that some issues are remaining invisible for many months...

Anyway I set 4.5.14 as stable, at least it is better than 4.5.03.

No problem. You have to decide such things. I just wanted to mention it. Thx.

I think Symm Copy should be disabled or a warning should appear if you click on it while Virtual Mirror mode is on....because the user is sending the application two conflicting commands. When you have Virtual Mirror mode on (it should be placed in the Toolbar, not hidden in the Retopo menu), you are telling 3D Coat that you DO NOT want real geometry across the symmetry plane....not yet, anyway. When you leave it active AND hit Symm Copy, that is a contradictory command. No wonder it's buggy. It confuses the heck out of the application. It's like one parent telling their kid to go to sleep, and the other telling them to go to the living room and do their (school) homework. :D

:)

  • Like 1

Share this post


Link to post
Share on other sites

Can someone tell me what setting to change or what i'm missing?

 

I can't seem to paint SOME of the pixels on the edge of UV shells.

 

Arrows shows the artifacts of the pixels I can't paint.

 

55d9518c16d69.png

 

Share this post


Link to post
Share on other sites

A german user who is not speaking english well has extreme problems in the surface mode of v4.5.14. The bug appears randomly.

 

Here is the post with images: http://3d-coat.com/forum/index.php?showtopic=18215

Some more infos after talking with the user.

 

- The user is switching between voxel and surface mode to use some of the special mode tools like pinch.

- When using undo / redo then the artefacts appears.

 

I have tested it with a sphere. It was not easy to reproduce it, bebause it needs a lot tweaks and undos / redos but sometime gaps eppear between some faces in the surface mode.

 

Best wishes

Chris

Share this post


Link to post
Share on other sites

4.5.15

- fixed Symm copy in retopo tool

- uniform movement in FPS mode

Really cosmetic changes. This is expected to be stable build.

Thanks Andrew, but could you please make sure that each build goes on the Google Drive FIRST. 4.5.15 is not on the Google Drive and the standard link is slower than frozen molasses. Slower than 1990's Dial-Up, slow.

Share this post


Link to post
Share on other sites

....nevermind. After looking at the G-Drive again, I can see they are there. What threw me off was some 4.5.14 links on the end, where the latest builds are usually on the very end.

Share this post


Link to post
Share on other sites

Thank you Andrew for reintroducing the old style quick quadrangulation method in 4.5.15!

Share this post


Link to post
Share on other sites

I just wanted to say a big thank you to the developers on how quickly the updated versions for Linux and MacOS are coming out.  It's awesome, thank you!

 

Jason

Share this post


Link to post
Share on other sites

Is Project Scale 100% etc (for use in external editors) back in? 

What do you exactly mean?

Share this post


Link to post
Share on other sites

What do you exactly mean?

 

ROENhGT.png

 

This is missing from the latest version, i had to revert to an older build.

  • Like 1

Share this post


Link to post
Share on other sites

Texture Projection size/multiplier

This option will be recover in v4.05.16 -probably tomorrow-

  • Like 1

Share this post


Link to post
Share on other sites

Just Tested the new pbr functions. I loved it, it simplifies a lot working a shading - in less than 10 minutes i had my materials setted up in cycles with jst minor tweaks : O! -

 

feedback:

 

- When Painting "pbr" With brush and switch to fill. The smart material preview stays minimized. However, if you switch from fill to brush it resets and open again. It should only open when you activete the whole "pbr painting" thing. Having to minimize it all the time can be annoying sometimes. 

 

- Being able to rotate environment trough horizontal axe. Currently we can only do it on the vertical one. Most of the time it's ok, but in some models, like a hammer or an airplane that rotates a lot it's important to check how the material will behave in diferent situations.

 

- For materials that are not for an engine, sometimes it's better to tile textures and mix shader layers with a mask texture. Is it posible to bake each layer of a smart material into square textures to tile and be used on an coated material? the workflow seems perfect for videogames, but it doesn't seem to totally integrate for rendering.

 

- This one is just personal preference, can be ignored but people from modo and blender will appreciate.Trackball/ orbit rotation. Seems a little thing, but some times i miss that so much!

 

Thanx and continue with the good job! 

Share this post


Link to post
Share on other sites

Updated to 4.5.16 [stable]

- restored Projection scale

- Fixed Fill whole layer/Refill layer in UV mapping mode

- SHIFT LMB - rotate panorama, SHIFT RM - blur panorama, it is good to estimate glare of the model. Need to re-select navigation scheme to get this.

- Correct offset on VoxLayer tool in "Average normal" mode

- Fixed length corrected in measure tool in scenes with scale

Main development branch is different, I am making only small tweaks in stable branch to avoid general stability breaking.

Mac/Linux will come in 1-3 days.

  • Like 4

Share this post


Link to post
Share on other sites

v4.05.16 stable so far.

 

Gongrats Andrew.

Share this post


Link to post
Share on other sites

Confirmed , and now how am i going to get the lost folders and materials back?

 

This was a bad idea lol.

Share this post


Link to post
Share on other sites

AO baking weirdness:

 

ao_weird.png

 

Left: retopologized object, AO baked with Textures -> Calculate Occlusion. Very strange result.

 

Right: the same object, exported with File -> Export Objects & Textures, then re-imported into the paint room, AO baked with Textures -> Calculate Occlusion (same settings). Correct result.

 

I get this unusable AO result on the left side of the screenshot occasionally. What could be going on?

Edited by wilson66

Share this post


Link to post
Share on other sites

Thank you Andrew for all your work. 

 

I am trying to find some information about the roadmap of 3D-C. Are there any plans to make layer masking easier? (it is kind of crazy for a user at the moment) or being able to mask some of the layer adjustments especially (Hue/Sautation/Value/Brightness/Contrast?).

 

I know texture painting is not the main focus and it is all about the package as a whole but i really like the texture portion of the package. 

Share this post


Link to post
Share on other sites

AO baking weirdness:

 

ao_weird.png

 

Left: retopologized object, AO baked with Textures -> Calculate Occlusion. Very strange result.

 

Right: the same object, exported with File -> Export Objects & Textures, then re-imported into the paint room, AO baked with Textures -> Calculate Occlusion (same settings). Correct result.

 

I get this unusable AO result on the left side of the screenshot occasionally. What could be going on?

Maybe voxel model was not hidden in the voxel tree.
Voxel models casts a shadow on the low-poly model.
  • Like 2

Share this post


Link to post
Share on other sites

 

Maybe voxel model was not hidden in the voxel tree.
Voxel models casts a shadow on the low-poly model.

 

 

Thanks, I wasn't aware that this is necessary. It works when I hide the voxel model. 

 

Strange though that I have never done this before, and some bakes work without those artifacts, others don't. Also, those artifacts appeared when baking AO in combination with normal bake in retopo room (Bake -> Bake with Normal Map).

 

Anyway, thanks again for the hint.

Edited by wilson66

Share this post


Link to post
Share on other sites

Thanks, I wasn't aware that this is necessary. It works when I hide the voxel model. 

 

Strange though that I have never done this before, and some bakes work without those artifacts, others don't. Also, those artifacts appeared when baking AO in combination with normal bake in retopo room (Bake -> Bake with Normal Map).

 

Anyway, thanks again for the hint.

That would seem to indicate the retopo mesh is beneath the surface of the Voxel object. If snapped properly and you adjust the inner and outer baking cages correctly, during the bake setup process, all should go as expected.

  • Like 1

Share this post


Link to post
Share on other sites

Any chance of getting an option to use the 4.1 paint brush in 4.5 (specifically, paint buildup)? Theres been a few topics about it lately cropping up:

http://3d-coat.com/forum/index.php?showtopic=18182

http://www.polycount.com/forum/showthread.php?p=2345263

 

Also, when is the Smooth/Blur tool going to be fixed so it works with modern texture resolutions?

http://3d-coat.com/mantis/view.php?id=1502

Edited by PolyHertz
  • Like 1

Share this post


Link to post
Share on other sites

I'm suffering without drag and drop operations for image files. I want to drag and drop a texture file to Smart Materials window and it would create a default material with this texture, so I can paint on my model with this texture. Manually creating material for any single texture is very annoying task.

Mantis report.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×