Jump to content
3D Coat Forums
Andrew Shpagin

V4.5 BETA (experimental)

Recommended Posts

Color palette / Color Swatches

drop menu is working on your side too ?

post-10142-0-23959000-1447516405_thumb.j

post-10142-0-50129800-1447516499_thumb.j

 

ty

Share this post


Link to post
Share on other sites

3DC version beta 4.5.22 non-cuda 64 bit----Windows 7

 

The color picker using the V key or using the sampler icon appears not to be working. Choose color from all layers is enabled.

Can someone confirm this? 

 

Also, the below has been going on for a while and not sure if it is a bug or since we got PBR it no longer works...

 

Problem: Per-Pixel Mode in the paint room...

When you press Ctrl-Alt-P there is no projection data in Photoshop CC. No model image or colors... It is empty except for the wirefire

 

EDIT:

If you use "Edit Projections in Ext. Editor" under the Edit Menu it works, Just not the hotkey combo... I will test some more... 

Got it>>> The hotkey combo had been resigned to "Edit all metal Layers". I did not resigned them... I set a new hotkey combo, all works good now... 

Edited by digman

Share this post


Link to post
Share on other sites

4.5.22 [beta]

- Image may be directly dropped onto Smart matrial editor slots

Great adddition, I can not get it to work though. When I drag an image from Windows Explorer or a DAM into one of the map slots nothing happens

or I get the Popup which offers me to create Alphas, Strips etc. What also doesn't work and would be helpful was dragging a already loaded map

from one slot to the next(or getting a dropdown with all referenced bitmaps to choose from). Another thing I found useful: Doubleclick on the

Shaderball opens the Material Editor.

Share this post


Link to post
Share on other sites

Limited Testing on the new padding settings choices we have... First, like to say Thank you Andrew for working on this problem...

 

" Take Interpolated Color"  Seems best for general painting and even better at higher resolutions. 

 

"Naive" which I think was meant to be "Native" as Naive means lack of wisdom, understanding, He was naive in thinking that he could make a A+ animation on his first day at animation school... ;)

 

"Naive"... Seems best for pixel painting... I could pixel paint right on one side of the seam ( no linear texture filter) without some partially transparent pixels appearing on the other side of the seam. This was not possible in former versions of 3DC...

 

"Take Nearest Opposite Pixel" My least favorite of the 3 as it seems closer to the old style with it's problems. I will have to test this one some more...

 

Generally it seems that Andrew also just did some deeper work on the problem as well... Nothing is perfect in life and I do not expect it to be so, these routines are better. Will you encounter some problems yes,,, We are working over seams. There can be stretching because of the uv set layout or at worse just a bad uv seam layout... 3DC cannot correct that and no padding routine is iron clad so I always expect some clean-up but now that has been reduced...

 

Testing done in PPP mode with a 512k map...

Edited by digman

Share this post


Link to post
Share on other sites

Naive is NAIVE, not native. It is simplest and works not good if displacement used. But for some cases it really works as you need.

LOL,.. Ok  Andrew, I got it... it is the simplest routine... Though not a normal word one would use for a setting, that is in American vernacular. We would just use the word "Simple"

 

This setting does works good for pixel painting and again thank you for all the hard work... 

 

Forget to mention,,, " Take Interpolated Color" , it indeed is good for displacement...

Edited by digman

Share this post


Link to post
Share on other sites

Great adddition, I can not get it to work though. When I drag an image from Windows Explorer or a DAM into one of the map slots nothing happens

or I get the Popup which offers me to create Alphas, Strips etc. What also doesn't work and would be helpful was dragging a already loaded map

from one slot to the next(or getting a dropdown with all referenced bitmaps to choose from). Another thing I found useful: Doubleclick on the

Shaderball opens the Material Editor.

It works if your 3DC is not maximized.... Though it should work either way... 

 

3DC maximized... from the taskbar, open Windows explorer and drag a file into a slot, nothing happens.

 

Unmaximize 3DC then you can drag in an image file to a Smart Materal slot, that works...

 

That is how it is working on my end ATM...

Edited by digman

Share this post


Link to post
Share on other sites

Off topic, but does anyone know if 3DC has a scratchpad feature (like in Paint Tool SAI. digital equivalent to a palette board for mixing colors) ? If not, it would be a nice addition.

Share this post


Link to post
Share on other sites

I confirm the above issues as well.

 

And i must say that i am again really impressed from the additions and bug fixes.

 

Thank you Andrew and rest of the team.

Share this post


Link to post
Share on other sites

Off topic, but does anyone know if 3DC has a scratchpad feature (like in Paint Tool SAI. digital equivalent to a palette board for mixing colors) ? If not, it would be a nice addition.

Nope not ATM, would be nice though... I maded my own color mixer for now, though the tools available... 

I created a mixing palette board in TwistedBrush... I can either mix colors or use a gradient blend of colors ( gray gradient is shown on the right but colors as well can be used)

 

When done mixing a few colors, Copy that layer to the Windows Clipboard.

 

Now jump back to 3DC, paste it into the additional color palette from 3DC's Windows menu drop list. In this 3DC color palette, you have no need to click on a color but just hover over it for selection.

I can keep jumping back and forth as needed and update the color palette... Plus can save the Palette in Twistedbrush for later use.

The old saying in digital painting, The best thing about digital painting is that we have millions of colors to choose from, the worst thing about digital painting is we have millions of colors to choose from... LOL 

 

The colors shown are highly saturated, I did not drop a grayscale layer over them set to color mode to desaturate them to what I would need. This was just for show...

post-518-0-16460200-1447537436_thumb.jpg

post-518-0-99853200-1447537471_thumb.jpg

Edited by digman

Share this post


Link to post
Share on other sites

The color picker using the V key or using the sampler icon appears not to be working. Choose color from all layers is enabled.

Can someone confirm this? 

 

not to be working in PPP mode

 

working in Sculpt paint mode

Share this post


Link to post
Share on other sites

It works if your 3DC is not maximized.... Though it should work either way...

3DC maximized... from the taskbar, open Windows explorer and drag a file into a slot, nothing happens.

Unmaximize 3DC then you can drag in an image file to a Smart Materal slot, that works...

That is how it is working on my end ATM...

Thanks Digman,

I never use any program in non maximized state but I gave it a try. On my end this doesn't get drag and drop to work either.

Share this post


Link to post
Share on other sites

3DC version beta 4.5.22 non-cuda 64 bit----Windows 7

 

The color picker using the V key or using the sampler icon appears not to be working. Choose color from all layers is enabled.

Can someone confirm this? 

...

Confirmed in pixel paint mode. I go back to v.21. Can't work without color picker.

  • Like 1

Share this post


Link to post
Share on other sites

Yes i can confirm , digman confirms , carlos the same.

Share this post


Link to post
Share on other sites

Confirmed in pixel paint mode. I go back to v.21. Can't work without color picker.

workaround:

Color picker works in Texture Editor window.

Share this post


Link to post
Share on other sites

Thanks Digman,

I never use any program in non maximized state but I gave it a try. On my end this doesn't get drag and drop to work either.

Either do I... I did it as a test... Yes it needs fixing by the development team which I'm sure it will be...

Share this post


Link to post
Share on other sites

The mirror uv island problem has been brought up by a couple of users recently. When painting you get artifacts on the edges of the uv islands. Now if you turn symmetry on along the correct axis, then there is no problem...

 

Is turning symmetry on Andrew's way of avoiding any artifacts when painting mirrored uvs or is this a bug? It has been awhile since I used mirrored uvs. I used them before when I was working on game for a few months and do not remember having problems back then without symmetry being enabled.

 

I uploaded a simple 3DC file for anyone who cares to test... Use Ctrl+C then Ctrl+V to paste one island to the other, bake for PPP without a normal map...(no baking) test away... Symmetry is 100% correct in the retopo room.

 

3DC version beta 4.5.22 Windows 64 bit non-cuda. 

 

EDIT: Ah, I see there is a bug report as well at Mantis.

seam artifacts.zip

Edited by digman

Share this post


Link to post
Share on other sites

Something is going on with the smart materials folders.

 

I created several folders to brake up a huge folder and get them categorized.

 

Now , the folder that were shipped with 3d coat , fabrics for example show my custom materials in there and nothing from the shipped ones.

Share this post


Link to post
Share on other sites

Michaelgdrs, I had simiar problem. I had old Smart Materials in folder 'OldMat'. I moved skin smart material from 'OldMat' folder to newly created 'Skin' folder. Now there are two duplicates of skin materials: one in 'Skin' folder - as expected, but second copy is in 'Wood' folder - and all default wood materials are gone! 

So while moving SmartMaterial from old folder to 'skin' folder, 3dc erased wood materiasl ! and put copies of skin materials into it! Not good. I better backup my material library.

  • Like 1

Share this post


Link to post
Share on other sites

Each time i try to move a material from one folder to another this happens.

 

Thank you Jose for reporting this as this is a serious one that can cause issues on a commercial project.

Share this post


Link to post
Share on other sites

4.5.23 [beta]

- fixed problem of non-boolean fail over non intersecting objects.

- Non-boolean merge all/merge subtree

- Corrected drag&drop to pbr editor

- fixed problem of color picker/swatches dialog

- fixed picking in ppp mode

  • Like 4

Share this post


Link to post
Share on other sites

4.5.23 [beta]

- fixed problem of non-boolean fail over non intersecting objects.

- Non-boolean merge all/merge subtree

Many many thanks for the bugfix and the feature. I was about to script in the non-boolean merge all/subtree, but that bug was preventing me from doing it. :)

Share this post


Link to post
Share on other sites

×