Jump to content
3DCoat Forums
Andrew Shpagin

V4.5 BETA (experimental)

Recommended Posts

After working on the Max applink for a while, there are two things I think really need to get fixed:

 

-Fix for UI undocking bug when using Applinks (anytime 3DC auto loads a file using "import.txt" it undocks random UI windows).
-Fix for run.txt application autorun happening too early (it shouldn't run the app until user presses OK in Export Options).

 

I'm looking at maaaybe updating or remaking some of the other applinks, but I don't want to bother if at least the first issue isn't going to be resolved.

 

Also on that note, where did the online scripting manual go?

Edited by PolyHertz
  • Like 1

Share this post


Link to post
Share on other sites

Is it possible to get a fix to be able to hide the freeze mask in the main PBR viewport. its really distracting to paint with this . its been bugged for quite awhile. 

 

http://3dcoat.com/mantis/view.php?id=1850

You can always change the way the freeze selection is displayed...to fit your preference. You can do this through the Freeze menu (Toggle Freeze View or Show/Hide Freeze selection)

 

Share this post


Link to post
Share on other sites

yeh these functions are great and work fine in 4.1 but have been busted in the new PBR viewport/shaders since the 4.5 beta began. Show/Hide doesn't work. and the visible overlay effect of the mask is quite harsh . At a minimum id like to be able to just hide the freeze mask.

Edited by Boonta

Share this post


Link to post
Share on other sites

is it possible to use a smart material as a mask generator ? so you are using the smart material to provide a cavity mask while you paint on the fly changing colors at will ? it seems possible in theory but i need to change the color in the smart material each time i need a new color which is a bit slow. unless there is a better way..........................?

Share this post


Link to post
Share on other sites

is it possible to use a smart material as a mask generator ? so you are using the smart material to provide a cavity mask while you paint on the fly changing colors at will ? it seems possible in theory but i need to change the color in the smart material each time i need a new color which is a bit slow. unless there is a better way..........................?

 

Absolutely. :) Just paint the SM on a layer, then go to the layer you want to mask, click on the little arrow pointing downward on the right of the layer name and set the layer you want to be the clip mask (which will be the layer you painted the SM on), and hit Invert Clip Mask.

Now select the layer with the SM, turn the opacity depth & roughness (metalness too if you need) to 0%. That will do the trick. EDIT: Of course you can also not turn the opacities to 0% but whatever you like, for some more wear effects, which always looks good.

I did a video on the topic here, where I paint my mask to hide something I've already painted and want to rough up. Same principle, but just in reverse. Here's the link:

 

Edited by Javis
More info on Opacity/Depth/Etc.

Share this post


Link to post
Share on other sites

Any news about a new build?

The orthodox church started their christmas two days ago. They celebrate it on the 6th - 7th of January. So we will need patience some more days. :)

Share this post


Link to post
Share on other sites

the clip mask feature is pretty handy . i wish there as a visual way to see which layers have a clip mask and also which mask layer they are using to clip... even something simple like color coded icons or something 

  • Like 1

Share this post


Link to post
Share on other sites

Curves tool doesn't snap to 2D and 3D grid. It is only possible to snap their control points once they are created, and how it works is that it's not the centre of the point that gets snapped, but instead the point where you clicked your mouse on.

  • Like 1

Share this post


Link to post
Share on other sites

Curves tool doesn't snap to 2D and 3D grid. It is only possible to snap their control points once they are created, and how it works is that it's not the centre of the point that gets snapped, but instead the point where you clicked your mouse on.

I confirm the issue as well on the 2d grid.  I had noticed it about a month ago but never mentioned the issue... The point gizmo is not effected at all by the grid snap either. 

Edited by digman
  • Like 2

Share this post


Link to post
Share on other sites

3D-Coat has permanently emptied my whole surface layer. At first I experienced a strange issue when I couldn't sculpt on the layer at all (the brush circle did not show up), even though the sculpture was visible. So I saved and reloaded the scene and WHAM - my layer is empty. 0 triangles.

I did not use proxy. I was only sculpting and rendering.

---

It happens whenever I press CTRL+M combination in the sculpt room and I don't have this combination mapped to anything. What's more, CTRL+M cannot be mapped to anything at all.

Can someone please try this combo and see if it makes the surface layer unsculptable and eventually deleted (upon scene reloading)?

Edited by ajz3d

Share this post


Link to post
Share on other sites

Did a test on cube and Yes same thing happens exactly as you described . I am on 4.5.03 win 8.1

Thanks for confirmation. I'll report it to Mantis.

Share this post


Link to post
Share on other sites

4.5.25A

Symm Copy result:

post-12523-0-14117500-1452708767_thumb.j

Surface mode, Z-Axis symmetry. Copying from Z+.

---

Decimation, Clean Surface, Weld Vertices, also cause similar issues (with symmetry on or off). Probably 3D-Coat corrupted my surface layer somewhere along the road.

---

Same with Tangent Smoothing.

Edited by ajz3d

Share this post


Link to post
Share on other sites

While we are on the subject of mesh corruption.

Version beta 4.5.25 Non cuda 64 bit, GL, Windows 7 64 bit.

 

Voxel Mode.

Extrude brush with the Stamp Drag "X" tool from the e-panel

Drag to place your Alpha stamp.

Click Undo

Blam, big time mesh corruption on the Stamp extrusion. It only undo parts of the mesh.

post-518-0-63057700-1452729864_thumb.jpg

Edited by digman

Share this post


Link to post
Share on other sites

I'll try to reproduce it.

---

Regarding corruption from my post, tools that I were using are:

When layer was in voxel mode:

- Symmetry: Radial 16x (later 12x) + additional Z-plane

- Move, Build, Fill, Clay

Then after conversion to surface:

- Similar symmetry settings. Sometimes symmetry off only to temporarily turn on Z-plane for Symm Copy operation

- Move, LC Inflate (or what it's called, I'm not near my computer ATM), amForm, amSharp, LC CleanClay (decimate), Fill, LC Extrude, Pose

- Tangent Smoothing 25x

- Strong and Bump Smoothing

These are those that I remember.

I made duplicates of my layer as I progressed further into details.

I fixed the layer by converting it to super hi-res voxel volume and back to surface again. Makes me wonder why tools like Clean Surface are useless in fixing corrupted surfaces.

---

Andrew has fixed the CTRL+M bug.

Edited by ajz3d

Share this post


Link to post
Share on other sites

And once again my VoxTree layer got corrupted when I was working in surface mode. Same symptoms.

---

Yet another problem. I call them "air pockets". They form up from time to time in brushed areas and are hard to remove:

 

post-12523-0-88491000-1452777611_thumb.j

 

post-12523-0-07102500-1452777616_thumb.j

 

Some of them are disconnected from the outer surface and float freely inside the mesh:

 

post-12523-0-29041200-1452777849_thumb.j

 

This happens on a mesh that was freshly converted from voxels. After some LC brushing.

 

The only reasonable way of removing those disconnected bubbles that I can think of, is to use Powerful Smoothing because it welds nearby vertices.

 

---

OK, this is ridiculous. There's no way I can hunt them all:

 

post-12523-0-65889000-1452778372_thumb.j

Edited by ajz3d

Share this post


Link to post
Share on other sites

Merge Visible (no-booleans) crashes 3D-Coat (after long calculation time) if merged objects are instances. I suggest to automatically call Un-Instance for visible objects before running the operation.

---

Clone tool for voxels sometimes causes infamous Out of Memory error even though lots of memory is still available. This occurs randomly. Just a moment ago 3D-Coat crashed when I was attempting to clone a fragment of a voxelized 18M mesh. Next time I used it, on a similar fragment of the same mesh - it worked.

Edited by ajz3d

Share this post


Link to post
Share on other sites

4.5.26 [beta]

- Big and important! Anti-atiased painting introduced everywhere - vertex paintg, ppp, mv, ptex. It is applied to stencils, materials, brushes, text, curved pictures.

See examples (stencils) - https://t.co/zI9lOpLUBt , text - https://t.co/iLTQsmmaik

- Export of metallness is possible in gloss/specular color workflow as well.

- Export dialog got controls to correct exported textures via gamma and curves correction (preparing to make good presets for all renders).

- Move via brush tool in retopo room will not snap vertex to cursor position even if thre is only one vertex in brush.

- Contours for cutting may be saved in UV and Retopo rooms, look in Commands->Save contour. Files may be saved as EPS or DXF. It is very useful for real thing production - like shoes or acryl details.

  • Like 6

Share this post


Link to post
Share on other sites

:clapping:  :clapping:  :clapping: THANK YOU FOR THE EXPORT DIALOG PRESETS

Share this post


Link to post
Share on other sites

Yay, texture export curve correction! Definitely going to be using that.

 

I also posted this on the previous page, but can we get the bug fixed where random UI windows become undocked whenever importing via an applink? It's seriously annoying.

Edited by PolyHertz

Share this post


Link to post
Share on other sites

×