Jump to content
3DCoat Forums
Andrew Shpagin

V4.5 BETA (experimental)

Recommended Posts

I selected polygons from the upper part of one retopo group and cloned them to a new group. Then I hid the original group and began working with the clone. After some time, I revealed the original group and I encountered it at the following state:

 

post-12523-0-69007900-1456606270_thumb.j

 

Most of the polygons I cloned have disappeared.

---

I lost another retopo group. I have a reason to believe that it is caused by symmetry.

 

post-12523-0-01591600-1456607811_thumb.j

 

This time I was prepared for this and kept a backup in a form of an exported .obj file.

Edited by ajz3d

Share this post


Link to post
Share on other sites

@ajz3d. Yep I think you have found a bug... The same thing happens if you have a few retopo object layers and you delete them, The remaining retopo object layer has missing polygons.. I found out about this just the other day when I was testing the autopo and had some retopo object layers that were part of the test but I no longer needed them. The only way to avoid getting the missing polygons was to create another uv set and move all the other retopo object layers to that uv set... 

 

This is a critical bug and needs fixing asap...

  • Like 1

Share this post


Link to post
Share on other sites

@ajz3d. Yep I think you have found a bug... The same thing happens if you have a few retopo object layers and you delete them, The remaining retopo object layer has missing polygons.. I found out about this just the other day when I was testing the autopo and had some retopo object layers that were part of the test but I no longer needed them. The only way to avoid getting the missing polygons was to create another uv set and move all the other retopo object layers to that uv set... 

 

This is a critical bug and needs fixing asap...

Thanks for confirming it, Digman. Damn, this is one nasty bug, and I'm still unsure how to reproduce it. What I'm fairly sure of though is that I did not remove any retopo groups before the bug hit me for the first time, though I might be mistaken because I didn't really pay too much attention.

 

My workflow (for the current challenge) is to retopo a base object (a sculpt), occasionally use built-in simple subdivision to generate a denser mesh, clone this and that to a new retopo group, hide the original group, work with the clone and frequently test its subdivision in the sculpt room by importing a mesh from retopo room via Pick From Retopo button.

---

Dig, I just noticed that your current reputation is equal to 666. :diablo: Repent your sins, brother! :D

Edited by ajz3d

Share this post


Link to post
Share on other sites

Dig, I just noticed that your current reputation is equal to 666. diablo.gif Repent your sins, brother! biggrin.png

 

Yes, all my answers to the questions at the forum have subliminal messages in them, just like the Beatles 1969 album "Abby Road"   ;)

Edited by digman
  • Like 1

Share this post


Link to post
Share on other sites

Evening all!

The one thing I would absolutely love is for the sculpt object to be visible in the tweak room. It would be so useful.

Marc, I heard rumours that the tweak room is scheduled for future removal.

Share this post


Link to post
Share on other sites

Marc, I heard rumours that the tweak room is scheduled for future removal.

Noooooooo! :-(

Are there any plans for an alternative? It is a really useful room for low making tweaks to low poly objects for baking purposes.

Sometimes, you don't want everything to conform to what is in the sculpt room. Your awesome script did help with part of this but this is like the final piece of the puzzle.

Does anyone else use the tweak room?

Share this post


Link to post
Share on other sites

Noooooooo! :-(

Are there any plans for an alternative? It is a really useful room for low making tweaks to low poly objects for baking purposes.

Sometimes, you don't want everything to conform to what is in the sculpt room. Your awesome script did help with part of this but this is like the final piece of the puzzle.

Does anyone else use the tweak room?

Actually, most of the functionality already exists in the Retopo workspace...except for some of the sculpt tools. The Brush tool (with Auto Snap turned off) in the Retopo Room works just the MOVE brush. What I suggested to Andrew in a conference call, is to consolidate the mesh structures of the Paint and Retopo workspaces, so regardless of which of those workspaces you use, it's all the same mesh. That would allow Andrew to remove the UV tools from the Retopo room....that way the UV room is the place to do all UV's, period.

 

I asked him to add Soft Selection (which is in the Tweak Room) and to add the Surface mode brushes. That would remove 2 tabs/workspaces and the app works more like what a new user would expect. I hope he is currently working on consolidation, but don't know

  • Like 1

Share this post


Link to post
Share on other sites

I hope he is currently working on consolidation, but don't know

 

Refactoring the whole app is a pretty huge task...I'm not sure its finished. 

Share this post


Link to post
Share on other sites

So everything is going to the better side of things , that good.

Share this post


Link to post
Share on other sites

Actually, most of the functionality already exists in the Retopo workspace...except for some of the sculpt tools. The Brush tool (with Auto Snap turned off) in the Retopo Room works just the MOVE brush. What I suggested to Andrew in a conference call, is to consolidate the mesh structures of the Paint and Retopo workspaces, so regardless of which of those workspaces you use, it's all the same mesh. That would allow Andrew to remove the UV tools from the Retopo room....that way the UV room is the place to do all UV's, period.

 

I asked him to add Soft Selection (which is in the Tweak Room) and to add the Surface mode brushes. That would remove 2 tabs/workspaces and the app works more like what a new user would expect. I hope he is currently working on consolidation, but don't know

That sounds pretty good actually and it makes a lot of sense. 3d Coat can be a complex beast but it is still faster than zbrush for baking from 3d scan data and adding normal maps to individual portions of a low poly mesh.

Share this post


Link to post
Share on other sites

4.5.29 [beta]

- Shading using PBR was essentially changed. Now GGX lighting natively supported. What does it actually means -

1) Almost all voxel sculpting shaders are PBR compatible now. Each shader has rich set of parameters, including different textures, sss, gloss, metalness, cavity and bulge settings. Very good support of cavity and bulge is present in realime.

2) All PBR shaders effects (except pseudo SSS effect) are exactly baked into paint room.

3) PicMat-s are also present but it is not guaraneed that they will be baked correctly, so use them only on intermediate stage.

4) GGX exact support means compatibility with most of current engines and renders.

5) Painting over mesh is "as is" without modulation on background shader color. But painting over layer 0 is disabled for voxels/surface.

- Factures included in this build (DX only). It is essentially beta stuff, so it is just for review. Factures are addional covering over the voxel/surface objects. We take tiled texture and mix it with random pieces seamlessly. It allows to cover meshes with tiled textures without tiling. Also it allows to texture objects without UV-s at all. It is very important for landscapes. It was developed long time ago, but now we decided to expose it as beta tool. To use factures go to Paint room, open Windows->Popups->Factures and select facture. Now paint over object. Textue will be modulated by selecteed color.

SEVERAL DRAWBACKS:

- Old shaders are disabled because shaders system was completely re-made.

- Old panoramas are disabled, you will need to add them as HDR or EXR files from scratch.

  • Like 3

Share this post


Link to post
Share on other sites

New shaders look awesome! Nice work Andrew.

 

I have only one problem - I cannot find the contrast icon that is supposed to be located somewhere in the top right area of the screen.

post-12523-0-42352700-1456846340_thumb.p

 

This is a screenshot from 3D-Coat using factory settings. As you can see there is no such button in this location.

post-12523-0-53818700-1456846346_thumb.p

---

Cool! We can toggle between coloured and greyscale panorama versions. This will come in handy.

Edited by ajz3d

Share this post


Link to post
Share on other sites

Thanks for your hard work in the new update, I have one major problem described below.. It does not effect the new default shader.

 

Sculpt Room:

The new PBR shaders have this grid pattern which is very distracting for sculpting and not smooth like the old shaders. It appears to be the voxel or surface mode grid type patterns.

This also effects the non PBR shaders as well. The more you res+ the smaller the grid but they are still there. Is this the intended behavior? This model is 1,8 million. I tested a 6 million voxel model and as stated the grid pattern is still there.

 

The problem also is in the new contrast mode, either one the grid pattern is still there.

 

Other users please confirm this problem to know if it is happening with other systems and graphic cards..

Nvidia 770...  Drivers 361.43

 

Beta version 4.5.29---- 64 bit non cuda, DX--- Windows 7

Same shader problem in the GL version too.

 

EDIT: A 16 million surface mode or voxel mode object still has a clearly seen grid pattern.

EDIT2: I am getting black texture areas in the 3DC render room... These areas are correctly rendered in 4.5.28 but now in 4.5.29 these same areas are black...  The original color is a lighter rust tone... That will be the subject of another post with details but not till tomorrow.

post-518-0-39410300-1456867636_thumb.png

post-518-0-26387600-1456867982_thumb.png

Edited by digman

Share this post


Link to post
Share on other sites

Same here with 4.5.29 DX and GL, with and without CUDA enabled on a Laptop with a GeForce GT 630M running Windows 10

 

I'll further test with the workstation if needed. No build for Linux yet, though.

Share this post


Link to post
Share on other sites

I will post this picture of the render room, this goes with my second edit from my first post.

 

The bake model is from the paint room with a smart material and normal map.

left side of the attached image... 4.5.28  This is rendered correctly... GGX shader (Unreal) Roughness---Metalness workflow.

right side--------------------------      4.5.29. This  is rendered incorrectly with some texture areas almost being black.  GGX shader Burley 12 (Unreal) Roughness---Metalness workflow.

 

Look at roughness too there is a large difference between 4.5.28 and 4.5.29

Metalness is set at 100 percent in the smart material shader with some roughness, top material layer is pure dielectric with some roughness.

No matter the light angle from the hdr image the black areas are still there... That is one of the default Hdr Env maps..

 

Please do your own test and report back here to make sure it is not my system, details in my first post...

post-518-0-27503400-1456873801_thumb.png

Edited by digman

Share this post


Link to post
Share on other sites

PBR shaders grid pattern

 

Edit shader settings test

cavity setting = 0.5 solve the issue

cavity off = solve the issue

 

I think the problem is in the new cavity shader effect

 

-----------

render room - default settings-

exposition is very High

shadows could be better

visible artifacts

post-10142-0-22334200-1456877518_thumb.j

 

--------------------

New Sculpt shader system is a m a z i n g, much better visual feel/feedback

 

Ty !

Share this post


Link to post
Share on other sites

PBR shaders grid pattern

 

Edit shader settings

cavity setting = 0.5 solve the issue

cavity off = solve the issue

 

I think the problem is in the new cavity shader effect

 

-----------

render room - default settings-

exposition is very High

shadows could be better

visible artifacts

attachicon.gifRR.jpg

 

--------------------

New Sculpt shader system is a m a z i n g, much better visual feel/feedback

 

Ty !

Nope, after disabling cavity.  The default shader is fine and needs no adjustments. It is the others... We should not have have a grid pattern... New users will go what the H@###ll and experience users should not have to adjust the cavity settings in the shader to remove a grid pattern plus I was still getting  some grid effects after disabling cavity.

post-518-0-51892300-1456878120_thumb.png

Edited by digman

Share this post


Link to post
Share on other sites

Confirmed the issue in another machine using 4.5.29 (GL64) CUDA and non-CUDA both using a Quadro K620.

 

Changing the shader's parameters as carlosan said doesn't solve the issue, here.

Share this post


Link to post
Share on other sites

We should not have have a grid pattern

 

agree, just try to point in one direction, its not a directive to work without problems

 

there is a issue to be solved

Share this post


Link to post
Share on other sites

Man, this new shader system is pretty amazing...I'm just messing around and I made a pretty convincing seal skin texture.  

I think it still needs some tweaks as Digman alluded to.  Perhaps a sensitivity slider or an option to blur the effect on the depth and bump colours, as right now it's picking up a lot of the imperfections on my mesh and drawing too much attention.  Actually, I'm not sure it's the same thing that's happening to Digman.  

 

But I must say, I'm very excited.  Any chance of getting Yebis post processing integration?

 

Untitled-1.jpg

  • Like 3

Share this post


Link to post
Share on other sites

×