Jump to content
3DCoat Forums
chikega

[Solved] Normal Map Artifacts and Lightwave

Recommended Posts

It appears that I'm getting significant normal map artifacts with the latest version of 3dCoat 4.1.17D. In previous versions, I would always get clean normal maps by simply exporting the object as a LWO. I've tested the objects in both Lightwave 11.6.3 and Lightwave 2015.1 to see if it was a Lightwave problem, but the same artifacts show up in both versions. 

I then loaded scenes with objects and normal maps generated by previous versions of 3dCoat and the renderings are clean with no artifacts. See images. The first image is an older scene using Lightwave 2015.1. The second image is a new scene using Lightwave 2015.1 ... it looks the same in 11.6.3. 

3dCoat%20Lightwave%201.png

 

3dCoat%20Lightwave%202.png

Edited by chikega

Share this post


Link to post
Share on other sites

Hi Chikega

 

Will you post which Normal Map Software Preset are you using ?

 

post-10142-0-25802000-1419368557_thumb.j

 

ty

Share this post


Link to post
Share on other sites

Looks like the green (Y) needs flipped. (Or use one of the presets that does it for you like Carlos suggested)

Share this post


Link to post
Share on other sites

I actually tried switching on and off X, Y, Z ... no joy. 

Here is a screen shot of my preferences which I have never messed with before. 

Pref%203dcoat.png

Share this post


Link to post
Share on other sites

Try please this set

 

but dont flipY inside LW Normal map - Node Editor

 

post-10142-0-88357800-1419371678_thumb.j

Share this post


Link to post
Share on other sites

It appears to be an issue with LW on Win 8.1. I created normal maps in Zbrush and get the same artifact issues on the PC. But the same objects render correctly on Mac OSX. 

 

I've started a thread on the LW forum: http://forums.newtek.com/showthread.php?145007-Normal-Map-broken-LW-2015-1-Win8-1&p=1415543#post1415543

Edited by chikega

Share this post


Link to post
Share on other sites

Yes i was reading your post

 

there is 2 reply

Do you tested this solutions in your project ?

Will be nice to know the result after it

 

Are you using color-space conversion?

Did you disabled color-space conversion on normal map image file?
It looks too bright to me = it has been passed through color-space converting routine..

 

Yes, I'm wondering if you just need to make sure it's set to Linear in the image properties, could it be that simple?

 

Share this post


Link to post
Share on other sites
Changing the Color Space RGB of the Normal Map from Default to Linear fixed the issue in the corrupt scene. But what is strange is that in the other scene, it's set on Default and works. Weird.

 

After investigating a little further, I noticed that the color spaces for each scene are totally different. I've never messed with the Color Space settings before.

 

post-10142-0-18666500-1419438566_thumb.p

 

Well, glad it looks as solved.

  • Like 1

Share this post


Link to post
Share on other sites

×