Jump to content
3DCoat Forums
Vaiktorg

[Solved] PBR Quality is not the same in Viewport vs PBR Mat. Previewer

Recommended Posts

Im having this issue where i cant really see what im doing because the viewport and the render room, is not showing me the correct visual representation of the PBR material. In contrast, the PBR Material Previewer works wonders and it looks how it is supposed to. Is this an BETA problem or is it just me? I added a picture of what i mean as an attachment.

 

Yes, i have tried everything and read everything, even work with the lights!

post-38828-0-85929300-1419658368_thumb.p

Edited by Vaiktorg

Share this post


Link to post
Share on other sites

Hi

 

At which texture resolution are you working ?

 

Fast test using 4K

 

Before

post-10142-0-38642400-1419675335_thumb.j

 

After

post-10142-0-07852100-1419675334_thumb.j

 

note:

there is a BETA2 ^_^

Share this post


Link to post
Share on other sites

Nop, same results, exactly how you did! Quick 4K res test, same results!

post-38828-0-74561600-1419704605_thumb.p

Share this post


Link to post
Share on other sites

Your Metalness is set = 0 %

 

will you please try Metalness = 100 %

user color tolerance = off

main color white and not black

Share this post


Link to post
Share on other sites

  1. Your color opacity is set to 200%
  2. Your image textures might have an alpha channel. It takes that into account and applies alpha (which screws with whatever channel the image is being applied to and will make it look completely different than expected)

Share this post


Link to post
Share on other sites

Did what you ordered and still can see a difference, the lights are conforming better with the normals and the masks in the model through the material previewer than the actual viewport. You could clearly see the difference in the texture on the painted camo and the depth on the paint over the bare metal, vs the viewport texture.

 

Will try the same again with Beta 2 and come back!

post-38828-0-79339700-1419729069_thumb.p

Edited by Vaiktorg

Share this post


Link to post
Share on other sites

Well, BETA 2 worked wonders and better than i thought actually :) Happy bout this!

post-38828-0-01012300-1419732770_thumb.p

Share this post


Link to post
Share on other sites

Cool, I'm glad to hear. Let us know if it happens again.

  • Like 1

Share this post


Link to post
Share on other sites

×