Jump to content
3DCoat Forums
brickyard

Texture seams

Recommended Posts

I've been using 3d Coat for a bit over a month now and find it to be overall a very comfortable program. I have however been dealing with an issue that pops up fairly often. Seams Around the UV

edges. This tends to effect the Normal and the Diffuse in the same way.

FMNtCYSm.png

I did some experimentation and found that it seemed to be caused specifically by having slightly different and overlapping UVs. Unfortunately I'm making game assets and this comes up in a lot of different things. From what I can tell these are just pixels which seem to be only halfway inside the UV shell and amount to pixels I just can't paint on.

So far my solutions have been to place a plane in the scene that contains the entire texture sheet, allowing me to paint out the bad parts. this of course is not accurate because I'm doing each edge separately. There is also smudging the texture in Photoshop. Same problem. What I'm looking for ideally, is more padding controls within 3D Coat, but it tends to only adding the padding after export and it gets the bad part of the texture anyway.

Any insights would be appreciated. Thanks in advance.

post-39401-0-56611300-1433788817_thumb.p

Share this post


Link to post
Share on other sites

From what I can tell the way I need my UVs to be causes the padding in 3DC not to function, at least until the texture is exported, which means what it's exporting will look the same as in the picture. I don't know if this is a bug or just that I've got some setting messed up. I'm hoping to understand the issue better so I can find a workaround.

  • Like 1

Share this post


Link to post
Share on other sites

Try getting them separate into 3dcoat and see what happens.

  • Like 1

Share this post


Link to post
Share on other sites

Any luck?

Share this post


Link to post
Share on other sites

Ok so that seems to be a functional work around. Thank you!

For anyone who stumbles on this same problem: From what I can tell the best way to do this is to use Import Object instead of Import, It will put what is imported in it's own group material. You CAN have multiple versions of the same model in the scene as long as UVs match up and overlap perfectly it doesn't cause this issue. This won't work for complex layered UVs which means setting up a model like this for 3D Coat requires removing that extra geometry.

Also note that in order to use this method you need to enter the UV tab and change the names from default to something else or you can only import textures onto one group.

  • Like 1

Share this post


Link to post
Share on other sites

You are correct , well done.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×