Jump to content
3DCoat Forums
therobin9810

3dcoat really slow, without explanation.

Recommended Posts

So I have been using 3dcoat for about a month now, just really getting into things now. I was working on a prodject trying to make as much detail out of one polygon. I made details in a Hp version and baked it down to a normal map, the Lp version consists of 1 quad polygon (I only paint in 3dcoat, nothing else). The problem now is that when i try to work on the Lp, the painting is really slow, as if it couldnt "think" fast enough it is just really laggy. I tried to paint without the normal and with another version of the model with 6 polygons to form a 3dimensional object, but to no avail.

Btw this does not occur on my other models, or the standard models that comes withthe program. Any help is greatly appreciated! -/- Robin

Share this post


Link to post
Share on other sites

Hi !

Could you share the project ?

Share this post


Link to post
Share on other sites

only a *.mtl ?

 

could you share LP.obj too ?

Share this post


Link to post
Share on other sites

You didn't provide a file containing the geometry.

 

Anyway, if you're experiencing some performance issues when sculpting over extremely low poly models (and a single quad is as low as you can get unless you're sculpting over a triangle), then what I can suggest you is to try this:

 

Turn off retopo snapping and subdivide your retopo group a couple of times with one of the icons that is located at the bottom of the retopo groups panel. Then bake your normals for per-pixel painting, paint your textures on the model and export them with File->Export Objects & Textures. Choose a geo filename and select the textures to export. You can then ignore, or delete the geo file (e.g. myfile.obj and myfile.mtl). Revert to a saved file from before you subdivided your model, go to retopo room again, and either:

- switch to Add/Split tool and then Export the retopo mesh to file (this will be your main geometry you will apply your textures on in your target program)

or:

- select Bake->Retopo->per pixel (no baking), to move your objects to the paint room, then in the paint room select File->Export Objects & Textures, select the geometry filename to write to and deselect all textures. You only want to export the geometry. Then apply the previously exported textures on that geometry in your target program.

Edited by ajz3d

Share this post


Link to post
Share on other sites

You didn't provide a file containing the geometry.

 

Anyway, if you're experiencing some performance issues when sculpting over extremely low poly models (and a single quad is as low as you can get unless you're sculpting over a triangle), then what I can suggest you is to try this:

 

Turn off retopo snapping and subdivide your retopo group a couple of times with one of the icons that is located at the bottom of the retopo groups panel. Then bake your normals for per-pixel painting, paint your textures on the model and export them with File->Export Objects & Textures. Choose a geo filename and select the textures to export. You can then ignore, or delete the geo file (e.g. myfile.obj and myfile.mtl). Revert to a saved file from before you subdivided your model, go to retopo room again, and either:

- switch to Add/Split tool and then Export the retopo mesh to file (this will be your main geometry you will apply your textures on in your target program)

or:

- select Bake->Retopo->per pixel (no baking), to move your objects to the paint room, then in the paint room select File->Export Objects & Textures, select the geometry filename to write to and deselect all textures. You only want to export the geometry. Then apply the previously exported textures on that geometry in your target program.

Thank you for your answer, but the problem is inside the paint tab of 3dcoat. When i paint its really laggy, i wouldnt know on the sculpt or retopo tab, since i only paint in 3dcoat.

I replied with the actual file a minute ago, thank you!

Share this post


Link to post
Share on other sites

Are you testing the version 4.5.09 ?

Is recommended update video drivers. Version 08 and 09 are using Cuda toolkit 6.5 and may fail with older drivers.

Share this post


Link to post
Share on other sites

Hey there,

 

I bet I know why this is lagging, because I have the same thing, I have put up a question in another topic about it.

 

Try minimising the 'Smart Material Preview' window. The little window that shows a preview of what the brush you are using will do. It's a lag king. As soon as you minimise it, it stops refreshing and lagging the viewport.

 

It will however pop back up EVERY TIME you pull out the bucket tool, and maybe some other tool I am unaware of.

 

Hope this helps.

  • Like 1

Share this post


Link to post
Share on other sites

You right

In the upper right corner of preview window there is a pin to maximize/minimize the preview

Use the preview window only to visualizing when you test/create a Smart material

Minimizing at paint stage.

Share this post


Link to post
Share on other sites

Hey there,

 

I bet I know why this is lagging, because I have the same thing, I have put up a question in another topic about it.

 

Try minimising the 'Smart Material Preview' window. The little window that shows a preview of what the brush you are using will do. It's a lag king. As soon as you minimise it, it stops refreshing and lagging the viewport.

 

It will however pop back up EVERY TIME you pull out the bucket tool, and maybe some other tool I am unaware of.

 

Hope this helps.

 

 

Yeah that is most likely the culprit. It's happens here as well since it was implemented into the other tools (for Smart Materials). I almost always minimize the thing when I am done visualizing with it, to paint/fill.

Share this post


Link to post
Share on other sites

So is there a way of permanently turning this feature off? like a setting somewhere I am missing?

 

If there isn't I would recommend adding it as an option. Does anyone know where the suggestion section is?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×